Loading ...
Sorry, an error occurred while loading the content.
 

vim 7.4: pasting is very slow on HP UX machine.

Expand Messages
  • Sarath Addanki
    Hi, I have to use vim on HP-UX machine. Whenever I paste any text with more than one line(or some 60 chars), it completes the operation very slowly. This
    Message 1 of 27 , Jun 28, 2014
      Hi,

      I have to use vim on HP-UX machine. Whenever I paste any text with more than one line(or some 60 chars), it completes the operation very slowly. This problem is making vim un usable. Please assist.

      Following are the details

      machine details:
      HP-UX stlhp107 B.11.31 U ia64 3120353525

      Terminal used is: dtterm

      Attached is the vim installation details.

      Please help to troubleshoot. I'm a long term user of vim. Without vim it's difficult to write code for me.

      Thanks,
      Sarath

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Ben Fritz
      ... Is it faster if you :set paste first before pasting? Make sure to turn it off again after you paste. -- -- You received this message from the vim_use
      Message 2 of 27 , Jun 28, 2014
        On Saturday, June 28, 2014 4:01:39 PM UTC-5, Sarath Addanki wrote:
        > Hi,
        >
        > I have to use vim on HP-UX machine. Whenever I paste any text with more than one line(or some 60 chars), it completes the operation very slowly. This problem is making vim un usable. Please assist.
        >
        > Following are the details
        >
        > machine details:
        > HP-UX stlhp107 B.11.31 U ia64 3120353525
        >
        > Terminal used is: dtterm
        >
        > Attached is the vim installation details.
        >
        > Please help to troubleshoot. I'm a long term user of vim. Without vim it's difficult to write code for me.
        >
        > Thanks,
        > Sarath

        Is it faster if you ":set paste" first before pasting? Make sure to turn it off again after you paste.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Dominique PellĂ©
        ... Is it faster with vim -X ? In your attached file, we do not see the version of vim (first 2 lines of vim --version ). Dominique -- -- You received this
        Message 3 of 27 , Jun 28, 2014
          Sarath Addanki wrote:

          > Hi,
          >
          > I have to use vim on HP-UX machine. Whenever I paste
          > any text with more than one line(or some 60 chars), it
          > completes the operation very slowly. This problem is
          > making vim un usable. Please assist.
          >
          > Following are the details
          >
          > machine details:
          > HP-UX stlhp107 B.11.31 U ia64 3120353525
          >
          > Terminal used is: dtterm
          >
          > Attached is the vim installation details.
          >
          > Please help to troubleshoot. I'm a long term user of vim.
          > Without vim it's difficult to write code for me.


          Is it faster with "vim -X" ?

          In your attached file, we do not see the version of vim
          (first 2 lines of "vim --version").

          Dominique

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • KKde
          ... Ben - I tried and it s still slower. Thanks. Dominique - No it s not faster. Thanks. Version i m using is VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jun
          Message 4 of 27 , Jun 29, 2014
            >
            > Is it faster if you ":set paste" first before pasting? Make sure to turn it off again after you paste.

            Ben - I tried and it's still slower. Thanks.
            Dominique - No it's not faster. Thanks. Version i'm using is
            VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jun 28 2014 14:53:12)
            Compiled by <text removed>

            In my other HP machine it is faster, but the OS version is different(HP-UX hpitan4 B.11.23 U ia64)

            I installed vim from http://hpux.connect.org.uk/hppd/hpux/Editors/vim-7.4/

            I'm very grateful if someone can help me resolve the problem. As I said I cannot live without vim for coding and code navigation.

            are there any Vim users on HP machine here?

            Thanks,
            Sarath

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Gary Johnson
            ... I used to run Vim on HP-UX, but haven t for several years and I no longer have access to an HP-UX machine. I built Vim myself and never had any speed
            Message 5 of 27 , Jun 29, 2014
              On 2014-06-29, KKde wrote:

              > In my other HP machine it is faster, but the OS version is
              > different(HP-UX hpitan4 B.11.23 U ia64)
              >
              > I installed vim from
              > http://hpux.connect.org.uk/hppd/hpux/Editors/vim-7.4/
              >
              > I'm very grateful if someone can help me resolve the problem. As I
              > said I cannot live without vim for coding and code navigation.
              >
              > are there any Vim users on HP machine here?

              I used to run Vim on HP-UX, but haven't for several years and I no
              longer have access to an HP-UX machine. I built Vim myself and
              never had any speed issues. I always ran it in an xterm which I
              also built myself.

              Regards,
              Gary

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Matteo Cavalleri
              ... no patches included? there have been various bugs fixed in the first releases of vim 7.4, so if you re not using the latest version you might try to
              Message 6 of 27 , Jun 30, 2014
                > Dominique - No it's not faster. Thanks. Version i'm using is
                > VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jun 28 2014 14:53:12)
                > Compiled by <text removed>

                no patches included? there have been various bugs fixed in the first releases of vim 7.4, so if you're not using the latest version you might try to compile it from the sources.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Christian Brabandt
                ... There are a couple of things to check first: http://vimhelp.appspot.com/vim_faq.txt.html#faq-2.5 This should give you a hint, if this is a problem with Vim
                Message 7 of 27 , Jun 30, 2014
                  Am 2014-06-30 03:40, schrieb KKde:
                  >>
                  >> Is it faster if you ":set paste" first before pasting? Make sure to
                  >> turn it off again after you paste.
                  >
                  > Ben - I tried and it's still slower. Thanks.
                  > Dominique - No it's not faster. Thanks. Version i'm using is
                  > VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jun 28 2014 14:53:12)
                  > Compiled by <text removed>
                  >
                  > In my other HP machine it is faster, but the OS version is
                  > different(HP-UX hpitan4 B.11.23 U ia64)
                  >
                  > I installed vim from
                  > http://hpux.connect.org.uk/hppd/hpux/Editors/vim-7.4/
                  >
                  > I'm very grateful if someone can help me resolve the problem. As I
                  > said I cannot live without vim for coding and code navigation.
                  >
                  > are there any Vim users on HP machine here?

                  There are a couple of things to check first:
                  http://vimhelp.appspot.com/vim_faq.txt.html#faq-2.5

                  This should give you a hint, if this is a problem with Vim itsself or
                  some
                  plugin or runtime you are using.

                  Regards,
                  Christian

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • Sarath Addanki
                  I tried all the options suggested here. I have understood the problem more clearly now. Problematic Case: 1)Open a remote session to hpux machine via putty.
                  Message 8 of 27 , Jun 30, 2014
                    I tried all the options suggested here. I have understood the problem more clearly now.


                    Problematic Case:
                    1)Open a remote session to hpux machine via putty.
                    2)Open Vim and paste text (that has atleast 3 lines)
                    3)paste operation freezes and text animates slowly.

                    I have tried the following stuff to narrow out the possible issues

                    Case 1:
                    Repeat Step 1.
                    Open vi and paste text. Works perfectly

                    Case 2:
                    Repeat Step 1.
                    Open emacs and paste text. Works perfectly

                    Case 3:
                    Repeat Step 1.
                    Open gVim and paste text. No issues (though gvim startup time is slow)

                    Case 4:
                    Repeat Step 1.
                    Recompile vim with the following options --with-features=huge --enable=gui=no
                    Repeat Step 2 & Step 3. Still slow.

                    Case 5:
                    Repeat Step 1.
                    Open Vim with the following command
                    vim -u NONE -U NONE -N -i NONE -V16

                    Saw the error message:
                    Opening the X display failed. Result is same(slow paste)

                    Case 6:
                    Repeat Step 1.
                    Open Vim the following command
                    vim -X -u NONE -U NONE -N -i NONE -V16

                    Error message in Case 5 disappears. But Result is same(slow paste)

                    Case 7:
                    Repeat Step 1.
                    Open Vim with file containing some text. Copy some 10+ lines in Visual mode and paste. No issues. So, Paste inside editor works.


                    In the above cases, paste means I have copied text outside of putty and pasting into Vim editor which is inside Putty. I'm on Windows 7.

                    pasting from external source seems problem. I don't know how to trouble shoot this problem further.

                    Please help.

                    Thanks,
                    Sarath

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • James Freer
                    ... I use linux and I ve not found gvim or vim slow. I d say switch to a superior OS like linux and use emacs... as somehow you re finding trouble with
                    Message 9 of 27 , Jun 30, 2014
                      On Mon, 30 Jun 2014, Sarath Addanki wrote:

                      > I tried all the options suggested here. I have understood the problem more clearly now.
                      >
                      >
                      > Problematic Case:
                      > 1)Open a remote session to hpux machine via putty.
                      > 2)Open Vim and paste text (that has atleast 3 lines)
                      > 3)paste operation freezes and text animates slowly.
                      >
                      > I have tried the following stuff to narrow out the possible issues
                      >
                      > Case 1:
                      > Repeat Step 1.
                      > Open vi and paste text. Works perfectly
                      >
                      > Case 2:
                      > Repeat Step 1.
                      > Open emacs and paste text. Works perfectly
                      >
                      > Case 3:
                      > Repeat Step 1.
                      > Open gVim and paste text. No issues (though gvim startup time is slow)
                      >
                      > Case 4:
                      > Repeat Step 1.
                      > Recompile vim with the following options --with-features=huge --enable=gui=no
                      > Repeat Step 2 & Step 3. Still slow.
                      >
                      > Case 5:
                      > Repeat Step 1.
                      > Open Vim with the following command
                      > vim -u NONE -U NONE -N -i NONE -V16
                      >
                      > Saw the error message:
                      > Opening the X display failed. Result is same(slow paste)
                      >
                      > Case 6:
                      > Repeat Step 1.
                      > Open Vim the following command
                      > vim -X -u NONE -U NONE -N -i NONE -V16
                      >
                      > Error message in Case 5 disappears. But Result is same(slow paste)
                      >
                      > Case 7:
                      > Repeat Step 1.
                      > Open Vim with file containing some text. Copy some 10+ lines in Visual mode and paste. No issues. So, Paste inside editor works.
                      >
                      >
                      > In the above cases, paste means I have copied text outside of putty and pasting into Vim editor which is inside Putty. I'm on Windows 7.
                      >
                      > pasting from external source seems problem. I don't know how to trouble shoot this problem further.
                      >
                      > Please help.
                      >
                      > Thanks,
                      > Sarath

                      I use linux and I've not found gvim or vim slow. I'd say switch to a superior
                      OS like linux and use emacs... as somehow you're finding trouble with vim/gvim.

                      james

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • Sarath Addanki
                      james, OS selection is not always a choice. In work place you have to adapt to what you get. I request you to not divert this topic. Thanks! -- -- You received
                      Message 10 of 27 , Jun 30, 2014
                        james,

                        OS selection is not always a choice. In work place you have to adapt to what you get. I request you to not divert this topic. Thanks!

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      • Charles Campbell
                        ... What, if anything, does ... show? I m guessing that you re using the middlemouse to paste. Regards, Chip Campbell -- -- You received this message from the
                        Message 11 of 27 , Jun 30, 2014
                          Dominique Pellé wrote:
                          > Sarath Addanki wrote:
                          >
                          >> Hi,
                          >>
                          >> I have to use vim on HP-UX machine. Whenever I paste
                          >> any text with more than one line(or some 60 chars), it
                          >> completes the operation very slowly. This problem is
                          >> making vim un usable. Please assist.
                          >>
                          >> Following are the details
                          >>
                          >> machine details:
                          >> HP-UX stlhp107 B.11.31 U ia64 3120353525
                          >>
                          >> Terminal used is: dtterm
                          >>
                          >> Attached is the vim installation details.
                          >>
                          >> Please help to troubleshoot. I'm a long term user of vim.
                          >> Without vim it's difficult to write code for me.
                          >
                          > Is it faster with "vim -X" ?
                          >
                          > In your attached file, we do not see the version of vim
                          > (first 2 lines of "vim --version").
                          >
                          What, if anything, does

                          :imap <middlemouse>

                          show? I'm guessing that you're using the middlemouse to paste.

                          Regards,
                          Chip Campbell

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/d/optout.
                        • Sarath Addanki
                          ... the above ex command returns No mapping found . I m using right click to paste into Vim via PuTTY. Thanks -- -- You received this message from the
                          Message 12 of 27 , Jun 30, 2014
                            >
                            > What, if anything, does
                            >
                            >
                            >
                            > :imap <middlemouse>
                            >
                            >
                            >
                            > show? I'm guessing that you're using the middlemouse to paste.
                            >
                            >
                            >
                            > Regards,
                            >
                            > Chip Campbell


                            the above ex command returns "No mapping found".
                            I'm using right click to paste into Vim via PuTTY.

                            Thanks

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/d/optout.
                          • John Beckett
                            ... Has anyone pointed out what is happening? On paste (right click), PuTTY sends each character from the clipboard over the SSH session to the server where
                            Message 13 of 27 , Jun 30, 2014
                              Sarath Addanki wrote:
                              > I'm using right click to paste into Vim via PuTTY.

                              Has anyone pointed out what is happening? On paste (right
                              click), PuTTY sends each character from the clipboard over the
                              SSH session to the server where Vim is running, as if you had
                              typed the character. I do not know the details, but PuTTY must
                              somehow throttle sending in order to avoid overrunning the input
                              buffer on the server. My guess is that slow pasting is an
                              unavoidable consequence. I don't need to use PuTTY much, but in
                              the past I have found it easier to use a separate command prompt
                              window to upload a file (pscpy) with whatever text I needed,
                              then read it into Vim (:r filename.txt).

                              John


                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/d/optout.
                            • Gary Johnson
                              ... That s a good point, John, but Sarath did the same pasting into vi (vim tiny?) and emacs and neither was as slow as vim, so it s not just PuTTY. I wonder
                              Message 14 of 27 , Jun 30, 2014
                                On 2014-07-01, John Beckett wrote:
                                > Sarath Addanki wrote:
                                > > I'm using right click to paste into Vim via PuTTY.
                                >
                                > Has anyone pointed out what is happening? On paste (right
                                > click), PuTTY sends each character from the clipboard over the
                                > SSH session to the server where Vim is running, as if you had
                                > typed the character. I do not know the details, but PuTTY must
                                > somehow throttle sending in order to avoid overrunning the input
                                > buffer on the server. My guess is that slow pasting is an
                                > unavoidable consequence.

                                That's a good point, John, but Sarath did the same pasting into vi
                                (vim tiny?) and emacs and neither was as slow as vim, so it's not
                                just PuTTY.

                                I wonder if the problem would be there using telnet instead of ssh
                                and if so, if Wireshark would reveal anything interesting.

                                > I don't need to use PuTTY much, but in the past I have found it
                                > easier to use a separate command prompt window to upload a file
                                > (pscpy) with whatever text I needed, then read it into Vim (:r
                                > filename.txt).

                                I use PuTTY on Windows 7 over ssh to vim on Linux all the time and
                                most of the time I don't notice any speed issues at all, including
                                when I paste.

                                Regards,
                                Gary

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/d/optout.
                              • Christian Brabandt
                                ... Since you already recompiled your Vim, would it be hard for you to profile it? That might give us a clue, what is going on. Best, Christian -- -- You
                                Message 15 of 27 , Jun 30, 2014
                                  Am 2014-06-30 19:40, schrieb Sarath Addanki:
                                  > I tried all the options suggested here. I have understood the problem
                                  > more clearly now.
                                  >
                                  >
                                  > Problematic Case:
                                  > 1)Open a remote session to hpux machine via putty.
                                  > 2)Open Vim and paste text (that has atleast 3 lines)
                                  > 3)paste operation freezes and text animates slowly.
                                  >
                                  > I have tried the following stuff to narrow out the possible issues
                                  >
                                  > Case 1:
                                  > Repeat Step 1.
                                  > Open vi and paste text. Works perfectly
                                  >
                                  > Case 2:
                                  > Repeat Step 1.
                                  > Open emacs and paste text. Works perfectly
                                  >
                                  > Case 3:
                                  > Repeat Step 1.
                                  > Open gVim and paste text. No issues (though gvim startup time is slow)
                                  >
                                  > Case 4:
                                  > Repeat Step 1.
                                  > Recompile vim with the following options --with-features=huge
                                  > --enable=gui=no
                                  > Repeat Step 2 & Step 3. Still slow.
                                  >
                                  > Case 5:
                                  > Repeat Step 1.
                                  > Open Vim with the following command
                                  > vim -u NONE -U NONE -N -i NONE -V16
                                  >
                                  > Saw the error message:
                                  > Opening the X display failed. Result is same(slow paste)
                                  >
                                  > Case 6:
                                  > Repeat Step 1.
                                  > Open Vim the following command
                                  > vim -X -u NONE -U NONE -N -i NONE -V16
                                  >
                                  > Error message in Case 5 disappears. But Result is same(slow paste)
                                  >
                                  > Case 7:
                                  > Repeat Step 1.
                                  > Open Vim with file containing some text. Copy some 10+ lines in Visual
                                  > mode and paste. No issues. So, Paste inside editor works.
                                  >
                                  >
                                  > In the above cases, paste means I have copied text outside of putty
                                  > and pasting into Vim editor which is inside Putty. I'm on Windows 7.
                                  >
                                  > pasting from external source seems problem. I don't know how to
                                  > trouble shoot this problem further.

                                  Since you already recompiled your Vim, would it be hard for you to
                                  profile it?
                                  That might give us a clue, what is going on.

                                  Best,
                                  Christian

                                  --
                                  --
                                  You received this message from the "vim_use" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                  For more options, visit https://groups.google.com/d/optout.
                                • KKde
                                  ... What flags I should use for profiling? Regards, Sarath -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below
                                  Message 16 of 27 , Jul 1 8:09 AM
                                    On Tuesday, July 1, 2014 1:36:51 AM UTC-5, Christian Brabandt wrote:
                                    > Am 2014-06-30 19:40, schrieb Sarath Addanki:
                                    >
                                    > > I tried all the options suggested here. I have understood the problem
                                    >
                                    > > more clearly now.
                                    >
                                    > >
                                    >
                                    > >
                                    >
                                    > > Problematic Case:
                                    >
                                    > > 1)Open a remote session to hpux machine via putty.
                                    >
                                    > > 2)Open Vim and paste text (that has atleast 3 lines)
                                    >
                                    > > 3)paste operation freezes and text animates slowly.
                                    >
                                    > >
                                    >
                                    > > I have tried the following stuff to narrow out the possible issues
                                    >
                                    > >
                                    >
                                    > > Case 1:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open vi and paste text. Works perfectly
                                    >
                                    > >
                                    >
                                    > > Case 2:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open emacs and paste text. Works perfectly
                                    >
                                    > >
                                    >
                                    > > Case 3:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open gVim and paste text. No issues (though gvim startup time is slow)
                                    >
                                    > >
                                    >
                                    > > Case 4:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Recompile vim with the following options --with-features=huge
                                    >
                                    > > --enable=gui=no
                                    >
                                    > > Repeat Step 2 & Step 3. Still slow.
                                    >
                                    > >
                                    >
                                    > > Case 5:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open Vim with the following command
                                    >
                                    > > vim -u NONE -U NONE -N -i NONE -V16
                                    >
                                    > >
                                    >
                                    > > Saw the error message:
                                    >
                                    > > Opening the X display failed. Result is same(slow paste)
                                    >
                                    > >
                                    >
                                    > > Case 6:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open Vim the following command
                                    >
                                    > > vim -X -u NONE -U NONE -N -i NONE -V16
                                    >
                                    > >
                                    >
                                    > > Error message in Case 5 disappears. But Result is same(slow paste)
                                    >
                                    > >
                                    >
                                    > > Case 7:
                                    >
                                    > > Repeat Step 1.
                                    >
                                    > > Open Vim with file containing some text. Copy some 10+ lines in Visual
                                    >
                                    > > mode and paste. No issues. So, Paste inside editor works.
                                    >
                                    > >
                                    >
                                    > >
                                    >
                                    > > In the above cases, paste means I have copied text outside of putty
                                    >
                                    > > and pasting into Vim editor which is inside Putty. I'm on Windows 7.
                                    >
                                    > >
                                    >
                                    > > pasting from external source seems problem. I don't know how to
                                    >
                                    > > trouble shoot this problem further.
                                    >
                                    >
                                    >
                                    > Since you already recompiled your Vim, would it be hard for you to
                                    >
                                    > profile it?
                                    >
                                    > That might give us a clue, what is going on.
                                    >
                                    >
                                    >
                                    > Best,
                                    >
                                    > Christian

                                    What flags I should use for profiling?

                                    Regards,
                                    Sarath

                                    --
                                    --
                                    You received this message from the "vim_use" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                    For more options, visit https://groups.google.com/d/optout.
                                  • Charles Campbell
                                    ... Then you need to look for ... Its not that I expect that you have a mapping, but if you did, then you d be getting a delay as vim waits to see if there s
                                    Message 17 of 27 , Jul 1 8:15 AM
                                      Sarath Addanki wrote:
                                      >> What, if anything, does
                                      >>
                                      >>
                                      >>
                                      >> :imap <middlemouse>
                                      >>
                                      >>
                                      >>
                                      >> show? I'm guessing that you're using the middlemouse to paste.
                                      >>
                                      >>
                                      >>
                                      >> Regards,
                                      >>
                                      >> Chip Campbell
                                      >
                                      > the above ex command returns "No mapping found".
                                      > I'm using right click to paste into Vim via PuTTY.
                                      >
                                      >
                                      Then you need to look for

                                      :imap <rightmouse>

                                      Its not that I expect that you have a mapping, but if you did, then
                                      you'd be getting a delay as vim waits to see if there's more characters
                                      coming from you.

                                      Regards,
                                      Chip

                                      --
                                      --
                                      You received this message from the "vim_use" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php

                                      ---
                                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                      For more options, visit https://groups.google.com/d/optout.
                                    • Christian Brabandt
                                      Hi ... Seriously I do not know. I would start with uncommenting the PROFILE_LIBS variable in the Makefile and see how that works... Last time I did this, I
                                      Message 18 of 27 , Jul 1 11:23 AM
                                        Hi

                                        On Di, 01 Jul 2014, KKde wrote:

                                        > >
                                        > > Since you already recompiled your Vim, would it be hard for you to
                                        > > profile it?
                                        > >
                                        > > That might give us a clue, what is going on.
                                        >
                                        > What flags I should use for profiling?

                                        Seriously I do not know. I would start with uncommenting the
                                        PROFILE_LIBS variable in the Makefile and see how that works...

                                        Last time I did this, I think, I used the
                                        http://www.thegeekstuff.com/2012/08/gprof-tutorial/ to profile Vim.

                                        e.g. export PROFILE_LIBS = -pg, compile and then
                                        run a slow operation with the new compiled vim and use gprof gmon.out
                                        and from there look at the most obvious slow down function calls.

                                        On Windows, I would just compile a debug version and use ltprof.

                                        Best,
                                        Christian
                                        --
                                        Wie man sein Kind nicht nennen sollte:
                                        Karl Ender

                                        --
                                        --
                                        You received this message from the "vim_use" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php

                                        ---
                                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                        For more options, visit https://groups.google.com/d/optout.
                                      • Sarath Addanki
                                        ... Hi, Below are the profiling stats on two machines A & B. On machine B it is working fine. Both machines are HPUX only %Time Seconds Cumsecs #Calls
                                        Message 19 of 27 , Aug 5, 2014
                                          On Tuesday, 1 July 2014 14:23:22 UTC-4, Christian Brabandt wrote:
                                          > Hi
                                          >
                                          >
                                          >
                                          > On Di, 01 Jul 2014, KKde wrote:
                                          >
                                          >
                                          >
                                          > > >
                                          >
                                          > > > Since you already recompiled your Vim, would it be hard for you to
                                          >
                                          > > > profile it?
                                          >
                                          > > >
                                          >
                                          > > > That might give us a clue, what is going on.
                                          >
                                          > >
                                          >
                                          > > What flags I should use for profiling?
                                          >
                                          >
                                          >
                                          > Seriously I do not know. I would start with uncommenting the
                                          >
                                          > PROFILE_LIBS variable in the Makefile and see how that works...
                                          >
                                          >
                                          >
                                          > Last time I did this, I think, I used the
                                          >
                                          > http://www.thegeekstuff.com/2012/08/gprof-tutorial/ to profile Vim.
                                          >
                                          >
                                          >
                                          > e.g. export PROFILE_LIBS = -pg, compile and then
                                          >
                                          > run a slow operation with the new compiled vim and use gprof gmon.out
                                          >
                                          > and from there look at the most obvious slow down function calls.
                                          >
                                          >
                                          >
                                          > On Windows, I would just compile a debug version and use ltprof.
                                          >
                                          >
                                          >
                                          > Best,
                                          >
                                          > Christian
                                          >
                                          > --
                                          >
                                          > Wie man sein Kind nicht nennen sollte:
                                          >
                                          > Karl Ender

                                          Hi,

                                          Below are the profiling stats on two machines A & B. On machine B it is working fine. Both machines are HPUX only

                                          %Time Seconds Cumsecs #Calls msec/call Name

                                          MACHINE A

                                          27.8 0.05 0.05 1490 0.03 do_cmdline
                                          5.6 0.01 0.06 77666 0.00 hash_lookup
                                          5.6 0.01 0.07 24190 0.00 find_special_key
                                          5.6 0.01 0.08 11503 0.00 separate_nextcmd
                                          5.6 0.01 0.09 396 0.03 do_map
                                          0.0 0.00 0.09 463530 0.00 skipwhite
                                          0.0 0.00 0.09 348653 0.00 vim_strchr
                                          0.0 0.00 0.09 209196 0.00 vim_free
                                          0.0 0.00 0.09 162231 0.00 vim_isIDc
                                          0.0 0.00 0.09 124661 0.00 getline_equal



                                          MACHINE B
                                          %Time Seconds Cumsecs #Calls msec/call Name

                                          15.4 0.02 0.02 442611 0.00 skipwhite
                                          7.7 0.01 0.03 77397 0.00 hash_lookup
                                          7.7 0.01 0.04 13131 0.00 vim_str2nr
                                          7.7 0.01 0.05 4588 0.00 dbg_check_skipped
                                          0.0 0.00 0.05 253469 0.00 vim_strchr
                                          0.0 0.00 0.05 183319 0.00 vim_free
                                          0.0 0.00 0.05 152910 0.00 vim_isIDc
                                          0.0 0.00 0.05 116353 0.00 getline_equal
                                          0.0 0.00 0.05 69606 0.00 hash_find
                                          0.0 0.00 0.05 67704 0.00 dict_unref

                                          do_cmdline, find_special_key, separate_nextcmd, do_map functions are taking long time.

                                          Can anyone tell why these functions are taking long time?

                                          Regards,
                                          Sarath

                                          --
                                          --
                                          You received this message from the "vim_use" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php

                                          ---
                                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                          For more options, visit https://groups.google.com/d/optout.
                                        • Christian Brabandt
                                          ... Were you running any special commands or plugins? Best, Christian -- Wie man sein Kind nicht nennen sollte: Lisa Bonn -- -- You received this message from
                                          Message 20 of 27 , Aug 6, 2014
                                            On Di, 05 Aug 2014, Sarath Addanki wrote:

                                            > On Tuesday, 1 July 2014 14:23:22 UTC-4, Christian Brabandt wrote:
                                            > > On Di, 01 Jul 2014, KKde wrote:
                                            > > > > Since you already recompiled your Vim, would it be hard for you to
                                            > >
                                            > > > > profile it?
                                            > >
                                            > > > >
                                            > >
                                            > > > > That might give us a clue, what is going on.
                                            > >
                                            > > >
                                            > >
                                            > > > What flags I should use for profiling?
                                            > >
                                            > >
                                            > >
                                            > > Seriously I do not know. I would start with uncommenting the
                                            > >
                                            > > PROFILE_LIBS variable in the Makefile and see how that works...
                                            > >
                                            > >
                                            > >
                                            > > Last time I did this, I think, I used the
                                            > >
                                            > > http://www.thegeekstuff.com/2012/08/gprof-tutorial/ to profile Vim.
                                            > >
                                            > >
                                            > >
                                            > > e.g. export PROFILE_LIBS = -pg, compile and then
                                            > >
                                            > > run a slow operation with the new compiled vim and use gprof gmon.out
                                            > >
                                            > > and from there look at the most obvious slow down function calls.
                                            > >
                                            > >
                                            > >
                                            > > On Windows, I would just compile a debug version and use ltprof.
                                            >
                                            > Below are the profiling stats on two machines A & B. On machine B it is working fine. Both machines are HPUX only
                                            >
                                            > %Time Seconds Cumsecs #Calls msec/call Name
                                            >
                                            > MACHINE A
                                            >
                                            > 27.8 0.05 0.05 1490 0.03 do_cmdline
                                            > 5.6 0.01 0.06 77666 0.00 hash_lookup
                                            > 5.6 0.01 0.07 24190 0.00 find_special_key
                                            > 5.6 0.01 0.08 11503 0.00 separate_nextcmd
                                            > 5.6 0.01 0.09 396 0.03 do_map
                                            > 0.0 0.00 0.09 463530 0.00 skipwhite
                                            > 0.0 0.00 0.09 348653 0.00 vim_strchr
                                            > 0.0 0.00 0.09 209196 0.00 vim_free
                                            > 0.0 0.00 0.09 162231 0.00 vim_isIDc
                                            > 0.0 0.00 0.09 124661 0.00 getline_equal
                                            >
                                            >
                                            >
                                            > MACHINE B
                                            > %Time Seconds Cumsecs #Calls msec/call Name
                                            >
                                            > 15.4 0.02 0.02 442611 0.00 skipwhite
                                            > 7.7 0.01 0.03 77397 0.00 hash_lookup
                                            > 7.7 0.01 0.04 13131 0.00 vim_str2nr
                                            > 7.7 0.01 0.05 4588 0.00 dbg_check_skipped
                                            > 0.0 0.00 0.05 253469 0.00 vim_strchr
                                            > 0.0 0.00 0.05 183319 0.00 vim_free
                                            > 0.0 0.00 0.05 152910 0.00 vim_isIDc
                                            > 0.0 0.00 0.05 116353 0.00 getline_equal
                                            > 0.0 0.00 0.05 69606 0.00 hash_find
                                            > 0.0 0.00 0.05 67704 0.00 dict_unref
                                            >
                                            > do_cmdline, find_special_key, separate_nextcmd, do_map functions are taking long time.
                                            >
                                            > Can anyone tell why these functions are taking long time?

                                            Were you running any special commands or plugins?

                                            Best,
                                            Christian
                                            --
                                            Wie man sein Kind nicht nennen sollte:
                                            Lisa Bonn

                                            --
                                            --
                                            You received this message from the "vim_use" maillist.
                                            Do not top-post! Type your reply below the text you are replying to.
                                            For more information, visit http://www.vim.org/maillist.php

                                            ---
                                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                            For more options, visit https://groups.google.com/d/optout.
                                          • Charles Campbell
                                            Hello: May I suggest that you try the usual sort of thing to avoid entanglements with plugins and settings: vim -u NONE --noplugins ... then set up insert mode
                                            Message 21 of 27 , Aug 6, 2014
                                              Hello:

                                              May I suggest that you try the usual sort of thing to avoid
                                              entanglements with plugins and settings:

                                              vim -u NONE --noplugins
                                              :set nocp


                                              then set up insert mode and try pasting text.

                                              Regards,
                                              Chip Campbell

                                              --
                                              --
                                              You received this message from the "vim_use" maillist.
                                              Do not top-post! Type your reply below the text you are replying to.
                                              For more information, visit http://www.vim.org/maillist.php

                                              ---
                                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                              For more options, visit https://groups.google.com/d/optout.
                                            • Sarath Addanki
                                              ... I ran like you mentioned, below is the profiling stats. eval_init is taking time. %Time Seconds Cumsecs #Calls msec/call Name 100.0 0.01 0.01
                                              Message 22 of 27 , Aug 6, 2014
                                                On Wednesday, August 6, 2014 11:37:44 AM UTC-4, Charles Campbell wrote:
                                                > Hello:
                                                >
                                                >
                                                >
                                                > May I suggest that you try the usual sort of thing to avoid
                                                >
                                                > entanglements with plugins and settings:
                                                >
                                                >
                                                >
                                                > vim -u NONE --noplugins
                                                >
                                                > :set nocp
                                                >
                                                >
                                                >
                                                >
                                                >
                                                > then set up insert mode and try pasting text.
                                                >
                                                >
                                                >
                                                > Regards,
                                                >
                                                > Chip

                                                I ran like you mentioned, below is the profiling stats. eval_init is taking time.

                                                %Time Seconds Cumsecs #Calls msec/call Name

                                                100.0 0.01 0.01 1 10.00 eval_init
                                                0.0 0.00 0.01 7850 0.00 windgoto
                                                0.0 0.00 0.01 7829 0.00 out_char
                                                0.0 0.00 0.01 7824 0.00 out_flush_check
                                                0.0 0.00 0.01 6611 0.00 ptr2cells
                                                0.0 0.00 0.01 6600 0.00 win_lbr_chartabsize
                                                0.0 0.00 0.01 2648 0.00 vim_islower
                                                0.0 0.00 0.01 2098 0.00 vim_isupper
                                                0.0 0.00 0.01 1759 0.00 vim_strchr
                                                0.0 0.00 0.01 1365 0.00 netbeans_filedesc

                                                --
                                                --
                                                You received this message from the "vim_use" maillist.
                                                Do not top-post! Type your reply below the text you are replying to.
                                                For more information, visit http://www.vim.org/maillist.php

                                                ---
                                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                For more options, visit https://groups.google.com/d/optout.
                                              • Charles Campbell
                                                ... Well, eval_init() appears to do dictionary and variable stuff. So, I wonder if removing $HOME/.viminfo would help (perhaps you could move it to viminfo
                                                Message 23 of 27 , Aug 6, 2014
                                                  Sarath Addanki wrote:
                                                  > On Wednesday, August 6, 2014 11:37:44 AM UTC-4, Charles Campbell wrote:
                                                  >> Hello:
                                                  >>
                                                  >>
                                                  >>
                                                  >> May I suggest that you try the usual sort of thing to avoid
                                                  >>
                                                  >> entanglements with plugins and settings:
                                                  >>
                                                  >>
                                                  >>
                                                  >> vim -u NONE --noplugins
                                                  >>
                                                  >> :set nocp
                                                  >>
                                                  >>
                                                  >>
                                                  >>
                                                  >>
                                                  >> then set up insert mode and try pasting text.
                                                  >>
                                                  >>
                                                  >>
                                                  >> Regards,
                                                  >>
                                                  >> Chip
                                                  > I ran like you mentioned, below is the profiling stats. eval_init is taking time.
                                                  >
                                                  > %Time Seconds Cumsecs #Calls msec/call Name
                                                  >
                                                  > 100.0 0.01 0.01 1 10.00 eval_init
                                                  > 0.0 0.00 0.01 7850 0.00 windgoto
                                                  > 0.0 0.00 0.01 7829 0.00 out_char
                                                  > 0.0 0.00 0.01 7824 0.00 out_flush_check
                                                  > 0.0 0.00 0.01 6611 0.00 ptr2cells
                                                  > 0.0 0.00 0.01 6600 0.00 win_lbr_chartabsize
                                                  > 0.0 0.00 0.01 2648 0.00 vim_islower
                                                  > 0.0 0.00 0.01 2098 0.00 vim_isupper
                                                  > 0.0 0.00 0.01 1759 0.00 vim_strchr
                                                  > 0.0 0.00 0.01 1365 0.00 netbeans_filedesc
                                                  >
                                                  Well, eval_init() appears to do dictionary and variable stuff. So, I
                                                  wonder if removing $HOME/.viminfo would help (perhaps you could move it
                                                  to viminfo instead of .viminfo if you really want it instead).
                                                  Then use vim -u NONE --noplugins and try pasting. Does the vim take
                                                  awhile to start up? ie. is vim -u NONE --noplugins -X noticeably
                                                  faster at startup? (that won't let you paste using X11, though).

                                                  Chip Campbell

                                                  --
                                                  --
                                                  You received this message from the "vim_use" maillist.
                                                  Do not top-post! Type your reply below the text you are replying to.
                                                  For more information, visit http://www.vim.org/maillist.php

                                                  ---
                                                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                  For more options, visit https://groups.google.com/d/optout.
                                                • Sarath Addanki
                                                  ... removed .viminfo. strangely, profiling stats are normal. Also,note that vim doesn t take time to startup. I guess the problem is something with hpux OS or
                                                  Message 24 of 27 , Aug 6, 2014
                                                    >
                                                    > Well, eval_init() appears to do dictionary and variable stuff. So, I
                                                    >
                                                    > wonder if removing $HOME/.viminfo would help (perhaps you could move it
                                                    >
                                                    > to viminfo instead of .viminfo if you really want it instead).
                                                    >
                                                    > Then use vim -u NONE --noplugins and try pasting. Does the vim take
                                                    >
                                                    > awhile to start up? ie. is vim -u NONE --noplugins -X noticeably
                                                    >
                                                    > faster at startup? (that won't let you paste using X11, though).
                                                    >
                                                    >
                                                    >
                                                    > Chip Campbell

                                                    removed .viminfo. strangely, profiling stats are normal. Also,note that vim doesn't take time to startup. I guess the problem is something with hpux OS or X11 libraries stuff.

                                                    %Time Seconds Cumsecs #Calls msec/call Name

                                                    0.0 0.00 0.00 7821 0.00 out_char
                                                    0.0 0.00 0.00 7821 0.00 windgoto
                                                    0.0 0.00 0.00 7817 0.00 out_flush_check
                                                    0.0 0.00 0.00 6602 0.00 ptr2cells
                                                    0.0 0.00 0.00 6600 0.00 win_lbr_chartabsize
                                                    0.0 0.00 0.00 1628 0.00 vim_islower
                                                    0.0 0.00 0.00 1573 0.00 vim_strchr
                                                    0.0 0.00 0.00 1312 0.00 netbeans_filedesc
                                                    0.0 0.00 0.00 1310 0.00 vim_isupper
                                                    0.0 0.00 0.00 1289 0.00 mch_breakcheck
                                                    0.0 0.00 0.00 1289 0.00 ui_breakcheck
                                                    0.0 0.00 0.00 1269 0.00 get_real_state
                                                    0.0 0.00 0.00 1226 0.00 check_termcode
                                                    0.0 0.00 0.00 881 0.00 vim_free
                                                    0.0 0.00 0.00 616 0.00 del_typebuf
                                                    0.0 0.00 0.00 616 0.00 vgetc

                                                    Thanks

                                                    --
                                                    --
                                                    You received this message from the "vim_use" maillist.
                                                    Do not top-post! Type your reply below the text you are replying to.
                                                    For more information, visit http://www.vim.org/maillist.php

                                                    ---
                                                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                    For more options, visit https://groups.google.com/d/optout.
                                                  • Charles Campbell
                                                    ... So, if I understand you correctly, removing .viminfo made your pasting work normally? .viminfo is created by vim and lets it remember some stuff between
                                                    Message 25 of 27 , Aug 6, 2014
                                                      Sarath Addanki wrote:
                                                      >> Well, eval_init() appears to do dictionary and variable stuff. So, I
                                                      >>
                                                      >> wonder if removing $HOME/.viminfo would help (perhaps you could move it
                                                      >>
                                                      >> to viminfo instead of .viminfo if you really want it instead).
                                                      >>
                                                      >> Then use vim -u NONE --noplugins and try pasting. Does the vim take
                                                      >>
                                                      >> awhile to start up? ie. is vim -u NONE --noplugins -X noticeably
                                                      >>
                                                      >> faster at startup? (that won't let you paste using X11, though).
                                                      >>
                                                      >>
                                                      >>
                                                      >> Chip Campbell
                                                      > removed .viminfo. strangely, profiling stats are normal. Also,note that vim doesn't take time to startup. I guess the problem is something with hpux OS or X11 libraries stuff.
                                                      >
                                                      > %Time Seconds Cumsecs #Calls msec/call Name
                                                      >
                                                      > 0.0 0.00 0.00 7821 0.00 out_char
                                                      > 0.0 0.00 0.00 7821 0.00 windgoto
                                                      > 0.0 0.00 0.00 7817 0.00 out_flush_check
                                                      > 0.0 0.00 0.00 6602 0.00 ptr2cells
                                                      > 0.0 0.00 0.00 6600 0.00 win_lbr_chartabsize
                                                      > 0.0 0.00 0.00 1628 0.00 vim_islower
                                                      > 0.0 0.00 0.00 1573 0.00 vim_strchr
                                                      > 0.0 0.00 0.00 1312 0.00 netbeans_filedesc
                                                      > 0.0 0.00 0.00 1310 0.00 vim_isupper
                                                      > 0.0 0.00 0.00 1289 0.00 mch_breakcheck
                                                      > 0.0 0.00 0.00 1289 0.00 ui_breakcheck
                                                      > 0.0 0.00 0.00 1269 0.00 get_real_state
                                                      > 0.0 0.00 0.00 1226 0.00 check_termcode
                                                      > 0.0 0.00 0.00 881 0.00 vim_free
                                                      > 0.0 0.00 0.00 616 0.00 del_typebuf
                                                      > 0.0 0.00 0.00 616 0.00 vgetc
                                                      >
                                                      > Thanks
                                                      >
                                                      So, if I understand you correctly, removing .viminfo made your pasting
                                                      work normally? .viminfo is created by vim and lets it remember some
                                                      stuff between vim sessions. Read :help viminfo for more.

                                                      Regards,
                                                      Chip

                                                      --
                                                      --
                                                      You received this message from the "vim_use" maillist.
                                                      Do not top-post! Type your reply below the text you are replying to.
                                                      For more information, visit http://www.vim.org/maillist.php

                                                      ---
                                                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                      For more options, visit https://groups.google.com/d/optout.
                                                    • Sarath Addanki
                                                      ... Sorry, that I didn t explained clearly. removing .viminfo doesn t show any strange in profiling stats. But the paste issue still persists Regards, Sarath
                                                      Message 26 of 27 , Aug 6, 2014
                                                        On Wednesday, 6 August 2014 12:48:22 UTC-4, Charles Campbell wrote:
                                                        > Sarath Addanki wrote:
                                                        >
                                                        > >> Well, eval_init() appears to do dictionary and variable stuff. So, I
                                                        >
                                                        > >>
                                                        >
                                                        > >> wonder if removing $HOME/.viminfo would help (perhaps you could move it
                                                        >
                                                        > >>
                                                        >
                                                        > >> to viminfo instead of .viminfo if you really want it instead).
                                                        >
                                                        > >>
                                                        >
                                                        > >> Then use vim -u NONE --noplugins and try pasting. Does the vim take
                                                        >
                                                        > >>
                                                        >
                                                        > >> awhile to start up? ie. is vim -u NONE --noplugins -X noticeably
                                                        >
                                                        > >>
                                                        >
                                                        > >> faster at startup? (that won't let you paste using X11, though).
                                                        >
                                                        > >>
                                                        >
                                                        > >>
                                                        >
                                                        > >>
                                                        >
                                                        > >> Chip Campbell
                                                        >
                                                        > > removed .viminfo. strangely, profiling stats are normal. Also,note that vim doesn't take time to startup. I guess the problem is something with hpux OS or X11 libraries stuff.
                                                        >
                                                        > >
                                                        >
                                                        > > %Time Seconds Cumsecs #Calls msec/call Name
                                                        >
                                                        > >
                                                        >
                                                        > > 0.0 0.00 0.00 7821 0.00 out_char
                                                        >
                                                        > > 0.0 0.00 0.00 7821 0.00 windgoto
                                                        >
                                                        > > 0.0 0.00 0.00 7817 0.00 out_flush_check
                                                        >
                                                        > > 0.0 0.00 0.00 6602 0.00 ptr2cells
                                                        >
                                                        > > 0.0 0.00 0.00 6600 0.00 win_lbr_chartabsize
                                                        >
                                                        > > 0.0 0.00 0.00 1628 0.00 vim_islower
                                                        >
                                                        > > 0.0 0.00 0.00 1573 0.00 vim_strchr
                                                        >
                                                        > > 0.0 0.00 0.00 1312 0.00 netbeans_filedesc
                                                        >
                                                        > > 0.0 0.00 0.00 1310 0.00 vim_isupper
                                                        >
                                                        > > 0.0 0.00 0.00 1289 0.00 mch_breakcheck
                                                        >
                                                        > > 0.0 0.00 0.00 1289 0.00 ui_breakcheck
                                                        >
                                                        > > 0.0 0.00 0.00 1269 0.00 get_real_state
                                                        >
                                                        > > 0.0 0.00 0.00 1226 0.00 check_termcode
                                                        >
                                                        > > 0.0 0.00 0.00 881 0.00 vim_free
                                                        >
                                                        > > 0.0 0.00 0.00 616 0.00 del_typebuf
                                                        >
                                                        > > 0.0 0.00 0.00 616 0.00 vgetc
                                                        >
                                                        > >
                                                        >
                                                        > > Thanks
                                                        >
                                                        > >
                                                        >
                                                        > So, if I understand you correctly, removing .viminfo made your pasting
                                                        >
                                                        > work normally? .viminfo is created by vim and lets it remember some
                                                        >
                                                        > stuff between vim sessions. Read :help viminfo for more.
                                                        >
                                                        >
                                                        >
                                                        > Regards,
                                                        >
                                                        > Chip

                                                        Sorry, that I didn't explained clearly. removing .viminfo doesn't show any strange in profiling stats. But the paste issue still persists

                                                        Regards,
                                                        Sarath

                                                        --
                                                        --
                                                        You received this message from the "vim_use" maillist.
                                                        Do not top-post! Type your reply below the text you are replying to.
                                                        For more information, visit http://www.vim.org/maillist.php

                                                        ---
                                                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                        For more options, visit https://groups.google.com/d/optout.
                                                      • Sarath Addanki
                                                        Hi, Can anyone provide help on this? I m not getting why paste issue is with vim editor only. rest other editors like vi, emacs doesn t have this issue.
                                                        Message 27 of 27 , Aug 11, 2014
                                                          Hi,

                                                          Can anyone provide help on this?

                                                          I'm not getting why paste issue is with vim editor only. rest other editors like vi, emacs doesn't have this issue.

                                                          profiling doesn't show any time consuming calls.

                                                          Thanks

                                                          --
                                                          --
                                                          You received this message from the "vim_use" maillist.
                                                          Do not top-post! Type your reply below the text you are replying to.
                                                          For more information, visit http://www.vim.org/maillist.php

                                                          ---
                                                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                          For more options, visit https://groups.google.com/d/optout.
                                                        Your message has been successfully submitted and would be delivered to recipients shortly.