Loading ...
Sorry, an error occurred while loading the content.
 

mapping M-right/left to switch tabs

Expand Messages
  • Maciej Dziardziel
    I would like to use M-right/left to move between tabs - without leaving the mode I have set in the tab. ... works in normal mode. For insert mode I could use
    Message 1 of 4 , Jun 17, 2014
      I would like to use M-right/left to move between tabs
      - without leaving the mode I have set in the tab.

      :map <M-Right> :tabnext<CR>

      works in normal mode. For insert mode I could use

      :imap <M-Right> <ESC>:tabnext<CR>

      but then when I'll come back to the tab I was,
      I have to set insert mode again.

      Is there a way to keep mode in the tab?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Ben Fritz
      ... Switch tabs differently. This feels a little hackish, but it works in the quick testing I did. The cleaner mappings won t work because changing
      Message 2 of 4 , Jun 17, 2014
        On Tuesday, June 17, 2014 6:23:26 AM UTC-5, Maciej Dziardziel wrote:
        > I would like to use M-right/left to move between tabs
        > - without leaving the mode I have set in the tab.
        >
        > :map <M-Right> :tabnext<CR>
        >
        > works in normal mode. For insert mode I could use
        >
        > :imap <M-Right> <ESC>:tabnext<CR>
        >
        > but then when I'll come back to the tab I was,
        > I have to set insert mode again.
        >
        > Is there a way to keep mode in the tab?

        Switch tabs differently. This feels a little hackish, but it works in the quick testing I did. The cleaner <expr> mappings won't work because changing buffers during the map expression is not allowed.

        fun! TabNext()
        tabnext
        return ''
        endfun

        fun! TabPrev()
        tabprev
        return ''
        endfun

        inore <A-Right> <C-R>=TabNext()<CR>
        inore <A-Left> <C-R>=TabPrev()<CR>
        nnore <A-Right> gt
        nnore <A-Left> gT

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Maciej Dziardziel
        On Tuesday, June 17, 2014 12:36:38 PM UTC+1, Ben Fritz wrote: Thanks. That works, but now I realized that perhaps problem is deeper then I thought. So now I
        Message 3 of 4 , Jun 17, 2014
          On Tuesday, June 17, 2014 12:36:38 PM UTC+1, Ben Fritz wrote:

          Thanks. That works, but now I realized that perhaps problem is deeper then I thought. So now I can switch tabs regardless of the mode,
          but mode seems to be global. Setting it in one tab sets it to every tab.
          Can it be tab-dependent?

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Ben Fritz
          ... Yes, but that is more complicated: http://vim.wikia.com/wiki/Restore_the_last_used_mode_when_switching_tabpages or
          Message 4 of 4 , Jun 17, 2014
            On Tuesday, June 17, 2014 7:08:40 AM UTC-5, Maciej Dziardziel wrote:
            > On Tuesday, June 17, 2014 12:36:38 PM UTC+1, Ben Fritz wrote:
            >
            > Thanks. That works, but now I realized that perhaps problem is deeper then I thought. So now I can switch tabs regardless of the mode,
            > but mode seems to be global. Setting it in one tab sets it to every tab.
            > Can it be tab-dependent?

            Yes, but that is more complicated:

            http://vim.wikia.com/wiki/Restore_the_last_used_mode_when_switching_tabpages

            or

            http://stackoverflow.com/a/22396144/1390430

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.