Loading ...
Sorry, an error occurred while loading the content.

Ability to undo changes from outside Vim

Expand Messages
  • Eric Christopherson
    In my vimrc I have set undofile set undodir=~/.vimundo -- thus I am almost always able to undo changes done in Vim even if I close a file and reopen it. One
    Message 1 of 3 , Jun 11, 2014
    • 0 Attachment
      In my vimrc I have
        set undofile
        set undodir=~/.vimundo
      -- thus I am almost always able to undo changes done in Vim even if I close a file and reopen it. One other benefit I've enjoyed for a while is the behavior where, if I have a file open in Vim, and some program besides Vim modifies the file, not only does Vim prompt me about whether I want to load the up-to-date version of the file, but even if I do so I can still press u to undo the *external* changes. However, today I noticed this isn't working anymore on my Windows machine (I will check on my Mac and Linux later).

      Does anyone know how I can make it behave the old way again?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Ben Fritz
      ... Check the help for the undoreload option; perhaps you re hitting the limits there. Question for the list, :help undoreload says The save only happens
      Message 2 of 3 , Jun 11, 2014
      • 0 Attachment
        On Wednesday, June 11, 2014 5:36:31 PM UTC-5, Eric Christopherson wrote:
        > In my vimrc I have
        >
        >   set undofile
        >   set undodir=~/.vimundo
        > -- thus I am almost always able to undo changes done in Vim even if I close a file and reopen it. One other benefit I've enjoyed for a while is the behavior where, if I have a file open in Vim, and some program besides Vim modifies the file, not only does Vim prompt me about whether I want to load the up-to-date version of the file, but even if I do so I can still press u to undo the *external* changes. However, today I noticed this isn't working anymore on my Windows machine (I will check on my Mac and Linux later).
        >
        >
        >
        >
        > Does anyone know how I can make it behave the old way again?

        Check the help for the 'undoreload' option; perhaps you're hitting the limits there.

        Question for the list, :help 'undoreload' says "The save only happens when this options is negative or when the number of lines is smaller than the value of this option".

        Does that mean you can set it to -1 to make it always save without any line-number limit?

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Eric Christopherson
        Ah, thanks; that d be it. undoreload is set by default to 10000, and my file is now over that many lines. I set it to -1 and that made it work. ... -- -- You
        Message 3 of 3 , Jun 12, 2014
        • 0 Attachment
          Ah, thanks; that'd be it. undoreload is set by default to 10000, and my file is now over that many lines. I set it to -1 and that made it work.


          On Wed, Jun 11, 2014 at 10:27 PM, Ben Fritz <fritzophrenic@...> wrote:
          On Wednesday, June 11, 2014 5:36:31 PM UTC-5, Eric Christopherson wrote:
          > In my vimrc I have
          >
          >   set undofile
          >   set undodir=~/.vimundo
          > -- thus I am almost always able to undo changes done in Vim even if I close a file and reopen it. One other benefit I've enjoyed for a while is the behavior where, if I have a file open in Vim, and some program besides Vim modifies the file, not only does Vim prompt me about whether I want to load the up-to-date version of the file, but even if I do so I can still press u to undo the *external* changes. However, today I noticed this isn't working anymore on my Windows machine (I will check on my Mac and Linux later).
          >
          >
          >
          >
          > Does anyone know how I can make it behave the old way again?

          Check the help for the 'undoreload' option; perhaps you're hitting the limits there.

          Question for the list, :help 'undoreload' says "The save only happens when this options is negative or when the number of lines is smaller than the value of this option".

          Does that mean you can set it to -1 to make it always save without any line-number limit?

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        Your message has been successfully submitted and would be delivered to recipients shortly.