Loading ...
Sorry, an error occurred while loading the content.

Odd behaviour with :q!

Expand Messages
  • Graham Nicholls
    On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert
    Message 1 of 13 , May 6, 2014
    • 0 Attachment
      On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.

      A subsequent :q! usually works, but sometimes does the same.

      I'm using konsole under KDE if that's of interest.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Tim Chase
      ... It would be more helpful to know what plugins and non-standard settings you have. I m going to guess that if you repeatedly try vim -u NONE ... it
      Message 2 of 13 , May 6, 2014
      • 0 Attachment
        On 2014-05-06 04:18, Graham Nicholls wrote:
        > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411;
        > randomly at a frequency of about 1 in 5, entering :q! (when in
        > command mode) puts me into insert mode after adding an M and a
        > blank line.
        >
        > A subsequent :q! usually works, but sometimes does the same.
        >
        > I'm using konsole under KDE if that's of interest.

        It would be more helpful to know what plugins and non-standard
        settings you have. I'm going to guess that if you repeatedly try

        vim -u NONE ...

        it shouldn't give you any trouble. If it does, then there's
        something much shadier going on. If that works just fine, there's
        likely some mapping interfering with your command.

        I also presume that, if you type ":q!" in other programs, such as
        another text-editor or the command-shell, you have no problems
        (ruling out a flaky keyboard like the built-in one on my laptop here
        where the ZAQ1!<tab> cluster is broken).

        -tim
      • Graham Nicholls
        ... Hmmm, that s interesting: if I do # while true; do vim -u NONE ; done then I can run vi forever without getting the problem, which is a relief. I don t
        Message 3 of 13 , May 6, 2014
        • 0 Attachment
          On Tuesday, 6 May 2014 14:01:22 UTC+1, Tim Chase wrote:
          > On 2014-05-06 04:18, Graham Nicholls wrote:
          >
          > > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411;
          >
          > > randomly at a frequency of about 1 in 5, entering :q! (when in
          >
          > > command mode) puts me into insert mode after adding an M and a
          >
          > > blank line.
          >
          > >
          >
          > > A subsequent :q! usually works, but sometimes does the same.
          >
          > >
          >
          > > I'm using konsole under KDE if that's of interest.
          >
          >
          >
          > It would be more helpful to know what plugins and non-standard
          >
          > settings you have. I'm going to guess that if you repeatedly try
          >
          >
          >
          > vim -u NONE ...

          >
          >
          >
          > -tim

          Hmmm, that's interesting:
          if I do
          # while true; do vim -u NONE ; done
          then I can run vi forever without getting the problem, which is a relief.

          I don't think it's my .exrc - actually, I haven't got one (it's a shared root account, so in my .gnbashrc, I set EXINIT:

          [root@xxxxxxxxxxxxxxx ~]# echo $EXINIT
          set ts=2 ht=2 sw=2 sm ws ic ai

          I have no plugins, and it's a freshly installed box, so nothing non-standard. Must be something Redhat have done. Any idea how I can track this down, and thanks for the useful response. I'm quite surprised this hasn't been seen before.

          Graham

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Tim Chase
          ... Well, that at least demonstrates that all is working correctly before other files start mucking with your configuration. So that s good news. ... so if
          Message 4 of 13 , May 6, 2014
          • 0 Attachment
            On 2014-05-06 07:09, Graham Nicholls wrote:
            > On Tuesday, 6 May 2014 14:01:22 UTC+1, Tim Chase wrote:
            > > vim -u NONE ...
            >
            > Hmmm, that's interesting:
            > if I do
            > # while true; do vim -u NONE ; done
            > then I can run vi forever without getting the problem, which is a
            > relief.

            Well, that at least demonstrates that all is working correctly before
            other files start mucking with your configuration. So that's good
            news.

            > I don't think it's my .exrc - actually, I haven't got one (it's a
            > shared root account, so in my .gnbashrc, I set EXINIT:

            There are several files that are checked:

            :sp $VIM/vimrc
            :sp ~/.vimrc
            :sp ~/.gvimrc
            :sp ~/.exrc
            :sp $VIMRUNTIME/evim.vim

            so if any of those exist you might want to check those locations (and
            any files they reference) for weird mappings that are screwing with
            your settings.

            -tim
          • Graham Nicholls
            Interesting: I ran strace -f -o /tmp/vim_trace , and got this: grep open.*rc /tmp/vim_trace /tmp/vim_trace:47680 open( /etc/virc , O_RDONLY) = 3
            Message 5 of 13 , May 6, 2014
            • 0 Attachment
              Interesting: I ran strace -f -o /tmp/vim_trace , and got this:

              grep "open.*rc\>" /tmp/vim_trace

              /tmp/vim_trace:47680 open("/etc/virc", O_RDONLY)       = 3
              /tmp/vim_trace:47680 open("/root/.vimrc", O_RDONLY)    = -1 ENOENT (No such file or directory)
              /tmp/vim_trace:47680 open("/root/_vimrc", O_RDONLY)    = -1 ENOENT (No such file or directory)
              /tmp/vim_trace:47680 open("/root/.exrc", O_RDONLY)     = -1 ENOENT (No such file or directory)

              As virc is the only open which succeeds, it must be the culprit.  Here's what it looks like:
              ls -l /etc/virc 
              -rw-r--r--. 1 root root 1962 Apr 19  2010 /etc/virc

              <I did paste it here>


              I'm too damn lazy to work out which bit is doing it - I think I'll just remove it.

              UPDATE:  It's not that! renamed the file, and now:

              grep "open.*rc\>" /tmp/vim_trace.48290 
              48545 open("/etc/virc", O_RDONLY)       = -1 ENOENT (No such file or directory)
              48545 open("/root/7ticks/.vimrc", O_RDONLY) = -1 ENOENT (No such file or directory)
              48545 open("/root/7ticks/_vimrc", O_RDONLY) = -1 ENOENT (No such file or directory)

              (The only other opens are for library files)

              This is odd (and interesting).

              Graham






              On 6 May 2014 15:22, Tim Chase <vim@...> wrote:
              On 2014-05-06 07:09, Graham Nicholls wrote:
              > On Tuesday, 6 May 2014 14:01:22 UTC+1, Tim Chase  wrote:
              > >   vim -u NONE ...
              >
              > Hmmm, that's interesting:
              > if I do
              > # while true; do vim -u NONE ; done
              > then I can run vi forever without getting the problem, which is a
              > relief.

              Well, that at least demonstrates that all is working correctly before
              other files start mucking with your configuration.  So that's good
              news.

              > I don't think it's my .exrc - actually, I haven't got one (it's a
              > shared root account, so in my .gnbashrc, I set EXINIT:

              There are several files that are checked:

                :sp $VIM/vimrc
                :sp ~/.vimrc
                :sp ~/.gvimrc
                :sp ~/.exrc
                :sp $VIMRUNTIME/evim.vim

              so if any of those exist you might want to check those locations (and
              any files they reference) for weird mappings that are screwing with
              your settings.

              -tim




              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Graham Nicholls
              Doh! I moved /etc/virc (which is surely an aberrant rc filename for vim) on the wrong server (I have 4 hops to get to the one in question). It is that. Here s
              Message 6 of 13 , May 6, 2014
              • 0 Attachment
                Doh! I moved /etc/virc (which is surely an aberrant rc filename for vim) on the wrong server (I have 4 hops to get to the one in question).  It is that.
                Here's the file if you're interested (I'm going to remove it):

                grahamn@gn-linux:~/remotes$ clear ; cat virc
                if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
                   set fileencodings=ucs-bom,utf-8,latin1
                endif

                set nocompatible        " Use Vim defaults (much better!)
                set bs=indent,eol,start         " allow backspacing over everything in insert mode
                "set ai                 " always set autoindenting on
                "set backup             " keep a backup file
                set viminfo='20,\"50    " read/write a .viminfo file, don't store more
                                        " than 50 lines of registers
                set history=50          " keep 50 lines of command line history
                set ruler               " show the cursor position all the time

                " Only do this part when compiled with support for autocommands
                if has("autocmd")
                  augroup redhat
                  autocmd!
                  " In text files, always limit the width of text to 78 characters
                  autocmd BufRead *.txt set tw=78
                  " When editing a file, always jump to the last cursor position
                  autocmd BufReadPost *
                  \ if line("'\"") > 0 && line ("'\"") <= line("$") |
                  \   exe "normal! g'\"" |
                  \ endif
                  " don't write swapfile on most commonly used directories for NFS mounts or USB sticks
                  autocmd BufNewFile,BufReadPre /media/*,/mnt/* set directory=~/tmp,/var/tmp,/tmp
                  " start with spec file template
                  autocmd BufNewFile *.spec 0r /usr/share/vim/vimfiles/template.spec
                  augroup END
                endif

                if has("cscope") && filereadable("/usr/bin/cscope")
                   set csprg=/usr/bin/cscope
                   set csto=0
                   set cst
                   set nocsverb
                   " add any database in current directory
                   if filereadable("cscope.out")
                      cs add cscope.out
                   " else add database pointed to by environment
                   elseif $CSCOPE_DB != ""
                      cs add $CSCOPE_DB
                   endif
                   set csverb
                endif

                " Switch syntax highlighting on, when the terminal has colors
                " Also switch on highlighting the last used search pattern.
                if &t_Co > 2 || has("gui_running")
                  syntax on
                  set hlsearch
                endif

                filetype plugin on

                if &term=="xterm"
                     set t_Co=8
                     set t_Sb=dm
                     set t_Sf=dm
                endif

                " Don't wake up system with blinking cursor:
                let &guicursor = &guicursor . ",a:blinkon0"





                On 6 May 2014 14:01, Tim Chase <vim@...> wrote:
                On 2014-05-06 04:18, Graham Nicholls wrote:
                > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411;
                > randomly at a frequency of about 1 in 5, entering :q! (when in
                > command mode) puts me into insert mode after adding an M and a
                > blank line.
                >
                > A subsequent :q! usually works, but sometimes does the same.
                >
                > I'm using konsole under KDE if that's of interest.

                It would be more helpful to know what plugins and non-standard
                settings you have.  I'm going to guess that if you repeatedly try

                  vim -u NONE ...

                it shouldn't give you any trouble.  If it does, then there's
                something much shadier going on.  If that works just fine, there's
                likely some mapping interfering with your command.

                I also presume that, if you type ":q!" in other programs, such as
                another text-editor or the command-shell, you have no problems
                (ruling out a flaky keyboard like the built-in one on my laptop here
                where the ZAQ1!<tab> cluster is broken).

                -tim




                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Graham Nicholls
                ... Seems like it s nocompatible which is doing it - by a process of elimination - I started at the bottom, eliminating lines/functions till it worked. All
                Message 7 of 13 , May 6, 2014
                • 0 Attachment
                  On Tuesday, 6 May 2014 12:18:39 UTC+1, Graham Nicholls wrote:
                  > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                  >
                  > A subsequent :q! usually works, but sometimes does the same.
                  >
                  > I'm using konsole under KDE if that's of interest.

                  Seems like it's nocompatible which is doing it - by a process of elimination - I started at the bottom, eliminating lines/functions till it worked.

                  All very odd, but thanks for your help.

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • Christian Brabandt
                  Hi Graham! ... Does this only happen with konsole? By any chance, you are not accidentally using q:? Best, Christian -- Loch in Erde, Bronze rin. Glocke
                  Message 8 of 13 , May 6, 2014
                  • 0 Attachment
                    Hi Graham!

                    On Di, 06 Mai 2014, Graham Nicholls wrote:

                    > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                    >
                    > A subsequent :q! usually works, but sometimes does the same.
                    >
                    > I'm using konsole under KDE if that's of interest.

                    Does this only happen with konsole?
                    By any chance, you are not accidentally using q:?

                    Best,
                    Christian
                    --
                    Loch in Erde,
                    Bronze rin.
                    Glocke fertig,
                    Bim bim bimm.
                    -- Frei nach Friedrich Schiller

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • Charles Campbell
                    ... I m not sure that you ve correctly identified the problem. I ve attached two files: nicholls : a shell script that runs vim a hundred times, using
                    Message 9 of 13 , May 6, 2014
                    • 0 Attachment
                      Graham Nicholls wrote:
                      > On Tuesday, 6 May 2014 12:18:39 UTC+1, Graham Nicholls wrote:
                      >> On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                      >>
                      >> A subsequent :q! usually works, but sometimes does the same.
                      >>
                      >> I'm using konsole under KDE if that's of interest.
                      > Seems like it's nocompatible which is doing it - by a process of elimination - I started at the bottom, eliminating lines/functions till it worked.
                      >
                      > All very odd, but thanks for your help.
                      >
                      I'm not sure that you've correctly identified the problem. I've
                      attached two files:

                      nicholls : a shell script that runs vim a hundred times, using
                      nicholls.vimrc (which I copied from your earlier email) and which
                      immediately tells vim to quit. I also ran it after having changed vim
                      to gvim, by the way.

                      Result: a bit of blinking as (g)vim popped in and out, but otherwise it
                      ran as expected. If a vim had refused to quit, a (g)vim window would
                      have remained open. I did this on a scientific linux 6.4 (Carbon)
                      system with a huge vim 7.4.272.

                      Suggestion: try running vim with -V and, when it refuses to quit and
                      goes insert instead, maybe you can see what happened. I don't much like
                      having distributed .vimrc files, as that frequently causes problems, but
                      I don't see anything in that .virc that should cause that quitting
                      issue. Dropping the "set nocompatible" is like preventing yourself from
                      having a car accident by removing the car's battery. It may work but
                      one does miss out on a lot.

                      What happens when you run the attached script?

                      Regards,
                      Chip Campbell

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • Charles Campbell
                      ... !sneppah reven taht wonk uoy -- naitsirhC ,no emoC ,sdrageR pihC (seriously, though: what does ... show? Any maps starting with q ?) -- -- You received
                      Message 10 of 13 , May 6, 2014
                      • 0 Attachment
                        Christian Brabandt wrote:
                        > Hi Graham!
                        >
                        > On Di, 06 Mai 2014, Graham Nicholls wrote:
                        >
                        >> On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                        >>
                        >> A subsequent :q! usually works, but sometimes does the same.
                        >>
                        >> I'm using konsole under KDE if that's of interest.
                        > Does this only happen with konsole?
                        > By any chance, you are not accidentally using q:?
                        >
                        !sneppah reven taht wonk uoy -- naitsirhC ,no emoC

                        ,sdrageR
                        pihC

                        (seriously, though: what does
                        :map
                        show? Any maps starting with "q"?)


                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      • Graham Nicholls
                        ... Yes, looks like only in konsole - never with plain vanilla xterm, and no, I m definitely hitting :q!. I ve seen it on other servers, too. Most odd, as
                        Message 11 of 13 , May 7, 2014
                        • 0 Attachment
                          On Tuesday, 6 May 2014 19:18:35 UTC+1, Christian Brabandt wrote:
                          > Hi Graham!
                          >
                          >
                          >
                          > On Di, 06 Mai 2014, Graham Nicholls wrote:
                          >
                          >
                          >
                          > > On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                          >
                          > >
                          >
                          > > A subsequent :q! usually works, but sometimes does the same.
                          >
                          > >
                          >
                          > > I'm using konsole under KDE if that's of interest.
                          >
                          >
                          >
                          > Does this only happen with konsole?
                          >
                          > By any chance, you are not accidentally using q:?
                          >
                          >
                          >
                          > Best,
                          >
                          > Christian
                          >
                          > --
                          >
                          > Loch in Erde,
                          >
                          > Bronze rin.
                          >
                          > Glocke fertig,
                          >
                          > Bim bim bimm.
                          >
                          > -- Frei nach Friedrich Schiller

                          Yes, looks like only in konsole - never with plain vanilla xterm, and no, I'm definitely hitting :q!. I've seen it on other servers, too. Most odd, as it's random.

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/d/optout.
                        • Graham Nicholls
                          ... 100 iterations with no windows left open , interestingly. I d agree that I ve not identified the problem; just a temporary fix, and running with compatible
                          Message 12 of 13 , May 7, 2014
                          • 0 Attachment
                            On Tuesday, 6 May 2014 19:33:02 UTC+1, Charles Campbell wrote:
                            > Graham Nicholls wrote:
                            >
                            > > On Tuesday, 6 May 2014 12:18:39 UTC+1, Graham Nicholls wrote:
                            >
                            > >> On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                            >
                            > >>
                            >
                            > >> A subsequent :q! usually works, but sometimes does the same.
                            >
                            > >>
                            >
                            > >> I'm using konsole under KDE if that's of interest.
                            >
                            > > Seems like it's nocompatible which is doing it - by a process of elimination - I started at the bottom, eliminating lines/functions till it worked.
                            >
                            > >
                            >
                            > > All very odd, but thanks for your help.
                            >
                            > >
                            >
                            > I'm not sure that you've correctly identified the problem. I've
                            >
                            > attached two files:
                            >
                            >
                            >
                            > nicholls : a shell script that runs vim a hundred times, using
                            >
                            > nicholls.vimrc (which I copied from your earlier email) and which
                            >
                            > immediately tells vim to quit. I also ran it after having changed vim
                            >
                            > to gvim, by the way.
                            >
                            >
                            >
                            > Result: a bit of blinking as (g)vim popped in and out, but otherwise it
                            >
                            > ran as expected. If a vim had refused to quit, a (g)vim window would
                            >
                            > have remained open. I did this on a scientific linux 6.4 (Carbon)
                            >
                            > system with a huge vim 7.4.272.
                            >
                            >
                            >
                            > Suggestion: try running vim with -V and, when it refuses to quit and
                            >
                            > goes insert instead, maybe you can see what happened. I don't much like
                            >
                            > having distributed .vimrc files, as that frequently causes problems, but
                            >
                            > I don't see anything in that .virc that should cause that quitting
                            >
                            > issue. Dropping the "set nocompatible" is like preventing yourself from
                            >
                            > having a car accident by removing the car's battery. It may work but
                            >
                            > one does miss out on a lot.
                            >
                            >
                            >
                            > What happens when you run the attached script?
                            >
                            >
                            >
                            > Regards,
                            >
                            > Chip Campbell

                            100 iterations with no windows left open , interestingly.

                            I'd agree that I've not identified the problem; just a temporary fix, and running with compatible set _is_ a non-starter. In fact, it wouldn't be running, it'd be hopping.

                            I wonder if it's somehow about how fast it's typed. I could run up something in expect to slowly type :q! and see if that exhibits the problem, if I get the time.
                            Thanks for your script, but seriously, ksh, not bash? :-)

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/d/optout.
                          • Graham Nicholls
                            ... Nope, no maps. running vim -V stops the behaviour, too - doesn t mention loading virc, so not sure if that s not the same as deleting the virc file. Thanks
                            Message 13 of 13 , May 7, 2014
                            • 0 Attachment
                              On Tuesday, 6 May 2014 21:15:40 UTC+1, Charles Campbell wrote:
                              > Christian Brabandt wrote:
                              >
                              > > Hi Graham!
                              >
                              > >
                              >
                              > > On Di, 06 Mai 2014, Graham Nicholls wrote:
                              >
                              > >
                              >
                              > >> On a RHEL 6.2 server, I get odd behaviour with vim 7.2.411; randomly at a frequency of about 1 in 5, entering :q! (when in command mode) puts me into insert mode after adding an M and a blank line.
                              >
                              > >>
                              >
                              > >> A subsequent :q! usually works, but sometimes does the same.
                              >
                              > >>
                              >
                              > >> I'm using konsole under KDE if that's of interest.
                              >
                              > > Does this only happen with konsole?
                              >
                              > > By any chance, you are not accidentally using q:?
                              >
                              > >
                              >
                              > !sneppah reven taht wonk uoy -- naitsirhC ,no emoC
                              >
                              >
                              >
                              > ,sdrageR
                              >
                              > pihC
                              >
                              >
                              >
                              > (seriously, though: what does
                              >
                              > :map
                              >
                              > show? Any maps starting with "q"?)

                              Nope, no maps. running vim -V stops the behaviour, too - doesn't mention loading virc, so not sure if that's not the same as deleting the virc file.

                              Thanks

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/d/optout.
                            Your message has been successfully submitted and would be delivered to recipients shortly.