Loading ...
Sorry, an error occurred while loading the content.
 

Added asm.snippets to snipmate but cannot get it working without :set filetype=asm

Expand Messages
  • Fabio D'Alfonso
    Hi, I already have a cpp.snippets (auto) working, but I cannot get asm extension be auto detected and need to set the filetype in the file to trigger snippets.
    Message 1 of 6 , May 6, 2014
      Hi,
      I already have a cpp.snippets (auto) working, but I cannot get asm extension be auto detected and need to set the filetype in the file to trigger snippets.

      How to get the asm auto detected?

      Thanks
      Fabio D'Alfonso

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Fabio D'Alfonso
      Hi, found where the problem is but have no idea about how to solve. I use the nasm assembler, so I made nasm the default filetype for asm to get the
      Message 2 of 6 , May 6, 2014
        Hi,
        found where the problem is but have no idea about how to solve.

        I use the nasm assembler, so I made nasm the default filetype for asm to get the highlighting (anyway the manual would be the same).

        This is the point:
        -  to get the snipmate working I have to set filetype to asm, loosing the highlighiting
        -  to use the highlighting I need to set the filetype to nasm and cannot use the snippets.

        So how can I have file.asm, as nasm (asm) type, while using snipmate?


        Thanks in advance 

        Fabio D'Alfonso
        'Enabling Business Through IT'
        cell.  +39.348.059.40.22 *
        web: www.fabiodalfonso.com
        email: fabio.dalfonso@...
        linkedin: www.linkedin.com/in/fabiodalfonso
        twitter: www.twitter.com/#!/fabio_dalfonso

        fax: +39.06.874.599.581
        BlackBerry® Wireless Enabled Address.

        * Hidden  numbers are automatically rejected by the phone
        On 5/6/2014 11:32 AM, Fabio D'Alfonso wrote:
        Hi,
        I already have a cpp.snippets (auto) working, but I cannot get asm extension be auto detected and need to set the filetype in the file to trigger snippets. 
        
        How to get the asm auto detected?
        
        Thanks
        Fabio D'Alfonso
        
        

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Fabio D'Alfonso
        Hi, found where the problem is but have no idea about how to solve. I use the nasm assembler, so I made nasm the default filetype for asm to get the
        Message 3 of 6 , May 6, 2014
          Hi,
          found where the problem is but have no idea about how to solve.

          I use the nasm assembler, so I made nasm the default filetype for asm to
          get the highlighting (anyway the manual would be the same).

          This is the point:
          - to get the snipmate working I have to set filetype to asm, loosing
          the highlighiting
          - to use the highlighting I need to set the filetype to nasm and cannot
          use the snippets.

          So how can I have file.asm, as nasm (asm) type, while using snipmate?


          Thanks in advance

          Fabio D'Alfonso
          'Enabling Business Through IT'
          cell. +39.348.059.40.22 ***
          web: www.fabiodalfonso.com <http://www.fabiodalfonso.com/>
          email: fabio.dalfonso@...
          <mailto:fabio.dalfonso@...>linkedin:
          www.linkedin.com/in/fabiodalfonso <http://it.linkedin.com/in/fabiodalfonso>
          twitter: www.twitter.com/#!/fabio_dalfonso
          <http://www.twitter.com/#%21/fabio_dalfonso>

          fax: +39.06.874.599.581
          BlackBerry® Wireless Enabled Address.


          ** Hidden numbers are automatically rejected by the phone*

          On 5/6/2014 11:32 AM, Fabio D'Alfonso wrote:
          > Hi,
          > I already have a cpp.snippets (auto) working, but I cannot get asm extension be auto detected and need to set the filetype in the file to trigger snippets.
          >
          > How to get the asm auto detected?
          >
          > Thanks
          > Fabio D'Alfonso
          >

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Fabio D'Alfonso
          Found, sorry for sending the messages. Snipmate uses the type.snippets, so the nasm.snippets made the work. I already had there, but mistyped the name
          Message 4 of 6 , May 6, 2014
            Found,
            sorry for sending the messages.

            Snipmate uses the type.snippets, so the nasm.snippets made the work. I
            already had there, but mistyped the name (sniptpets something) and the
            file was not read.

            So that is it.


            Fabio D'Alfonso
            'Enabling Business Through IT'
            cell. +39.348.059.40.22 ***
            web: www.fabiodalfonso.com <http://www.fabiodalfonso.com/>
            email: fabio.dalfonso@...
            <mailto:fabio.dalfonso@...>linkedin:
            www.linkedin.com/in/fabiodalfonso <http://it.linkedin.com/in/fabiodalfonso>
            twitter: www.twitter.com/#!/fabio_dalfonso
            <http://www.twitter.com/#%21/fabio_dalfonso>

            fax: +39.06.874.599.581
            BlackBerry® Wireless Enabled Address.


            ** Hidden numbers are automatically rejected by the phone*

            On 5/6/2014 12:41 PM, Fabio D'Alfonso wrote:
            > Hi,
            > found where the problem is but have no idea about how to solve.
            >
            > I use the nasm assembler, so I made nasm the default filetype for asm
            > to get the highlighting (anyway the manual would be the same).
            >
            > This is the point:
            > - to get the snipmate working I have to set filetype to asm, loosing
            > the highlighiting
            > - to use the highlighting I need to set the filetype to nasm and
            > cannot use the snippets.
            >
            > So how can I have file.asm, as nasm (asm) type, while using snipmate?
            >
            >
            > Thanks in advance
            >
            > Fabio D'Alfonso
            > 'Enabling Business Through IT'
            > cell. +39.348.059.40.22 ***
            > web: www.fabiodalfonso.com <http://www.fabiodalfonso.com/>
            > email: fabio.dalfonso@...
            > <mailto:fabio.dalfonso@...>linkedin:
            > www.linkedin.com/in/fabiodalfonso
            > <http://it.linkedin.com/in/fabiodalfonso>
            > twitter: www.twitter.com/#!/fabio_dalfonso
            > <http://www.twitter.com/#%21/fabio_dalfonso>
            >
            > fax: +39.06.874.599.581
            > BlackBerry® Wireless Enabled Address.
            >
            >
            > ** Hidden numbers are automatically rejected by the phone*
            >
            > On 5/6/2014 11:32 AM, Fabio D'Alfonso wrote:
            >> Hi,
            >> I already have a cpp.snippets (auto) working, but I cannot get asm
            >> extension be auto detected and need to set the filetype in the file
            >> to trigger snippets.
            >>
            >> How to get the asm auto detected?
            >>
            >> Thanks
            >> Fabio D'Alfonso
            >>
            >

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Marc Weber
            Hi Fabio, consider telling your mail client to send textmails only when posting to mailinglists. About snipmate and filetypes: Do RTFM:
            Message 5 of 6 , May 6, 2014
              Hi Fabio,

              consider telling your mail client to send textmails only when posting to
              mailinglists.

              About snipmate and filetypes:
              Do RTFM: https://github.com/garbas/vim-snipmate
              => FAQ

              Thus setting scope_aliases is one option.
              How to set filetype?

              ftdetect/*.vim files get the job done as well as au commands, like this:

              autocmd BufRead,BufNewFile *.y,*.ly :set ft=happy

              ft can contain multiple filetypes AFAIK, eg ft=a,b

              snipmate itself supports "importing" other snippet files, too.
              But I recommend using the scope_aliases instead.

              If it should happen that you're still using msanders of snipmate version
              then get consider using a plugin manager which supports vim-pi which
              tries to protect against using outdated plugins by telling you about
              alternatives when installing.

              Eg see: http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html

              You also want to know about the collaborative vim-snippets effort:
              https://github.com/honza/vim-snippets

              We welcome you to help maintain the assembler snippets.

              Marc Weber

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Fabio D'Alfonso
              Hi, it asks (thunderbird) the format before, I sent the message twice because the first was html in error, sometimes, it goes . I sent a post after that where
              Message 6 of 6 , May 6, 2014
                Hi,
                it asks (thunderbird) the format before, I sent the message twice
                because the first was html in error, sometimes, it goes .

                I sent a post after that where I explain that the problem was I
                mispelled the nasm.snippets (something like nasm.snippest) ,
                "type".snippets, I tried before sending the email, supposing that could
                be the type, not the extension to be used.
                So the try was not successful and I went forward to the list. Now I made
                the file name correct, and I have both working.

                Thanks

                Fabio D'Alfonso
                'Enabling Business Through IT'
                cell. +39.348.059.40.22 ***
                web: www.fabiodalfonso.com <http://www.fabiodalfonso.com/>
                email: fabio.dalfonso@...
                <mailto:fabio.dalfonso@...>linkedin:
                www.linkedin.com/in/fabiodalfonso <http://it.linkedin.com/in/fabiodalfonso>
                twitter: www.twitter.com/#!/fabio_dalfonso
                <http://www.twitter.com/#%21/fabio_dalfonso>

                fax: +39.06.874.599.581
                BlackBerry® Wireless Enabled Address.


                ** Hidden numbers are automatically rejected by the phone*

                On 5/6/2014 1:36 PM, Marc Weber wrote:
                > Hi Fabio,
                >
                > consider telling your mail client to send textmails only when posting to
                > mailinglists.
                >
                > About snipmate and filetypes:
                > Do RTFM: https://github.com/garbas/vim-snipmate
                > => FAQ
                >
                > Thus setting scope_aliases is one option.
                > How to set filetype?
                >
                > ftdetect/*.vim files get the job done as well as au commands, like this:
                >
                > autocmd BufRead,BufNewFile *.y,*.ly :set ft=happy
                >
                > ft can contain multiple filetypes AFAIK, eg ft=a,b
                >
                > snipmate itself supports "importing" other snippet files, too.
                > But I recommend using the scope_aliases instead.
                >
                > If it should happen that you're still using msanders of snipmate version
                > then get consider using a plugin manager which supports vim-pi which
                > tries to protect against using outdated plugins by telling you about
                > alternatives when installing.
                >
                > Eg see: http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html
                >
                > You also want to know about the collaborative vim-snippets effort:
                > https://github.com/honza/vim-snippets
                >
                > We welcome you to help maintain the assembler snippets.
                >
                > Marc Weber
                >

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.