Loading ...
Sorry, an error occurred while loading the content.
 

Problem browsing ftp server with Netrw

Expand Messages
  • Steve
    Hi, I m trying to browse my ftp server with vim using Netrw. The problem is that no file show up. I m doing: vim ftp://user@mysite/ then I enter my password
    Message 1 of 4 , May 4 12:28 PM
      Hi,

      I'm trying to browse my ftp server with vim using Netrw. The problem
      is that no file show up. I'm doing:

      vim ftp://user@mysite/
      then I enter my password and I get the following window:

      "========================================================
      " Netrw Directory Listing (netrw v145)
      " ftp://user@mysite/
      " sorted by time
      " Quick Help: <F1>:help etc...
      "========================================================
      ./
      ../

      And nothing else.
      It works using ncftp for example.

      What's wrong?

      Thank you.
      Steve

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Charles Campbell
      ... I m pretty busy this week (finals) and so won t be able to do much. * what o/s? what netrw options do you use? * did you make ncftp the command to be used?
      Message 2 of 4 , May 5 7:41 AM
        Steve wrote:
        > Hi,
        >
        > I'm trying to browse my ftp server with vim using Netrw. The problem
        > is that no file show up. I'm doing:
        >
        > vim ftp://user@mysite/
        > then I enter my password and I get the following window:
        >
        > "========================================================
        > " Netrw Directory Listing (netrw v145)
        > " ftp://user@mysite/
        > " sorted by time
        > " Quick Help: <F1>:help etc...
        > "========================================================
        > ./
        > ../
        >
        > And nothing else.
        > It works using ncftp for example.
        >
        > What's wrong?
        >
        > Thank you.
        > Steve
        >
        I'm pretty busy this week (finals) and so won't be able to do much.

        * what o/s? what netrw options do you use?
        * did you make ncftp the command to be used? (ie. :he g:netrw_ftp_cmd)
        * I see a note in the help about ncftp (ie. :he g:netrw_ftp_options).
        You may need to change the default on that variable.
        * have you looked at :help netrw-debug ?

        Regards,
        C Campbell

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Charles Campbell
        ... Also, netrw v145 is old. Its up to v152e now (http://www.drchip.org/astronaut/vim/index.html#NETRW) Regards, C Campbell -- -- You received this message
        Message 3 of 4 , May 5 7:42 AM
          Steve wrote:
          > Hi,
          >
          > I'm trying to browse my ftp server with vim using Netrw. The problem
          > is that no file show up. I'm doing:
          >
          > vim ftp://user@mysite/
          > then I enter my password and I get the following window:
          >
          > "========================================================
          > " Netrw Directory Listing (netrw v145)
          > " ftp://user@mysite/
          > " sorted by time
          > " Quick Help: <F1>:help etc...
          > "========================================================
          > ./
          > ../
          >
          > And nothing else.
          > It works using ncftp for example.
          >
          > What's wrong?
          >
          > Thank you.
          > Steve
          >
          Also, netrw v145 is old. Its up to v152e now
          (http://www.drchip.org/astronaut/vim/index.html#NETRW)

          Regards,
          C Campbell

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Steve
          Hi Charles, Thanks for your answers. ... So that s even nicer from you :) ... Debian wheezy with kernel 3.13 from backports. No specific options. ... No. ...
          Message 4 of 4 , May 5 1:07 PM
            Hi Charles,

            Thanks for your answers.

            > I'm pretty busy this week (finals) and so won't be able to do much.

            So that's even nicer from you :)

            > * what o/s? what netrw options do you use?

            Debian wheezy with kernel 3.13 from backports. No specific options.

            > * did you make ncftp the command to be used? (ie. :he g:netrw_ftp_cmd)

            No.

            > * I see a note in the help about ncftp (ie. :he
            > g:netrw_ftp_options). You may need to change the default on that
            > variable.
            > * have you looked at :help netrw-debug ?

            No.

            In fact, after some search on the Net, It seems it was not a vim related
            issue, but rather a firewall (iptables) one. I recently made a fresh
            install (after 12 years on the same system) of Debian but I kept all the
            old configuration. Well I thought I did. I found that I forgot to load a
            kernel module, namely nf_conntrack_ftp. Loading it solved the problem.
            Before that, I compiled vim 7.4, but still had the same problem.
            Solution arised when I tried the same operation on another machine with
            same config but routing directly to the Net without any firewall.

            In your other post you were suggesting using netrw version 152, which I
            also tried, but without success. Problem was really linked with this
            kernel module. So to say that netrw v145 (which is shipped with Debian
            wheezy) works perfectly, as expected.

            Thanks for this great software!

            Best,
            Steve

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.