Loading ...
Sorry, an error occurred while loading the content.

my invisible characters are not displayed properly

Expand Messages
  • FlashBurn
    For some reason my invisible characters are not displayed properly. I have to source my vimrc a second time for the list setting to work. Here is my setting
    Message 1 of 13 , Apr 15, 2014
    • 0 Attachment
      For some reason my invisible characters are not displayed properly. I have to source my vimrc a second time for the 'list' setting to work.

      Here is my setting for 'listchars'
      set listchars=tab:►\ ,eol:¬,trail:●

      The results of the invisibles not being displayed is in the attached file called invisibles_wrong.jpg.

      If I source my vimrc again, everything is working. You can see the result in the attached imaged called invisibles_right.jpg

      Can anyone explain why this is happening?

      Any help is appreciated.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Jürgen Krämer
      Hi, ... in your .vimrc encoding is probably set to utf-8 only after listchars is set. Move the line with set encoding=utf-8 before the one with set
      Message 2 of 13 , Apr 15, 2014
      • 0 Attachment
        Hi,

        FlashBurn wrote:
        > For some reason my invisible characters are not displayed properly. I
        > have to source my vimrc a second time for the 'list' setting to work.
        >
        > Here is my setting for 'listchars'
        > set listchars=tab:►\ ,eol:¬,trail:●
        >
        > The results of the invisibles not being displayed is in the attached
        > file called invisibles_wrong.jpg.
        >
        > If I source my vimrc again, everything is working. You can see the
        > result in the attached imaged called invisibles_right.jpg
        >
        > Can anyone explain why this is happening?

        in your .vimrc encoding is probably set to utf-8 only after listchars
        is set. Move the line with

        set encoding=utf-8

        before the one with

        set listchars=tab:►\ ,eol:¬,trail:●

        and it should work correctly.

        Regards,
        Jürgen

        --
        Sometimes I think the surest sign that intelligent life exists elsewhere
        in the universe is that none of it has tried to contact us. (Calvin)

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • FlashBurn
        ... I was so happy to see the answer, but the happiness didn t last long. My encoding is set before the listchars. Here is a snapshot of my vimrc Necessary
        Message 3 of 13 , Apr 15, 2014
        • 0 Attachment
          On Tuesday, April 15, 2014 9:26:27 AM UTC-4, Jürgen Krämer wrote:
          > Hi,
          >
          >
          >
          > FlashBurn wrote:
          >
          > > For some reason my invisible characters are not displayed properly. I
          >
          > > have to source my vimrc a second time for the 'list' setting to work.
          >
          > >
          >
          > > Here is my setting for 'listchars'
          >
          > > set listchars=tab:►\ ,eol:¬,trail:●
          >
          > >
          >
          > > The results of the invisibles not being displayed is in the attached
          >
          > > file called invisibles_wrong.jpg.
          >
          > >
          >
          > > If I source my vimrc again, everything is working. You can see the
          >
          > > result in the attached imaged called invisibles_right.jpg
          >
          > >
          >
          > > Can anyone explain why this is happening?
          >
          >
          >
          > in your .vimrc encoding is probably set to utf-8 only after listchars
          >
          > is set. Move the line with
          >
          >
          >
          > set encoding=utf-8
          >
          >
          >
          > before the one with
          >
          >
          >
          > set listchars=tab:►\ ,eol:¬,trail:●
          >
          >
          >
          > and it should work correctly.
          >
          >
          >
          > Regards,
          >
          > Jürgen
          >
          >
          >
          > --
          >
          > Sometimes I think the surest sign that intelligent life exists elsewhere
          >
          > in the universe is that none of it has tried to contact us. (Calvin)

          I was so happy to see the answer, but the happiness didn't last long. My encoding is set before the listchars. Here is a snapshot of my vimrc

          " Necessary to show the Unicode glyphs, needed for the vim-powerline plugin.
          set encoding=utf-8

          " Set the font
          if has('win32')
          set guifont=Consolas:h9:b:cANSI
          endif

          " Remove Menu from GUI
          set guioptions-=m
          " Remove Toolbar from GUI
          set guioptions-=T

          " ===== <Tab> completion =====
          " list:longest - List all matches and complete the longest match
          " full - complete the next full match.
          set wildmode=list:longest,full
          " Do not use the menu one can go through by using <Tab>. Simply list all the
          " files.
          set nowildmenu

          " Turn on line numbering.
          set number

          " Enable syntax highlighting
          syntax on

          " Remeber 300 last ex-commands
          set history=300

          " Make a buffer hidden when it is abandoned.
          set hidden

          " Set the colorscheme
          " Note: Keep the colorscheme settings after the syntax on command.
          " As it turns out syntax on reloads colorshcheme again.
          colorscheme xoria256

          " Turn on the highlight of the line with the cursor.
          set cursorline
          " Set up how to show tabs, end of line, and trailing spaces.
          set listchars=tab:►\ ,eol:¬,trail:●

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • FlashBurn
          ... I m running a GUI version of Vim, but I have no settings in gvimrc. I ran :verbose set encoding? listchars? guifont? Here is the result encoding=utf-8 Last
          Message 4 of 13 , Apr 15, 2014
          • 0 Attachment
            On Tuesday, April 15, 2014 9:56:06 AM UTC-4, FlashBurn wrote:
            > On Tuesday, April 15, 2014 9:26:27 AM UTC-4, Jürgen Krämer wrote:
            >
            > > Hi,
            >
            > >
            >
            > >
            >
            > >
            >
            > > FlashBurn wrote:
            >
            > >
            >
            > > > For some reason my invisible characters are not displayed properly. I
            >
            > >
            >
            > > > have to source my vimrc a second time for the 'list' setting to work.
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > Here is my setting for 'listchars'
            >
            > >
            >
            > > > set listchars=tab:►\ ,eol:¬,trail:●
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > The results of the invisibles not being displayed is in the attached
            >
            > >
            >
            > > > file called invisibles_wrong.jpg.
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > If I source my vimrc again, everything is working. You can see the
            >
            > >
            >
            > > > result in the attached imaged called invisibles_right.jpg
            >
            > >
            >
            > > >
            >
            > >
            >
            > > > Can anyone explain why this is happening?
            >
            > >
            >
            > >
            >
            > >
            >
            > > in your .vimrc encoding is probably set to utf-8 only after listchars
            >
            > >
            >
            > > is set. Move the line with
            >
            > >
            >
            > >
            >
            > >
            >
            > > set encoding=utf-8
            >
            > >
            >
            > >
            >
            > >
            >
            > > before the one with
            >
            > >
            >
            > >
            >
            > >
            >
            > > set listchars=tab:►\ ,eol:¬,trail:●
            >
            > >
            >
            > >
            >
            > >
            >
            > > and it should work correctly.
            >
            > >
            >
            > >
            >
            > >
            >
            > > Regards,
            >
            > >
            >
            > > Jürgen
            >
            > >
            >
            > >
            >
            > >
            >
            > > --
            >
            > >
            >
            > > Sometimes I think the surest sign that intelligent life exists elsewhere
            >
            > >
            >
            > > in the universe is that none of it has tried to contact us. (Calvin)
            >
            >
            >
            > I was so happy to see the answer, but the happiness didn't last long. My encoding is set before the listchars. Here is a snapshot of my vimrc
            >
            >
            >
            > " Necessary to show the Unicode glyphs, needed for the vim-powerline plugin.
            >
            > set encoding=utf-8
            >
            >
            >
            > " Set the font
            >
            > if has('win32')
            >
            > set guifont=Consolas:h9:b:cANSI
            >
            > endif
            >
            >
            >
            > " Remove Menu from GUI
            >
            > set guioptions-=m
            >
            > " Remove Toolbar from GUI
            >
            > set guioptions-=T
            >
            >
            >
            > " ===== <Tab> completion =====
            >
            > " list:longest - List all matches and complete the longest match
            >
            > " full - complete the next full match.
            >
            > set wildmode=list:longest,full
            >
            > " Do not use the menu one can go through by using <Tab>. Simply list all the
            >
            > " files.
            >
            > set nowildmenu
            >
            >
            >
            > " Turn on line numbering.
            >
            > set number
            >
            >
            >
            > " Enable syntax highlighting
            >
            > syntax on
            >
            >
            >
            > " Remeber 300 last ex-commands
            >
            > set history=300
            >
            >
            >
            > " Make a buffer hidden when it is abandoned.
            >
            > set hidden
            >
            >
            >
            > " Set the colorscheme
            >
            > " Note: Keep the colorscheme settings after the syntax on command.
            >
            > " As it turns out syntax on reloads colorshcheme again.
            >
            > colorscheme xoria256
            >
            >
            >
            > " Turn on the highlight of the line with the cursor.
            >
            > set cursorline
            >
            > " Set up how to show tabs, end of line, and trailing spaces.
            >
            > set listchars=tab:►\ ,eol:¬,trail:●
            I'm running a GUI version of Vim, but I have no settings in gvimrc.
            I ran :verbose set encoding? listchars? guifont? Here is the result
            encoding=utf-8
            Last set from ~\vimfiles\vimrc
            listchars=tab:<bf> ,eol:<ac>,trail:<bf>
            Last set from ~\vimfiles\vimrc
            guifont=Consolas:h9:b:cANSI
            Last set from ~\vimfiles\vimrc

            Any suggestions?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • FlashBurn
            ... I tried putting scriptencoding utf-8 right at the top of my vimrc but unfortunately nothing changed. :( -- -- You received this message from the vim_use
            Message 5 of 13 , Apr 15, 2014
            • 0 Attachment
              On Tuesday, April 15, 2014 10:40:54 AM UTC-4, FlashBurn wrote:
              > On Tuesday, April 15, 2014 9:56:06 AM UTC-4, FlashBurn wrote:
              >
              > > On Tuesday, April 15, 2014 9:26:27 AM UTC-4, Jürgen Krämer wrote:
              >
              > >
              >
              > > > Hi,
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > FlashBurn wrote:
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > For some reason my invisible characters are not displayed properly. I
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > have to source my vimrc a second time for the 'list' setting to work.
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > Here is my setting for 'listchars'
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > set listchars=tab:►\ ,eol:¬,trail:●
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > The results of the invisibles not being displayed is in the attached
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > file called invisibles_wrong.jpg.
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > If I source my vimrc again, everything is working. You can see the
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > result in the attached imaged called invisibles_right.jpg
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > > Can anyone explain why this is happening?
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > in your .vimrc encoding is probably set to utf-8 only after listchars
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > is set. Move the line with
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > set encoding=utf-8
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > before the one with
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > set listchars=tab:►\ ,eol:¬,trail:●
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > and it should work correctly.
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > Regards,
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > Jürgen
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > --
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > Sometimes I think the surest sign that intelligent life exists elsewhere
              >
              > >
              >
              > > >
              >
              > >
              >
              > > > in the universe is that none of it has tried to contact us. (Calvin)
              >
              > >
              >
              > >
              >
              > >
              >
              > > I was so happy to see the answer, but the happiness didn't last long. My encoding is set before the listchars. Here is a snapshot of my vimrc
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Necessary to show the Unicode glyphs, needed for the vim-powerline plugin.
              >
              > >
              >
              > > set encoding=utf-8
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Set the font
              >
              > >
              >
              > > if has('win32')
              >
              > >
              >
              > > set guifont=Consolas:h9:b:cANSI
              >
              > >
              >
              > > endif
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Remove Menu from GUI
              >
              > >
              >
              > > set guioptions-=m
              >
              > >
              >
              > > " Remove Toolbar from GUI
              >
              > >
              >
              > > set guioptions-=T
              >
              > >
              >
              > >
              >
              > >
              >
              > > " ===== <Tab> completion =====
              >
              > >
              >
              > > " list:longest - List all matches and complete the longest match
              >
              > >
              >
              > > " full - complete the next full match.
              >
              > >
              >
              > > set wildmode=list:longest,full
              >
              > >
              >
              > > " Do not use the menu one can go through by using <Tab>. Simply list all the
              >
              > >
              >
              > > " files.
              >
              > >
              >
              > > set nowildmenu
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Turn on line numbering.
              >
              > >
              >
              > > set number
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Enable syntax highlighting
              >
              > >
              >
              > > syntax on
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Remeber 300 last ex-commands
              >
              > >
              >
              > > set history=300
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Make a buffer hidden when it is abandoned.
              >
              > >
              >
              > > set hidden
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Set the colorscheme
              >
              > >
              >
              > > " Note: Keep the colorscheme settings after the syntax on command.
              >
              > >
              >
              > > " As it turns out syntax on reloads colorshcheme again.
              >
              > >
              >
              > > colorscheme xoria256
              >
              > >
              >
              > >
              >
              > >
              >
              > > " Turn on the highlight of the line with the cursor.
              >
              > >
              >
              > > set cursorline
              >
              > >
              >
              > > " Set up how to show tabs, end of line, and trailing spaces.
              >
              > >
              >
              > > set listchars=tab:►\ ,eol:¬,trail:●
              >
              > I'm running a GUI version of Vim, but I have no settings in gvimrc.
              >
              > I ran :verbose set encoding? listchars? guifont? Here is the result
              >
              > encoding=utf-8
              >
              > Last set from ~\vimfiles\vimrc
              >
              > listchars=tab:<bf> ,eol:<ac>,trail:<bf>
              >
              > Last set from ~\vimfiles\vimrc
              >
              > guifont=Consolas:h9:b:cANSI
              >
              > Last set from ~\vimfiles\vimrc
              >
              >
              >
              > Any suggestions?

              I tried putting scriptencoding utf-8 right at the top of my vimrc but unfortunately nothing changed. :(

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Ben Fritz
              ... A similar problem was discussed recently: https://groups.google.com/d/topic/vim_dev/gkw9zONYReM/discussion Try putting scriptencoding NEAR the top of your
              Message 6 of 13 , Apr 15, 2014
              • 0 Attachment
                On Tuesday, April 15, 2014 10:24:26 AM UTC-5, FlashBurn wrote:
                > I tried putting scriptencoding utf-8 right at the top of my vimrc but unfortunately nothing changed. :(


                A similar problem was discussed recently: https://groups.google.com/d/topic/vim_dev/gkw9zONYReM/discussion

                Try putting scriptencoding NEAR the top of your .vimrc, but AFTER the "set encoding=utf-8" line.

                If that doesn't work, you can try falling back to specifying codepoint values in a string. Both solutions are discussed in the linked thread.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Gary Johnson
                ... Would you please trim all the extra newlines that keep accumulating in your replies? Thanks, Gary -- -- You received this message from the vim_use
                Message 7 of 13 , Apr 15, 2014
                • 0 Attachment
                  On 2014-04-15, FlashBurn wrote:

                  > I tried putting scriptencoding utf-8 right at the top of my vimrc
                  > but unfortunately nothing changed. :(

                  Would you please trim all the extra newlines that keep accumulating
                  in your replies?

                  Thanks,
                  Gary

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • FlashBurn
                  ... Sorry about that. -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
                  Message 8 of 13 , Apr 15, 2014
                  • 0 Attachment
                    > Would you please trim all the extra newlines that keep accumulating
                    >
                    > in your replies?
                    >
                    >
                    >
                    > Thanks,
                    >
                    > Gary

                    Sorry about that.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  • FlashBurn
                    ... Ben, It worked. Thanks everyone. -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
                    Message 9 of 13 , Apr 15, 2014
                    • 0 Attachment
                      > A similar problem was discussed recently: https://groups.google.com/d/topic/vim_dev/gkw9zONYReM/discussion
                      >
                      > Try putting scriptencoding NEAR the top of your .vimrc, but AFTER the "set encoding=utf-8" line.
                      >
                      > If that doesn't work, you can try falling back to specifying codepoint values in a string. Both solutions are discussed in the linked thread.

                      Ben,

                      It worked. Thanks everyone.

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/d/optout.
                    • FlashBurn
                      ... Would anyone be able to explain to me why it worked? I would really appreciate it. Thanks. -- -- You received this message from the vim_use maillist. Do
                      Message 10 of 13 , Apr 15, 2014
                      • 0 Attachment
                        > It worked. Thanks everyone.

                        Would anyone be able to explain to me why it worked? I would really appreciate it.

                        Thanks.

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/d/optout.
                      • Ben Fritz
                        ... I get these added every time I hit reply on the Google Groups interface as well. I can t actually seem to find any bug reporting tool for Google anymore,
                        Message 11 of 13 , Apr 15, 2014
                        • 0 Attachment
                          On Tuesday, April 15, 2014 10:46:28 AM UTC-5, Gary Johnson wrote:
                          >
                          > Would you please trim all the extra newlines that keep accumulating
                          > in your replies?

                          I get these added every time I hit "reply" on the Google Groups interface as well.

                          I can't actually seem to find any bug reporting tool for Google anymore, previously they had a "report issue on this page" button or similar in the gear menu.

                          Anyway...what is an efficient way in Vim to deal with this? The best I came up with, was to record a macro on an extra newline that just did "ddj" and then run that macro with a count of 9999. It seems kludgy though and I'm always afraid I'll trim too much.

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/d/optout.
                        • Michael Henry
                          ... Based on a posting from Andy Wokula some time ago, I ve got a delete rubbish whitespace mapping in my vimrc (shown below). For your use case, the
                          Message 12 of 13 , Apr 15, 2014
                          • 0 Attachment
                            On 04/15/2014 03:02 PM, Ben Fritz wrote:
                            > On Tuesday, April 15, 2014 10:46:28 AM UTC-5, Gary Johnson wrote:
                            >>
                            >> Would you please trim all the extra newlines that keep accumulating
                            >> in your replies?

                            > Anyway...what is an efficient way in Vim to deal with this?
                            > The best I came up with, was to record a macro on an extra
                            > newline that just did "ddj" and then run that macro with a
                            > count of 9999. It seems kludgy though and I'm always afraid
                            > I'll trim too much.

                            Based on a posting from Andy Wokula some time ago, I've got a
                            "delete rubbish whitespace" mapping in my vimrc (shown below).
                            For your use case, the interesting part is the ability to select
                            a run of consecutive whitespace lines using "ip". With your
                            cursor in the run of blank lines, "dip" (or "dvip" as Andy's
                            mapping uses) selects and deletes the blank lines. It can seem
                            counter-intuitive that the "inner paragraph" being selected
                            consists of nothing but whitespace, but it's also convenient :-)

                            The mapping is below. I don't remember how much I changed
                            Andy's logic, so if something looks wrong below, it's likely my
                            fault, not his:

                            " Remove "rubbish" whitespace (from Andy Wokula posting).

                            nnoremap <silent> drw :<C-U>call DeleteRubbishWhitespace()<CR>

                            function! DeleteRubbishWhitespace()
                            " Reduce many spaces or blank lines to one.
                            let saveVirtualEdit = [&virtualedit]
                            set virtualedit=
                            let line = getline(".")
                            if line =~ '^\s*$'
                            let savePos = winsaveview()
                            let saveFoldEnable = &foldenable
                            setlocal nofoldenable
                            normal! dvip0D
                            let savePos.lnum = line(".")
                            let &l:foldenable = saveFoldEnable
                            call winrestview(savePos)
                            elseif line[col(".")-1] =~ '\s'
                            normal! zvyiw
                            if @@ != " "
                            normal! dviwr m[
                            " m[ is just to avoid a trailing space
                            endif
                            endif
                            let [&ve] = saveVirtualEdit
                            " Uncomment the line below if you have the repeat plugin.
                            " silent! call repeat#set("drw")
                            endfunction

                            Michael Henry

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/d/optout.
                          • Kartik Singhal
                            ... At least for GMail web interface, there is a Labs plugin called Quote selected text which lets you quote a particular part of a message to respond to
                            Message 13 of 13 , Apr 15, 2014
                            • 0 Attachment

                              On Wed, Apr 16, 2014 at 12:32 AM, Ben Fritz <fritzophrenic@...> wrote:
                              I get these added every time I hit "reply" on the Google Groups interface as well.

                              I can't actually seem to find any bug reporting tool for Google anymore, previously they had a "report issue on this page" button or similar in the gear menu.

                              At least for GMail web interface, there is a Labs plugin called 'Quote selected text' which lets you quote a particular part of a message to respond to (just like I did in this mail for your OP). Not sure if it works for Google Groups interface or not.


                              --
                              Kartik
                              http://k4rtik.wordpress.com/

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/d/optout.
                            Your message has been successfully submitted and would be delivered to recipients shortly.