Loading ...
Sorry, an error occurred while loading the content.

Many problems, how to debug on startup

Expand Messages
  • Tim Johnson
    I have transitioned my vim resources from OS X 10.7 to ubuntu 12.04 I ve got a real mess and rather than go into the gory details, I need two sets of advice to
    Message 1 of 6 , Apr 14, 2014
    • 0 Attachment
      I have transitioned my vim resources from OS X 10.7 to ubuntu 12.04

      I've got a real mess and rather than go into the gory details, I
      need two sets of advice to begin with

      1) When I start gvim, I get an error message that says "No Mapping
      Found" - most mapping does appear to work, so I need to step through
      gvim startup process.
      -- if I do `gvim -V20', I can see the startup steps, but I need to
      capture those messages in a file 'gvim -V20 > debug.txt' doesn't
      give me any results. Which syntax should I use?

      2)Once I have gvim started, I'm getting erratic results when I
      restore a session. Some sessions are fine, others have the syntax
      highlight turned off and I can't get it to resume, among other
      issues...
      -- similarly, I need a process to step through the session
      restoration.

      Any help would be appreciated, answering the questions above should
      enable me to trouble-shoot. In the meantime, I have a compromised
      development platform.

      TIA
      --
      Tim
      tim at tee jay forty nine dot com or akwebsoft dot com
      http://www.akwebsoft.com, http://www.tj49.com

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Nikolay Pavlov
      ... You should set &verbosefile option in --cmd. ... You can use :debug or use &verbose with &verbosefile, but I doubt this will help. These are helpful if you
      Message 2 of 6 , Apr 14, 2014
      • 0 Attachment


        On Apr 14, 2014 11:07 PM, "Tim Johnson" <tim@...> wrote:
        >
        > I have transitioned my vim resources from OS X 10.7 to ubuntu 12.04
        >
        > I've got a real mess and rather than go into the gory details, I
        > need two sets of advice to begin with
        >
        > 1) When I start gvim, I get an error message that says "No Mapping
        > Found" - most mapping does appear to work, so I need to step through
        > gvim startup process.
        >   -- if I do `gvim -V20', I can see the startup steps, but I need to
        >   capture those messages in a file 'gvim -V20 > debug.txt' doesn't
        >   give me any results. Which syntax should I use?

        You should set &verbosefile option in --cmd.

        >
        > 2)Once I have gvim started, I'm getting erratic results when I
        > restore a session. Some sessions are fine, others have the syntax
        > highlight turned off and I can't get it to resume, among other
        > issues...
        >   -- similarly, I need a process to step through the session
        >   restoration.

        You can use :debug or use &verbose with &verbosefile, but I doubt this will help. These are helpful if you need to determine what and why is run, but much less helpful if you need to determine why something is *not* run.

        ---

        Note that &verbose option may change execution flow, same for :debug. Specifically they are not compatible with some NERDTree functions if they are called inside :try: both &verbose and :debug try to dump returned values under certain circumstances and when they try to do this with recursive (containing themselves) data structures they fail because they use string() code. This failure when happened inside :try is transformed into an exception. I also think (but have not actually checked) that this failure also affects :redir.

        >
        > Any help would be appreciated, answering the questions above should
        > enable me to trouble-shoot. In the meantime, I have a compromised
        > development platform.
        >
        > TIA
        > --
        > Tim
        > tim at tee jay forty nine dot com or akwebsoft dot com
        > http://www.akwebsoft.com, http://www.tj49.com
        >
        > --
        > --
        > You received this message from the "vim_use" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php
        >
        > ---
        > You received this message because you are subscribed to the Google Groups "vim_use" group.
        > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        > For more options, visit https://groups.google.com/d/optout.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Gary Johnson
        ... The syntax is gvim -V20debug.txt The name of the debug output file _immediately_ follows the debug level. Take another look at ... and I think you ll see
        Message 3 of 6 , Apr 14, 2014
        • 0 Attachment
          On 2014-04-14, Tim Johnson wrote:
          > I have transitioned my vim resources from OS X 10.7 to ubuntu 12.04
          >
          > I've got a real mess and rather than go into the gory details, I
          > need two sets of advice to begin with
          >
          > 1) When I start gvim, I get an error message that says "No Mapping
          > Found" - most mapping does appear to work, so I need to step through
          > gvim startup process.
          > -- if I do `gvim -V20', I can see the startup steps, but I need to
          > capture those messages in a file 'gvim -V20 > debug.txt' doesn't
          > give me any results. Which syntax should I use?

          The syntax is

          gvim -V20debug.txt

          The name of the debug output file _immediately_ follows the debug
          level. Take another look at

          :help -V

          and I think you'll see this.

          > 2)Once I have gvim started, I'm getting erratic results when I
          > restore a session. Some sessions are fine, others have the syntax
          > highlight turned off and I can't get it to resume, among other
          > issues...
          > -- similarly, I need a process to step through the session
          > restoration.

          You could single-step through the restoration process by prefixing
          the restore command with ":debug" (see ":help :debug"), but that
          could be really tedious.

          I don't often save and restore sessions, so I probably can't offer
          much useful guidance with that.

          HTH,
          Gary

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Tim Johnson
          ... Thanks for the prompt reply - I have placed set verbose=1 in my .gvimrc Now when I start gvim, I got a whole lot of error messages of the sort like not
          Message 4 of 6 , Apr 14, 2014
          • 0 Attachment
            * Nikolay Pavlov <zyx.vim@...> [140414 11:22]:
            > > capture those messages in a file 'gvim -V20 > debug.txt' doesn't
            > > give me any results. Which syntax should I use?
            >
            > You should set &verbosefile option in --cmd.
            Thanks for the prompt reply -
            I have placed set verbose=1
            in my .gvimrc
            Now when I start gvim, I got a whole lot of error messages of the
            sort like
            'not found in 'runtimepath': "bitmaps/Open.png"'
            I think that is a holdover from macvim - but I don't why gvim is
            attempting to load those images or what to do about it.
            >
            > >
            > > 2)Once I have gvim started, I'm getting erratic results when I
            > > restore a session. Some sessions are fine, others have the syntax
            > > highlight turned off and I can't get it to resume, among other
            > > issues...
            > > -- similarly, I need a process to step through the session
            > > restoration.
            >
            > You can use :debug or use &verbose with &verbosefile, but I doubt this will
            > help. These are helpful if you need to determine what and why is run, but
            > much less helpful if you need to determine why something is *not* run.
            Using :debug from command I can see the following

            "repeat.txt" [readonly] 680L, 27209C
            Reading viminfo file "/home/tim/.viminfo" marks
            not found in 'runtimepath': "ftplugin/text.vim ftplugin/text_*.vim
            ftplugin/text
            /*.vim"
            not found in 'runtimepath': "indent/text.vim"
            not found in 'runtimepath': "syntax/text.vim syntax/text/*.vim"
            not found in 'runtimepath': "indent/help.vim"
            not found in 'runtimepath': "indent/help.vim"
            "
            I see my runtimepath as

            /home/tim/.vim,
            /var/lib/vim/addons,
            /usr/share/vim/vimfiles,
            /usr/share/vim/vim71,
            /usr/share/vim/vimfiles/after,
            /var/lib/vim/addons/after,
            /home/tim/.vim/after

            The fourth path is messed up - there is no /usr/share/vim/vim71
            should be /usr/share/vim/vim73 (I presume).

            So, how to fix runtimepath?

            thanks again

            --
            Tim
            tim at tee jay forty nine dot com or akwebsoft dot com
            http://www.akwebsoft.com, http://www.tj49.com

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Tim Johnson
            ... Big help, Gary, thanks. BTW: Fixed syntax clobbering when restoring sessions, runtimepath was hard coded in the session file and pointed to the macVim
            Message 5 of 6 , Apr 14, 2014
            • 0 Attachment
              * Gary Johnson <garyjohn@...> [140414 11:34]:
              > On 2014-04-14, Tim Johnson wrote:
              > > I have transitioned my vim resources from OS X 10.7 to ubuntu 12.04
              > >
              > > I've got a real mess and rather than go into the gory details, I
              > > need two sets of advice to begin with
              > >
              > > 1) When I start gvim, I get an error message that says "No Mapping
              > > Found" - most mapping does appear to work, so I need to step through
              > > gvim startup process.
              > > -- if I do `gvim -V20', I can see the startup steps, but I need to
              > > capture those messages in a file 'gvim -V20 > debug.txt' doesn't
              > > give me any results. Which syntax should I use?
              >
              > The syntax is
              >
              > gvim -V20debug.txt
              >
              > The name of the debug output file _immediately_ follows the debug
              > level. Take another look at
              >
              > :help -V
              >
              > and I think you'll see this.
              >
              > > 2)Once I have gvim started, I'm getting erratic results when I
              > > restore a session. Some sessions are fine, others have the syntax
              > > highlight turned off and I can't get it to resume, among other
              > > issues...
              > > -- similarly, I need a process to step through the session
              > > restoration.
              >
              > You could single-step through the restoration process by prefixing
              > the restore command with ":debug" (see ":help :debug"), but that
              > could be really tedious.
              >
              > I don't often save and restore sessions, so I probably can't offer
              > much useful guidance with that.
              >
              > HTH,
              Big help, Gary, thanks.

              BTW: Fixed syntax clobbering when restoring sessions, runtimepath
              was hard coded in the session file and pointed to the macVim
              version, which _is_ '71'.

              I'm making progress thanks to you folks.


              > --
              > --
              > You received this message from the "vim_use" maillist.
              > Do not top-post! Type your reply below the text you are replying to.
              > For more information, visit http://www.vim.org/maillist.php
              >
              > ---
              > You received this message because you are subscribed to the Google Groups "vim_use" group.
              > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              > For more options, visit https://groups.google.com/d/optout.

              --
              Tim
              tim at tee jay forty nine dot com or akwebsoft dot com
              http://www.akwebsoft.com, http://www.tj49.com

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Tim Johnson
              ... I now have my vim functioning. I m still seeing some issues when I set verbose to 1, but doesn t seem to be a critical issue. When time permits in the next
              Message 6 of 6 , Apr 14, 2014
              • 0 Attachment
                * Tim Johnson <tim@...> [140414 12:03]:
                > * Gary Johnson <garyjohn@...> [140414 11:34]:
                > > On 2014-04-14, Tim Johnson wrote:
                > I'm making progress thanks to you folks.
                I now have my vim functioning. I'm still seeing some issues when
                I set verbose to 1, but doesn't seem to be a critical issue.
                When time permits in the next day or so, I will revisit them just
                for grins.

                I the meantime, I want to thank Gary and Nikolay for their help.
                It was just what the doctor ordered :).
                cheers
                --
                Tim
                tim at tee jay forty nine dot com or akwebsoft dot com
                http://www.akwebsoft.com, http://www.tj49.com

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.