Loading ...
Sorry, an error occurred while loading the content.

dtd2vim

Expand Messages
  • russurquhart1@...
    Hi, I am trying to use the dtd2vim perl script. I have perl installed, and have been able to use other perl installations, but this one doesn t seem to work. I
    Message 1 of 4 , Apr 11, 2014
    • 0 Attachment
      Hi,

      I am trying to use the dtd2vim perl script. I have perl installed, and have been able to use other perl installations, but this one doesn't seem to work.

      I sent some email to the developer, but haven't heard anything. Has anyone used this, or had any success?


      Thanks,


      Russ

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • John Little
      ... doesn t seem to work ... not a lot to go on...;) Does it say something beginning with Can t locate SGML/DTD.pm in @INC ... If so, you d use cpan or cpanp
      Message 2 of 4 , Apr 12, 2014
      • 0 Attachment
        On Saturday, April 12, 2014 5:11:08 AM UTC+12, russur wrote:
        > I am trying to use the dtd2vim perl script. I have perl installed, and have been able to use other perl installations, but this one doesn't seem to work.

        "doesn't seem to work"... not a lot to go on...;)

        Does it say something beginning with
        Can't locate SGML/DTD.pm in @INC ...

        If so, you'd use cpan or cpanp to install SGML::DTD, needed by the dtd2vim script.

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Russell Urquhart
        Hi, That must be it, because that was my error. The install didn t say anything, as i recall about using cpan, so i assumed the install that came with the perl
        Message 3 of 4 , Apr 12, 2014
        • 0 Attachment
          Hi,

          That must be it, because that was my error. The install didn't say anything, as i recall about using cpan, so i assumed the install that came with the perl code was all that was needed. I'll give that a try!

          Thanks,


          Russ



          On Sat, Apr 12, 2014 at 03:32:11AM -0700, John Little wrote:
          > On Saturday, April 12, 2014 5:11:08 AM UTC+12, russur wrote:
          > > I am trying to use the dtd2vim perl script. I have perl installed, and have been able to use other perl installations, but this one doesn't seem to work.
          >
          > "doesn't seem to work"... not a lot to go on...;)
          >
          > Does it say something beginning with
          > Can't locate SGML/DTD.pm in @INC ...
          >
          > If so, you'd use cpan or cpanp to install SGML::DTD, needed by the dtd2vim script.
          >
          > Regards, John Little
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to the Google Groups "vim_use" group.
          > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/d/optout.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Russell Urquhart
          Hi, It turned out that the latest (2009?) build installed via its own installer. Cpan didn t work and wasn t necessary. My other question, after using it, is
          Message 4 of 4 , Apr 15, 2014
          • 0 Attachment
            Hi,

            It turned out that the latest (2009?) build installed via its own installer. Cpan didn't work and wasn't necessary.

            My other question, after using it, is that perlSGML seems to parse a given DTD, but it outputs the element names in lowercase. (Some of our element names have mixed case), this causes incorrect element names to be entered. Does anyone know how to have it keep the element names untouched.

            Also, does anyone know if there is a version that will parse schema files accordingly?

            Thanks for all your help!


            Russ


            On Sat, Apr 12, 2014 at 03:32:11AM -0700, John Little wrote:

            >
            > If so, you'd use cpan or cpanp to install SGML::DTD, needed by the dtd2vim script.
            >
            > Regards, John Little
            >

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.