Loading ...
Sorry, an error occurred while loading the content.
 

Colorscheme and tmux

Expand Messages
  • Gautier DI FOLCO
    Hi all I have a strange error with tmux 1.9 and ViM 7.4.214: I have this homemade colorscheme (http://pastebin.com/xafgX835) which works perfectly outside of
    Message 1 of 5 , Apr 9, 2014
      Hi all

      I have a strange error with tmux 1.9 and ViM 7.4.214:
      I have this homemade colorscheme (http://pastebin.com/xafgX835) which works perfectly outside of tmux (and worked perfectly before an update) and when I run it inside ViM inside tmux, it prints almost no color (some yellow lines, but that's it).

      I have set t_Co=256 and colors work well in zsh or with other colorschemes.

      Have you got an idea on what's wrong with my colorscheme?

      Thanks by advance for your help.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • Matteo Cavalleri
      ... I ve had some problem with colors under tmux and solved them with this config: if exists( $TMUX ) || exists( $SSH_TTY ) set t_ut= endif I m not sure if it
      Message 2 of 5 , Apr 9, 2014
        > Have you got an idea on what's wrong with my colorscheme?
        >
        > Thanks by advance for your help.

        I've had some problem with colors under tmux and solved them with this config:

        if exists('$TMUX') || exists('$SSH_TTY')
        set t_ut=
        endif

        I'm not sure if it will solve yours as well, but try it :)

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Gautier DI FOLCO
        ... Nothing changed, but thanks :) -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 5 , Apr 9, 2014
          2014-04-09 17:10 GMT+02:00 Matteo Cavalleri <cvlmtg@...>:
          > Have you got an idea on what's wrong with my colorscheme?
          >
          > Thanks by advance for your help.

          I've had some problem with colors under tmux and solved them with this config:

          if exists('$TMUX') || exists('$SSH_TTY')
              set t_ut=
          endif

          I'm not sure if it will solve yours as well, but try it :)


          Nothing changed, but thanks :)

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Sven Guckes
          ... well.. which terminal are you using? tmux comes with support for 88 and 256 colors. see man tmux , look for terminal-overrides . havent tried/verified it
          Message 4 of 5 , Apr 9, 2014
            * Gautier DI FOLCO <gautier.difolco@...> [2014-04-09 18:20]:
            > I have a strange error with tmux 1.9 and ViM 7.4.214:
            >
            > I have this homemade colorscheme (http://pastebin.com/xafgX835)
            > which works perfectly outside of tmux (and worked perfectly before
            > an update) and when I run it inside ViM inside tmux, it
            > prints almost no color (some yellow lines, but that's it).
            >
            > I have set t_Co=256 and colors work well
            > in zsh or with other colorschemes.
            > Have you got an idea on what's
            > wrong with my colorscheme?

            well.. which terminal are you using?

            tmux comes with support for 88 and 256 colors.
            see "man tmux", look for "terminal-overrides".
            havent tried/verified it myself yet.
            but will hopefully soon.

            if this works for you then
            please let us know! thanks.

            Sven [finally switching from screen to tmux]

            --
            TMUX - Terminal MUltipleXer - TMUX 1.9a [2014-02-22]
            home: http://tmux.sourceforge.net/
            http://sf.net/projects/tmux
            wiki: http://en.wikipedia.org/wiki/Tmux
            mail: tmux-users@...
            irc: irc.freenode.net/tmux
            book: http://pragprog.com/book/bhtmux/tmux
            ChangeLog: https://sourceforge.net/p/tmux/tmux-code/ci/master/tree/CHANGES
            manual: http://www.openbsd.org/cgi-bin/man.cgi?query=tmux&sektion=1
            https://lists.sourceforge.net/lists/listinfo/tmux-users
            https://lists.sourceforge.net/lists/listinfo/tmux-cvs

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Gautier DI FOLCO
            ... Thanks you for your answer, I use Konsole (KDE). I m not really sure on what to do. The strange part of this issue is that it works relatively well with
            Message 5 of 5 , Apr 9, 2014
              2014-04-09 20:21 GMT+02:00 Sven Guckes <guckes@...>:
              * Gautier DI FOLCO <gautier.difolco@...> [2014-04-09 18:20]:
              > I have a strange error with tmux 1.9 and ViM 7.4.214:
              >
              > I have this homemade colorscheme (http://pastebin.com/xafgX835)
              > which works perfectly outside of tmux (and worked perfectly before
              > an update) and when I run it inside ViM inside tmux, it
              > prints almost no color (some yellow lines, but that's it).
              >
              > I have set t_Co=256 and colors work well
              > in zsh or with other colorschemes.
              > Have you got an idea on what's
              > wrong with my colorscheme?

              well.. which terminal are you using?

              tmux comes with support for 88 and 256 colors.
              see "man tmux", look for "terminal-overrides".
              havent tried/verified it myself yet.
              but will hopefully soon.

              if this works for you then
              please let us know! thanks.

              Sven  [finally switching from screen to tmux]

              --
              TMUX - Terminal MUltipleXer - TMUX 1.9a [2014-02-22]
              home:   http://tmux.sourceforge.net/
                      http://sf.net/projects/tmux
              wiki:   http://en.wikipedia.org/wiki/Tmux
              mail:   tmux-users@...
              irc:    irc.freenode.net/tmux
              book:   http://pragprog.com/book/bhtmux/tmux
              ChangeLog: https://sourceforge.net/p/tmux/tmux-code/ci/master/tree/CHANGES
              manual: http://www.openbsd.org/cgi-bin/man.cgi?query=tmux&sektion=1
              https://lists.sourceforge.net/lists/listinfo/tmux-users
              https://lists.sourceforge.net/lists/listinfo/tmux-cvs

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.

              Thanks you for your answer,

              I use Konsole (KDE).
              I'm not really sure on what to do.
              The strange part of this issue is that it works relatively well with others standard colorschemes.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            Your message has been successfully submitted and would be delivered to recipients shortly.