Loading ...
Sorry, an error occurred while loading the content.

about colors schemes in terminal vim

Expand Messages
  • Ivan Ivanivich
    i found some color schemes on http://vimcolorschemetest.googlecode.com/ these schemes work well in vim-gtk, but not work in xfce4-terminal vim. how i can use
    Message 1 of 6 , Apr 7, 2014
    • 0 Attachment
      i found some color schemes on http://vimcolorschemetest.googlecode.com/

      these schemes work well in vim-gtk, but not work in xfce4-terminal vim.

      how i can use these schemes in xfce4-terminal? if it is possible.

      some of my configs:

      ivr@nout:~$ ls ~/.vim/colors/
      buttercream.vim
      ivr@nout:~$ env | grep TERM
      TERM=xterm-256color
      COLORTERM=Terminal
      ivr@nout:~$ cat ~/.vimrc | grep t_Co
      set t_Co=256
      ivr@nout:~$ cat ~/.vimrc | grep color
      color buttercream
      ivr@nout:~$

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • John Little
      ... (Near the top of buttercream.vim is the comment As of now only gui is supported ) Install the CSApprox.vim plugin from vim.org, and it will automatically
      Message 2 of 6 , Apr 7, 2014
      • 0 Attachment
        On Monday, April 7, 2014 11:49:14 PM UTC+12, Ivan Ivanivich wrote:

        > color buttercream

        (Near the top of buttercream.vim is the comment "As of now only gui is supported")

        Install the CSApprox.vim plugin from vim.org, and it will automatically translate the gui colors to terminal ones.

        (I don't care for the results with buttercream though, subtly less contrast than buttercream in gvim; but then I like dark background schemes for the increased contrast.)

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Ivan Ivanivich
        ... i will try it, thank -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
        Message 3 of 6 , Apr 8, 2014
        • 0 Attachment
          вторник, 8 апреля 2014 г., 1:24:38 UTC+4 пользователь John Little написал:
          > On Monday, April 7, 2014 11:49:14 PM UTC+12, Ivan Ivanivich wrote:
          >
          > > color buttercream
          >
          > (Near the top of buttercream.vim is the comment "As of now only gui is supported")
          >
          > Install the CSApprox.vim plugin from vim.org, and it will automatically translate the gui colors to terminal ones.
          >
          > (I don't care for the results with buttercream though, subtly less contrast than buttercream in gvim; but then I like dark background schemes for the increased contrast.)
          >
          > Regards, John Little

          i will try it, thank

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Ivan Ivanivich
          ... thank you very much, everything works perfectly but for 256 colors in xfce4-terminal need do the next steps: install ncurses-term and set up environment:
          Message 4 of 6 , Apr 8, 2014
          • 0 Attachment
            On Tuesday, April 8, 2014 1:24:38 AM UTC+4, John Little wrote:
            > On Monday, April 7, 2014 11:49:14 PM UTC+12, Ivan Ivanivich wrote:
            >

            thank you very much, everything works perfectly

            but for 256 colors in xfce4-terminal need do the next steps:

            install ncurses-term

            and set up environment: export TERM=xterm-256color

            in ~/.vimrc: set t_Co=256

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • Tony Mechelynck
            ... See also http://vim.wikia.com/wiki/Using_GUI_color_settings_in_a_terminal Of course, you should not use this values of $TERM and t_Co when running in a
            Message 5 of 6 , Apr 8, 2014
            • 0 Attachment
              On 08/04/14 11:54, Ivan Ivanivich wrote:
              > On Tuesday, April 8, 2014 1:24:38 AM UTC+4, John Little wrote:
              >> On Monday, April 7, 2014 11:49:14 PM UTC+12, Ivan Ivanivich wrote:
              >>
              >
              > thank you very much, everything works perfectly
              >
              > but for 256 colors in xfce4-terminal need do the next steps:
              >
              > install ncurses-term
              >
              > and set up environment: export TERM=xterm-256color
              >
              > in ~/.vimrc: set t_Co=256
              >
              See also http://vim.wikia.com/wiki/Using_GUI_color_settings_in_a_terminal

              Of course, you should not use this values of $TERM and 't_Co' when
              running in a terminal which is unable to display 256 colors (such as the
              Linux non-X consoles, which have only 16 colors, or maybe 16 foreground
              and 8 background).

              I use

              " use 256 colors in Console mode if we think the terminal supports it
              if &term =~? 'mlterm\|xterm'
              set t_Co=256
              endif

              near the top of my vimrc. (My konsole and gnome-terminal terminals
              support 256 colors, and they set $TERM to "xterm". Starting the GUI,
              which happens later if ever, always sets 'term' to "builtin_gui" and
              't_Co' to empty, neither of which can be changed.) Of course, if you use
              other terminals than I do, you may want to use a different if-condition.


              Best regards,
              Tony.
              --
              hundred-and-one symptoms of being an internet addict:
              106. When told to "go to your room" you inform your parents that you
              can't...because you were kicked out and banned.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • Ivan Ivanivich
              ... and I did something in my ~/.bashrc: if [[ $TERM == xterm ]] ; then export TERM= xterm-256color fi if i work in black linux terminal, then $TERM set
              Message 6 of 6 , Apr 9, 2014
              • 0 Attachment
                On Wednesday, April 9, 2014 6:47:35 AM UTC+4, Tony Mechelynck wrote:
                > On 08/04/14 11:54, Ivan Ivanivich wrote:
                >
                > > On Tuesday, April 8, 2014 1:24:38 AM UTC+4, John Little wrote:
                >
                > >> On Monday, April 7, 2014 11:49:14 PM UTC+12, Ivan Ivanivich wrote:
                >
                > >>
                >
                > >
                >
                > > thank you very much, everything works perfectly
                >
                > >
                >
                > > but for 256 colors in xfce4-terminal need do the next steps:
                >
                > >
                >
                > > install ncurses-term
                >
                > >
                >
                > > and set up environment: export TERM=xterm-256color
                >
                > >
                >
                > > in ~/.vimrc: set t_Co=256
                >
                > >
                >
                > See also http://vim.wikia.com/wiki/Using_GUI_color_settings_in_a_terminal
                >
                >
                >
                > Of course, you should not use this values of $TERM and 't_Co' when
                >
                > running in a terminal which is unable to display 256 colors (such as the
                >
                > Linux non-X consoles, which have only 16 colors, or maybe 16 foreground
                >
                > and 8 background).
                >
                >
                >
                > I use
                >
                >
                >
                > " use 256 colors in Console mode if we think the terminal supports it
                >
                > if &term =~? 'mlterm\|xterm'
                >
                > set t_Co=256
                >
                > endif
                >
                >
                >
                > near the top of my vimrc. (My konsole and gnome-terminal terminals
                >
                > support 256 colors, and they set $TERM to "xterm". Starting the GUI,
                >
                > which happens later if ever, always sets 'term' to "builtin_gui" and
                >
                > 't_Co' to empty, neither of which can be changed.) Of course, if you use
                >
                > other terminals than I do, you may want to use a different if-condition.
                >
                >
                >
                >
                >
                > Best regards,
                >
                > Tony.
                >
                > --
                >
                > hundred-and-one symptoms of being an internet addict:
                >
                > 106. When told to "go to your room" you inform your parents that you
                >
                > can't...because you were kicked out and banned.


                and I did something in my ~/.bashrc:

                if [[ "$TERM" == "xterm" ]] ; then
                export TERM="xterm-256color"
                fi

                if i work in "black" linux terminal, then $TERM set up as "Linux" and if i set $TERM as xterm-256color in "black termenal" then it leads to bugs in terminal

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              Your message has been successfully submitted and would be delivered to recipients shortly.