Loading ...
Sorry, an error occurred while loading the content.

How to take omni-complete operation effect in Windows using vim73

Expand Messages
  • weichanghe2000@...
    I am using vim in Windows system. but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing in
    Message 1 of 8 , Mar 23, 2014
    • 0 Attachment
      I am using vim in Windows system.
      but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
      However, it can list 203 words when vim 1.pl and then pressing <C-X><C-O> in Linux,
      _vimrc part setting is shown as below:
      set nocp
      filetype plugin on
      set ofu=syntaxcomplete#Complete
      imap <silent> ` <C-X><C-O>


      some detail description can be visist http://bbs.chinaunix.net/thread-4132366-1-1.html.

      Is anybody familiar with vim setting in windows?
      Any help and solution will be appreciated.
      Thanks advance firstly.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/d/optout.
    • weichanghe2000@...
      I am using vim in Windows system. but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing in
      Message 2 of 8 , Mar 23, 2014
      • 0 Attachment
        I am using vim in Windows system.
        but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
        However, it can list 203 words when vim 1.pl and then pressing <C-X><C-O> in Linux,
        _vimrc part setting is shown as below:
        set nocp
        filetype plugin on
        set ofu=syntaxcomplete#Complete
        imap <silent> ` <C-X><C-O>

        some detail description can be visist http://bbs.chinaunix.net/thread-4132366-1-1.html.

        Is anybody familiar with vim setting in windows?
        Any help and solution will be appreciated.
        Thanks advance firstly.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Ben Fritz
        ... I do not normally have problems with Vim omni complete on Windows. But then, you just say Vim 7.3 so I assume you re still using the first 7.3 release,
        Message 3 of 8 , Mar 23, 2014
        • 0 Attachment
          On Sunday, March 23, 2014 3:09:49 AM UTC-5, weichan...@... wrote:
          > I am using vim in Windows system.
          > but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
          > However, it can list 203 words when vim 1.pl and then pressing <C-X><C-O> in Linux,
          > _vimrc part setting is shown as below:
          > set nocp
          > filetype plugin on
          > set ofu=syntaxcomplete#Complete
          > imap <silent> ` <C-X><C-O>
          >
          > some detail description can be visist http://bbs.chinaunix.net/thread-4132366-1-1.html.
          >
          > Is anybody familiar with vim setting in windows?
          > Any help and solution will be appreciated.
          > Thanks advance firstly.

          I do not normally have problems with Vim omni complete on Windows.

          But then, you just say "Vim 7.3" so I assume you're still using the first 7.3 release, and not a more recently patched version. That came out 4 years ago. Can you try upgrading? The most recent version is now 7.4.212. You can get an installer for a fairly recent version (currently 7.4.205) here: http://sourceforge.net/projects/cream/files/Vim/

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Christian Brabandt
          ... Could it be, the syntax script was not loaded properly? There is no ... .vimrc, perhaps this is causing the problem (although, I would expect no
          Message 4 of 8 , Mar 24, 2014
          • 0 Attachment
            Am 2014-03-23 09:09, schrieb weichanghe2000@...:
            > I am using vim in Windows system.
            > but I meet a omni-complete problem that it can only list 7 words
            > automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
            > However, it can list 203 words when vim 1.pl and then pressing
            > <C-X><C-O> in Linux,
            > _vimrc part setting is shown as below:
            > set nocp
            > filetype plugin on
            > set ofu=syntaxcomplete#Complete
            > imap <silent> ` <C-X><C-O>

            Could it be, the syntax script was not loaded properly? There is no
            :syntax on statement in your
            .vimrc, perhaps this is causing the problem (although, I would expect no
            syntaxcompletion at all
            in that particular case). Does :syn list show you any output?

            Best,
            Christian

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          • weichanghe2000@...
            ... Thank you with your reply. Unfortunately, I have already add :syntax on sentence in my .vimrc. But it do not work. -- -- You received this message from
            Message 5 of 8 , Mar 24, 2014
            • 0 Attachment
              On Monday, March 24, 2014 8:35:57 PM UTC+8, Christian Brabandt wrote:
              > Am 2014-03-23 09:09, schrieb weichanghe2000@...:
              >
              > > I am using vim in Windows system.
              >
              > > but I meet a omni-complete problem that it can only list 7 words
              >
              > > automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
              >
              > > However, it can list 203 words when vim 1.pl and then pressing
              >
              > > <C-X><C-O> in Linux,
              >
              > > _vimrc part setting is shown as below:
              >
              > > set nocp
              >
              > > filetype plugin on
              >
              > > set ofu=syntaxcomplete#Complete
              >
              > > imap <silent> ` <C-X><C-O>
              >
              >
              >
              > Could it be, the syntax script was not loaded properly? There is no
              >
              > :syntax on statement in your
              >
              > .vimrc, perhaps this is causing the problem (although, I would expect no
              >
              > syntaxcompletion at all
              >
              > in that particular case). Does :syn list show you any output?
              >
              >
              >
              > Best,
              >
              > Christian

              Thank you with your reply.
              Unfortunately, I have already add ':syntax on' sentence in my .vimrc.
              But it do not work.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/d/optout.
            • weichanghe2000@...
              ... Thanks you very much. But I have got an incorrent display when I download from http://sourceforge.net/projects/cream/files/Vim/. And then I download
              Message 6 of 8 , Mar 24, 2014
              • 0 Attachment
                On Sunday, March 23, 2014 10:59:54 PM UTC+8, Ben Fritz wrote:
                > On Sunday, March 23, 2014 3:09:49 AM UTC-5, weichan...@... wrote:
                > > I am using vim in Windows system.
                > > but I meet a omni-complete problem that it can only list 7 words automatically when vim 1.pl and then pressing <C-X><C-O> in windows,
                > > However, it can list 203 words when vim 1.pl and then pressing <C-X><C-O> in Linux,
                > > _vimrc part setting is shown as below:
                > > set nocp
                > > filetype plugin on
                > > set ofu=syntaxcomplete#Complete
                > > imap <silent> ` <C-X><C-O>
                > >
                > > some detail description can be visist http://bbs.chinaunix.net/thread-4132366-1-1.html.
                > >
                > > Is anybody familiar with vim setting in windows?
                > > Any help and solution will be appreciated.
                > > Thanks advance firstly.
                >
                > I do not normally have problems with Vim omni complete on Windows.
                >
                > But then, you just say "Vim 7.3" so I assume you're still using the first 7.3 release, and not a more recently patched version. That came out 4 years ago. Can you try upgrading? The most recent version is now 7.4.212. You can get an installer for a fairly recent version (currently 7.4.205) here: http://sourceforge.net/projects/cream/files/Vim/


                Thanks you very much.
                But I have got an incorrent display when I download from http://sourceforge.net/projects/cream/files/Vim/.
                And then I download vim7.4 from http://www.vim.org/download.php#pc,
                It looks like well and satisfy my desired result when pressing <C-X><C-O> After installing.
                I post two figure as a proof finally.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/d/optout.
              • Christian Brabandt
                ... Then you might want to check with the maintainer of the plugin (look into the syntaxcomplete.vim script for his name/adress). He can likely figure out,
                Message 7 of 8 , Mar 24, 2014
                • 0 Attachment
                  Am 2014-03-24 16:23, schrieb weichanghe2000@...:
                  > Thank you with your reply.
                  > Unfortunately, I have already add ':syntax on' sentence in my .vimrc.
                  > But it do not work.

                  Then you might want to check with the maintainer of the plugin (look
                  into the syntaxcomplete.vim script for his name/adress).
                  He can likely figure out, what's going on in your case.

                  Best,
                  Christian

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/d/optout.
                • David Fishburn
                  ... Does that mean your issue is resolved? David (the maintainer of syntaxcomplete.vim) -- -- You received this message from the vim_use maillist. Do not
                  Message 8 of 8 , Mar 24, 2014
                  • 0 Attachment
                    ...

                     
                    Thanks you very much.
                    But I have got an incorrent display when I download from  http://sourceforge.net/projects/cream/files/Vim/.
                    And then I download vim7.4 from http://www.vim.org/download.php#pc,
                    It looks like well and satisfy my desired result when pressing <C-X><C-O> After installing.
                    I post two figure as a proof finally.

                    Does that mean your issue is resolved?

                    David (the maintainer of syntaxcomplete.vim)
                     

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/d/optout.
                  Your message has been successfully submitted and would be delivered to recipients shortly.