Loading ...
Sorry, an error occurred while loading the content.
 

Cannot edit remote file via ftp

Expand Messages
  • Lucas Sanner
    Hi, I d like to browse directories and edit files on my ubuntu server (set up with VirtualBox) through GVim (under Windows 7). So I m trying to use ftp
    Message 1 of 9 , Feb 6, 2014
      Hi,

      I'd like to browse directories and edit files on my ubuntu server (set up with VirtualBox) through GVim (under Windows 7).
      So I'm trying to use ftp protocol with GVim but it doesn't work.

      According to the netrw documentation, I type:

      e: ftp//user@192.168.0.46/mydirectory/

      and I'm asked for password then I get the list view (the same I get with :Explore command).
      BUT whenever I press the enter key to enter a directory or edit a file, I get the message
      "Press Enter or type a command" at the bottom of the screen, but nothing happen when I press Enter.

      What's wrong ?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles Campbell
      ... No idea -- obviously I can t use that address myself for testing. May I suggest looking at :he netrw-debug . Also, please include the vim version you re
      Message 2 of 9 , Feb 6, 2014
        Lucas Sanner wrote:
        > Hi,
        >
        > I'd like to browse directories and edit files on my ubuntu server (set up with VirtualBox) through GVim (under Windows 7).
        > So I'm trying to use ftp protocol with GVim but it doesn't work.
        >
        > According to the netrw documentation, I type:
        >
        > e: ftp//user@192.168.0.46/mydirectory/
        >
        > and I'm asked for password then I get the list view (the same I get with :Explore command).
        > BUT whenever I press the enter key to enter a directory or edit a file, I get the message
        > "Press Enter or type a command" at the bottom of the screen, but nothing happen when I press Enter.
        >
        > What's wrong ?
        >
        No idea -- obviously I can't use that address myself for testing. May I
        suggest looking at :he netrw-debug .

        Also, please include the vim version you're using and the netrw version
        you're using (its up to v150 now, you can get it from
        http://www.drchip.org/astronaut/vim/index.html#NETRW).

        What happens when you try to use ftp from the command line?

        Regards,
        Charles Campbell

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Lucas Sanner
        Thanks for you response. I m using the 7.4 version, but I don t know how to get the netrw version. ftp works fine in command line and with my ftp software. The
        Message 3 of 9 , Feb 6, 2014
          Thanks for you response.

          I'm using the 7.4 version, but I don't know how to get the netrw version.
          ftp works fine in command line and with my ftp software.


          The only clue I have is that whenever I try to enter a directory (mysubdirectory for instance), it is added to the path (at the top of the screen).

          ftp//user@192.168.0.46/mydirectory/mysubdirectory/mysubdirectory/mysubdirectory/


          Does that ring a bell ?


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Charles Campbell
          ... Not really. To get the latest version of netrw, which may or may not affect this issue, use: http://www.drchip.org/astronaut/vim/index.html#NETRW When you
          Message 4 of 9 , Feb 6, 2014
            Lucas Sanner wrote:
            > Thanks for you response.
            >
            > I'm using the 7.4 version, but I don't know how to get the netrw version.
            > ftp works fine in command line and with my ftp software.
            >
            >
            > The only clue I have is that whenever I try to enter a directory (mysubdirectory for instance), it is added to the path (at the top of the screen).
            >
            > ftp//user@192.168.0.46/mydirectory/mysubdirectory/mysubdirectory/mysubdirectory/
            >
            >
            > Does that ring a bell ?
            >
            >
            Not really. To get the latest version of netrw, which may or may not
            affect this issue, use:

            http://www.drchip.org/astronaut/vim/index.html#NETRW

            When you click on the title "Network Oriented Reading, Writing, and
            Browsing" you should get the file netrw.vba.gz. Then

            vim netrw.vba.gz
            :so %
            :q

            will activate it.

            Regards,
            C Campbell

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Lucas Sanner
            The issue still occurs after install the last plugin version. When I attempt to edit a file (which does exist on the server) I get the message No such file or
            Message 5 of 9 , Feb 6, 2014
              The issue still occurs after install the last plugin version.
              When I attempt to edit a file (which does exist on the server) I
              get the message "No such file or directory".

              I just don't get it.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Charles Campbell
              ... OK, now read :help netrw-debug . You ll need to get a debugging trace; be sure to remove any passwords from the debugging trace first (unless you don t
              Message 6 of 9 , Feb 6, 2014
                Lucas Sanner wrote:
                > The issue still occurs after install the last plugin version.
                > When I attempt to edit a file (which does exist on the server) I
                > get the message "No such file or directory".
                >
                > I just don't get it.
                >
                OK, now read :help netrw-debug . You'll need to get a debugging trace;
                be sure to remove any passwords from the debugging trace first (unless
                you don't care if I have them). Please try to do the minimal set of
                commands that cause the problem.

                Regards,
                C Campbell

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Lucas Sanner
                Ok, this is the debugging trace file (without passwords). The steps I did are: - Connect to my remote server via ftp - Log in - Attempt to enter a directory by
                Message 7 of 9 , Feb 6, 2014
                  Ok, this is the debugging trace file (without passwords).

                  The steps I did are:

                  - Connect to my remote server via ftp
                  - Log in
                  - Attempt to enter a directory by pressing Enter
                  - Attempt to edit a file by pressing Enter

                  That's all.
                  I hope you will be able to detect what's wrong.


                  Thanks

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Lucas Sanner
                  Has no one ever ran into this issue ? Can someone help me ? -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below
                  Message 8 of 9 , Feb 9, 2014
                    Has no one ever ran into this issue ?
                    Can someone help me ?


                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Charles Campbell
                    ... Hello! It seems that you typed: vim ftp://datamigo@192.168.0.46/myweb/ but there is no directory or file named myweb on that system; there is a directory
                    Message 9 of 9 , Feb 28, 2014
                      Lucas Sanner wrote:
                      > Ok, this is the debugging trace file (without passwords).
                      >
                      > The steps I did are:
                      >
                      > - Connect to my remote server via ftp
                      > - Log in
                      > - Attempt to enter a directory by pressing Enter
                      > - Attempt to edit a file by pressing Enter
                      >
                      > That's all.
                      > I hope you will be able to detect what's wrong.
                      >
                      >
                      > Thanks
                      >
                      Hello!

                      It seems that you typed:

                      vim ftp://datamigo@192.168.0.46/myweb/

                      but there is no directory or file named "myweb" on that system; there is
                      a directory named joomlight-3.x and a file named test.php, but its under
                      the home directory, not myweb.

                      You then selected joomlight-3.x with a <cr>; this resulted in netrw
                      trying ftp with:

                      vim ftp://datamigo@192.168.0.46/myweb/joomlight-3.x/

                      Of course, since there's no directory called "myweb", there's no
                      directory called "myweb/joomlight-3.x" either.

                      You then selected test.php with a <cr>; this resulted in netrw trying
                      ftp with:

                      vim ftp://datamigo@192.168.0.46/myweb/test.php

                      Again, there is no myweb directory, and so there's no myweb/test.php file.

                      However, netrw should issue a message about this problem, so please try
                      v151f which does so.

                      (http://www.drchip.org/astronaut/vim/index.html#NETRW)

                      Regards,
                      C Campbell

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    Your message has been successfully submitted and would be delivered to recipients shortly.