Loading ...
Sorry, an error occurred while loading the content.

+python3 vim7.4 .tar.gz build how on 64bit wheezy?

Expand Messages
  • Vek M
    Hi, I m trying to build vim. I m on: deathstar uname -a Linux deathstar 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux I have wheezy installed with
    Message 1 of 14 , Jan 6, 2014
    • 0 Attachment
      Hi, I'm trying to build vim. I'm on:
      deathstar> uname -a
      Linux deathstar 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux

      I have wheezy installed with python
      deathstar> whereis python
      python: /usr/bin/python3.2mu /usr/bin/python2.6 /usr/bin/python2.7-config /usr/bin/python2.7 /usr/bin/python3.2 /usr/bin/python /etc/python2.6 /etc/python2.7 /etc/python3.2 /etc/python /usr/lib/python2.6 /usr/lib/python2.7 /usr/lib/python3.2 /usr/bin/X11/python3.2mu /usr/bin/X11/python2.6 /usr/bin/X11/python2.7-config /usr/bin/X11/python2.7 /usr/bin/X11/python3.2 /usr/bin/X11/python /usr/local/lib/python2.6 /usr/local/lib/python2.7 /usr/local/lib/python3.2 /usr/include/python3.2mu /usr/include/python2.6 /usr/include/python2.7_d /usr/include/python2.7 /usr/include/python2.6_d /usr/share/python /usr/share/man/man1/python.1.gz

      I do:
      ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=/usr/bin/python3.2 --enable-cscope --enable-fail-if-missing |less

      I see:
      checking for GTK - version >= 2.2.0... yes; found version 2.24.10

      checking if X11 header files can be found... yes
      checking for _XdmcpAuthDoIt in -lXdmcp... yes
      checking for IceOpenConnection in -lICE... yes
      checking for XpmCreatePixmapFromData in -lXpm... yes

      checking --enable-python3interp argument... /usr/bin/python3.2

      checking --disable-gpm argument... no
      checking for gpm... yes

      make works fine
      src/vim --version gives me:
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
      Linking: gcc -L/usr/local/lib -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -lnsl -lgpm -ldl

      -python3 +X11 +xterm_clipboard -xterm_save +mouse_gpm -perl

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Andrei Olsen
      ... enable-python3interp options are yes , no or dynamic . See ./configure --help So, change it to --enable-python3interp=dynamic -- -- You received this
      Message 2 of 14 , Jan 6, 2014
      • 0 Attachment
        On Monday, January 6, 2014 9:26:51 AM UTC+1, Vek M wrote:
        > I do:
        > ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=/usr/bin/python3.2 --enable-cscope --enable-fail-if-missing |less

        enable-python3interp options are 'yes', 'no' or 'dynamic'. See ./configure --help

        So, change it to --enable-python3interp=dynamic

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Vek M
        Now i get: checking for python3... /usr/bin/python3.2 checking Python version... 3.2 checking Python is 3.0 or better... yep checking Python s abiflags... mu
        Message 3 of 14 , Jan 6, 2014
        • 0 Attachment
          Now i get:
          checking for python3... /usr/bin/python3.2
          checking Python version... 3.2
          checking Python is 3.0 or better... yep
          checking Python's abiflags... mu
          checking Python's install prefix... /usr
          checking Python's execution prefix... /usr
          checking Python's configuration directory...
          can't find it!
          configure: error: could not configure python3

          I also tried with:
          ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=yes --enable-cscope --enable-fail-if-missing --with-python-config-dir=/usr/lib/python3.2/config

          same error. also /usr/lib/python3.2/config-3.2mu

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Vek M
          ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing ./configure
          Message 4 of 14 , Jan 6, 2014
          • 0 Attachment
            ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing

            ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing --with-python-config-dir=/usr/lib/python3.2/config

            didn't work

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Andrei Olsen
            ... What version are you compiling? The one from repository? BTW, config dir should be /usr/lib/python3.2/config-3.2mu -- -- You received this message from the
            Message 5 of 14 , Jan 6, 2014
            • 0 Attachment
              On Monday, January 6, 2014 11:14:57 AM UTC+1, Vek M wrote:
              > ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing
              >
              > ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing --with-python-config-dir=/usr/lib/python3.2/config
              >
              > didn't work

              What version are you compiling? The one from repository?

              BTW, config dir should be /usr/lib/python3.2/config-3.2mu

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Vek M
              the one on the website (.tar.gz, not the mercurial/cvs download) This one: vim-7.4.tar.bz2 Tried that as well (same error) configure: error: could not
              Message 6 of 14 , Jan 6, 2014
              • 0 Attachment
                the one on the website (.tar.gz, not the mercurial/cvs download)
                This one: vim-7.4.tar.bz2

                Tried that as well (same error)
                configure: error: could not configure python3
                deathstar> ./configure --prefix=/usr/local/vim74 --enable-gui=gtk2 --enable-python3interp=dynamic --enable-cscope --enable-fail-if-missing --with-python-config-dir=/usr/lib/python3.2/config-3.2mu

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Vek M
                http://www.vim.org/download.php ftp://ftp.vim.org/pub/vim/unix/vim-7.4.tar.bz2 -- -- You received this message from the vim_use maillist. Do not top-post!
                Message 7 of 14 , Jan 6, 2014
                • 0 Attachment
                  http://www.vim.org/download.php
                  ftp://ftp.vim.org/pub/vim/unix/vim-7.4.tar.bz2

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Andrei Olsen
                  ... You may need to apply patches then: ftp://ftp.vim.org/pub/vim/patches/7.4/ Personally, I find it much easier pulling the source from Mercurial repository.
                  Message 8 of 14 , Jan 6, 2014
                  • 0 Attachment
                    On Monday, January 6, 2014 11:55:11 AM UTC+1, Vek M wrote:
                    > http://www.vim.org/download.php
                    > ftp://ftp.vim.org/pub/vim/unix/vim-7.4.tar.bz2

                    You may need to apply patches then:
                    ftp://ftp.vim.org/pub/vim/patches/7.4/

                    Personally, I find it much easier pulling the source from Mercurial repository.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Vek M
                    affirmative - that s what i did with 7.3 to get the pig flying.. but i thought they d have fixed it in 7.4. oh well.. mercurial it is -- -- You received this
                    Message 9 of 14 , Jan 6, 2014
                    • 0 Attachment
                      affirmative - that's what i did with 7.3 to get the pig flying.. but i thought they'd have fixed it in 7.4. oh well.. mercurial it is

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Vek M
                      Nope - didn t work with the mercurial download. -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text
                      Message 10 of 14 , Jan 6, 2014
                      • 0 Attachment
                        Nope - didn't work with the mercurial download.

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Andrei Olsen
                        ... Hmmm... just compiled .tar.bz2 version. And it worked fine with Python 3. Maybe you need to run make clean make distclean -- -- You received this message
                        Message 11 of 14 , Jan 6, 2014
                        • 0 Attachment
                          On Monday, January 6, 2014 12:12:21 PM UTC+1, Vek M wrote:
                          > affirmative - that's what i did with 7.3 to get the pig flying.. but i thought they'd have fixed it in 7.4. oh well.. mercurial it is

                          Hmmm... just compiled .tar.bz2 version. And it worked fine with Python 3.

                          Maybe you need to run

                          make clean
                          make distclean

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Vek M
                          ah got it working - python3.2-dev needed to be installed -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below
                          Message 12 of 14 , Jan 6, 2014
                          • 0 Attachment
                            ah got it working - python3.2-dev needed to be installed

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Vek M
                            thanks :) duh! wish they d put that reminder or the ./configure line as part of the INSTALL -- -- You received this message from the vim_use maillist. Do not
                            Message 13 of 14 , Jan 6, 2014
                            • 0 Attachment
                              thanks :) duh! wish they'd put that reminder or the ./configure line as part of the INSTALL

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Christian Brabandt
                              ... I think, I should mention the faq again: http://vimhelp.appspot.com/vim_faq.txt.html#faq-35.10 Best, Christian -- Heirate und teile die Probleme, von denen
                              Message 14 of 14 , Jan 6, 2014
                              • 0 Attachment
                                On Mo, 06 Jan 2014, Vek M wrote:

                                > ah got it working - python3.2-dev needed to be installed

                                I think, I should mention the faq again:
                                http://vimhelp.appspot.com/vim_faq.txt.html#faq-35.10

                                Best,
                                Christian
                                --
                                Heirate und teile die Probleme, von denen du nicht einmal wußtest,
                                daß du sie hast.

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              Your message has been successfully submitted and would be delivered to recipients shortly.