Loading ...
Sorry, an error occurred while loading the content.
 

has 7.4 changed behaviour chdir-ing to current file's dir by default?

Expand Messages
  • jmlucjav
    Hi, I was using vim-project, to set current dir to the root of my projects. I noticed lately that is not working anymore, I tried configuring it to no avail.
    Message 1 of 11 , Dec 29, 2013
      Hi,

      I was using vim-project, to set current dir to the root of my projects. I noticed lately that is not working anymore, I tried configuring it to no avail. So I thought the plugin was maybe buggy. 
      I installed vim-root, that does the same, and also does not work...at this point I started looking into it and show that both plugins are apparently working, but after they run their chdir, something runs
      another chdir later, to the same dir the current file is, and this overwrites the plugin's work.

      Thinking it might be another plugin or my settings, I run this
      gvim.exe -u NONE -U NONE -V9vimlog.txt 

      and when I open a file I can see this:

      autocommand au! LoadBufferMenu
      chdir(C:\Users\jm\conf\home\jm\vimfiles)
                                                      C:\Users\jm\conf\home\jm\vimfiles

      :set autochdir?
      gives
      noautochdir

      so I am missing something? How come current dir is being set all the time? I am running vim7.4 32b on win7

      thanks

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • jmlucjav
      Hi, I was using vim-project, to set current dir to the root of my projects. I noticed lately that is not working anymore, I tried configuring it to no avail.
      Message 2 of 11 , Dec 29, 2013
        Hi,


        I was using vim-project, to set current dir to the root of my projects. I noticed lately that is not working anymore, I tried configuring it to no avail. So I thought the plugin was maybe buggy. 
        I installed vim-root, that does the same, and also does not work...at this point I started looking into it and show that both plugins are apparently working, but after they run their chdir, something runs
        another chdir later, to the same dir the current file is, and this overwrites the plugin's work.

        Thinking it might be another plugin or my settings, I run this
        gvim.exe -u NONE -U NONE -V9vimlog.txt 

        and when I open a file I can see this:

        autocommand au! LoadBufferMenu
        chdir(C:\Users\jm\conf\home\jm\vimfiles)
                                                        C:\Users\jm\conf\home\jm\vimfiles

        :set autochdir?
        gives
        noautochdir

        so I am missing something? How come current dir is being set all the time? I am running vim7.4 32b on win7

        thanks

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tony Mechelynck
        ... What is the answer to ... (the :verbose prefix will make it tell you where it was last set). Maybe it is set back and forth. OTOH the autocommand you
        Message 3 of 11 , Dec 29, 2013
          On 29/12/13 16:00, jmlucjav wrote:
          > Hi,
          >
          > I was using vim-project, to set current dir to the root of my projects.
          > I noticed lately that is not working anymore, I tried configuring it to
          > no avail. So I thought the plugin was maybe buggy.
          > I installed vim-root, that does the same, and also does not work...at
          > this point I started looking into it and show that both plugins are
          > apparently working, but after they run their chdir, something runs
          > another chdir later, to the same dir the current file is, and this
          > overwrites the plugin's work.
          >
          > Thinking it might be another plugin or my settings, I run this
          > gvim.exe -u NONE -U NONE -V9vimlog.txt
          >
          > and when I open a file I can see this:
          >
          > autocommand au! LoadBufferMenu
          > chdir(C:\Users\jm\conf\home\jm\vimfiles)
          >
          > C:\Users\jm\conf\home\jm\vimfiles
          >
          > :set autochdir?
          > gives
          > noautochdir
          >
          > so I am missing something? How come current dir is being set all the
          > time? I am running vim7.4 32b on win7
          >
          > thanks

          What is the answer to

          :verbose set acd?

          (the :verbose prefix will make it tell you where it was last set). Maybe
          it is set back and forth.


          OTOH the autocommand you listed above is not in the proper format. Check
          where it is being defined. You should see something like

          au! BufRead,BufNewFile * chdir C:\Users\jm\conf\home\jm\vimfiles

          with no "autocommand" before au! and no parentheses; though even that
          seems to me to be a little overdoing it. You ought to be able to set
          that current directory once in the vimrc and never change it.

          Another thing: Vim 7.4.32b i.e. 7.4.beta32 is very old, even older than
          Vim 7.4.000, and now we're at 7.4.131 and counting. Please retry with
          the latest Vim found at http://sourceforge.net/projects/cream/files/Vim/


          Best regards,
          Tony.
          --
          hundred-and-one symptoms of being an internet addict:
          59. Your wife says communication is important in a marriage...so you buy
          another computer and install a second phone line so the two of you can
          chat.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • jmlucjav
          hey Tony with :verbose I still get the same: noautochdir About autocmd: I just pasted what I got from the log file, I dont know if the autocmd (and there is a
          Message 4 of 11 , Dec 29, 2013
            hey Tony

            with :verbose I still get the same:
            noautochdir

            About autocmd: I just pasted what I got from the log file, I dont know if the autocmd (and there is a autocommand before the au, not sure why you didnt see it) is linked with the chdir, let me copy exactly what I get:
            -----------------
            autocommand au! LoadBufferMenu


            chdir(C:\Users\jm\Dropbox\conf\home\jm\vimfiles)
                                                            C:\Users\jm\Dropbox\conf\home\jm\vimfiles
            ------------------

            this is with gvim.exe -u NONE -U NONE -V9vimlog.txt 

            Regarding the version, lol, I meant 7.4 32bit on win7 64bit. Exact version is 7.4 patch 131

            thanks



            On Sun, Dec 29, 2013 at 4:29 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
            On 29/12/13 16:00, jmlucjav wrote:
            Hi,

            I was using vim-project, to set current dir to the root of my projects.
            I noticed lately that is not working anymore, I tried configuring it to
            no avail. So I thought the plugin was maybe buggy.
            I installed vim-root, that does the same, and also does not work...at
            this point I started looking into it and show that both plugins are
            apparently working, but after they run their chdir, something runs
            another chdir later, to the same dir the current file is, and this
            overwrites the plugin's work.

            Thinking it might be another plugin or my settings, I run this
            gvim.exe -u NONE -U NONE -V9vimlog.txt

            and when I open a file I can see this:

            autocommand au! LoadBufferMenu
            chdir(C:\Users\jm\conf\home\jm\vimfiles)

            C:\Users\jm\conf\home\jm\vimfiles

            :set autochdir?
            gives
            noautochdir

            so I am missing something? How come current dir is being set all the
            time? I am running vim7.4 32b on win7

            thanks

            What is the answer to

                    :verbose set acd?

            (the :verbose prefix will make it tell you where it was last set). Maybe it is set back and forth.


            OTOH the autocommand you listed above is not in the proper format. Check where it is being defined. You should see something like

                    au! BufRead,BufNewFile * chdir C:\Users\jm\conf\home\jm\vimfiles

            with no "autocommand" before au! and no parentheses; though even that seems to me to be a little overdoing it. You ought to be able to set that current directory once in the vimrc and never change it.

            Another thing: Vim 7.4.32b i.e. 7.4.beta32 is very old, even older than Vim 7.4.000, and now we're at 7.4.131 and counting. Please retry with the latest Vim found at http://sourceforge.net/projects/cream/files/Vim/


            Best regards,
            Tony.
            --
            hundred-and-one symptoms of being an internet addict:
            59. Your wife says communication is important in a marriage...so you buy
                another computer and install a second phone line so the two of you can
                chat.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            --- You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
            For more options, visit https://groups.google.com/groups/opt_out.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Tony Mechelynck
            ... meaning it was never changed from its default. Strange. ... Ah, that s better. About the autocommand: there is no LoadBufferMenu event (but any script
            Message 5 of 11 , Dec 29, 2013
              On 29/12/13 16:40, jmlucjav wrote:
              > hey Tony
              >
              > with :verbose I still get the same:
              > noautochdir

              meaning it was never changed from its default. Strange.

              >
              > About autocmd: I just pasted what I got from the log file, I dont know
              > if the autocmd (and there is a autocommand before the au, not sure why
              > you didnt see it) is linked with the chdir, let me copy exactly what I get:
              > -----------------
              > autocommand au! LoadBufferMenu
              >
              >
              > chdir(C:\Users\jm\Dropbox\conf\home\jm\vimfiles)
              >
              > C:\Users\jm\Dropbox\conf\home\jm\vimfiles
              > ------------------
              >
              > this is with gvim.exe -u NONE -U NONE -V9vimlog.txt
              >
              > Regarding the version, lol, I meant 7.4 32bit on win7 64bit. Exact
              > version is 7.4 patch 131
              >
              > thanks
              >

              Ah, that's better.

              About the autocommand: there is no LoadBufferMenu event (but any script
              could create a LoadBufferMenu group). Does Vim answer anything to

              :verbose au LoadBufferMenu

              ?


              -u NONE -U NONE means no vimrc, no gvimrc, no plugins. It even skips the
              system vimrc if there is one on your system. You must have done
              something else after that, or Vim would behave in a strictly standard
              way, with 'compatible' set (which is not what most of us expect, but we
              each have a vimrc), and no autocommands at all.

              Also, you might have a look at the output of the :scriptnames command.
              Do you see anything in there which you wouldn't have expected?


              Best regards,
              Tony.
              --
              Unix will self-destruct in five seconds... 4... 3... 2... 1...

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • jmlucjav
              On Sun, Dec 29, 2013 at 6:36 PM, Tony Mechelynck
              Message 6 of 11 , Dec 29, 2013



                On Sun, Dec 29, 2013 at 6:36 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
                On 29/12/13 16:40, jmlucjav wrote:
                hey Tony

                with :verbose I still get the same:
                noautochdir

                meaning it was never changed from its default. Strange.



                About autocmd: I just pasted what I got from the log file, I dont know
                if the autocmd (and there is a autocommand before the au, not sure why
                you didnt see it) is linked with the chdir, let me copy exactly what I get:
                -----------------
                autocommand au! LoadBufferMenu


                chdir(C:\Users\jm\Dropbox\conf\home\jm\vimfiles)

                C:\Users\jm\Dropbox\conf\home\jm\vimfiles
                ------------------

                this is with gvim.exe -u NONE -U NONE -V9vimlog.txt

                Regarding the version, lol, I meant 7.4 32bit on win7 64bit. Exact
                version is 7.4 patch 131

                thanks


                Ah, that's better.

                About the autocommand: there is no LoadBufferMenu event (but any script could create a LoadBufferMenu group). Does Vim answer anything to

                        :verbose au LoadBufferMenu

                just something along this:
                -----Auto-commands-----------


                ?


                -u NONE -U NONE means no vimrc, no gvimrc, no plugins. It even skips the system vimrc if there is one on your system. You must have done something else after that, or Vim would behave in a strictly standard way, with 'compatible' set (which is not what most of us expect, but we each have a vimrc), and no autocommands at all.

                Also, you might have a look at the output of the :scriptnames command. Do you see anything in there which you wouldn't have expected?

                I get this:

                  1: C:\Users\jm\Dropbox\portable\vim\menu.vim
                  2: C:\Users\jm\Dropbox\portable\vim\autoload\paste.vim

                no idea if this is ok or not. I have been using vim for a year or so but I am not a connoisseur regarding its inner workings or viml.

                BTW I am using vim from http://tuxproject.de/projects/vim/

                thanks!

                Best regards,
                Tony.
                --
                Unix will self-destruct in five seconds... 4... 3... 2... 1...


                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                --- You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
                For more options, visit https://groups.google.com/groups/opt_out.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Tony Mechelynck
                ... If those two scripts are still loaded even when you do vim.exe -u NONE -U NONE -V9 vimlog.txt AND NOTHING ELSE, then there s something very weird at work.
                Message 7 of 11 , Dec 29, 2013
                  On 29/12/13 18:51, jmlucjav wrote:
                  >
                  >
                  >
                  > On Sun, Dec 29, 2013 at 6:36 PM, Tony Mechelynck
                  > <antoine.mechelynck@... <mailto:antoine.mechelynck@...>> wrote:
                  >
                  > On 29/12/13 16:40, jmlucjav wrote:
                  >
                  > hey Tony
                  >
                  > with :verbose I still get the same:
                  > noautochdir
                  >
                  >
                  > meaning it was never changed from its default. Strange.
                  >
                  >
                  >
                  > About autocmd: I just pasted what I got from the log file, I
                  > dont know
                  > if the autocmd (and there is a autocommand before the au, not
                  > sure why
                  > you didnt see it) is linked with the chdir, let me copy exactly
                  > what I get:
                  > -----------------
                  > autocommand au! LoadBufferMenu
                  >
                  >
                  > chdir(C:\Users\jm\Dropbox\__conf\home\jm\vimfiles)
                  >
                  > C:\Users\jm\Dropbox\conf\home\__jm\vimfiles
                  > ------------------
                  >
                  > this is with gvim.exe -u NONE -U NONE -V9vimlog.txt
                  >
                  > Regarding the version, lol, I meant 7.4 32bit on win7 64bit. Exact
                  > version is 7.4 patch 131
                  >
                  > thanks
                  >
                  >
                  > Ah, that's better.
                  >
                  > About the autocommand: there is no LoadBufferMenu event (but any
                  > script could create a LoadBufferMenu group). Does Vim answer anything to
                  >
                  > :verbose au LoadBufferMenu
                  >
                  >
                  > just something along this:
                  > -----Auto-commands-----------
                  >
                  >
                  > ?
                  >
                  >
                  > -u NONE -U NONE means no vimrc, no gvimrc, no plugins. It even skips
                  > the system vimrc if there is one on your system. You must have done
                  > something else after that, or Vim would behave in a strictly
                  > standard way, with 'compatible' set (which is not what most of us
                  > expect, but we each have a vimrc), and no autocommands at all.
                  >
                  > Also, you might have a look at the output of the :scriptnames
                  > command. Do you see anything in there which you wouldn't have expected?
                  >
                  > I get this:
                  >
                  > 1: C:\Users\jm\Dropbox\portable\vim\menu.vim
                  > 2: C:\Users\jm\Dropbox\portable\vim\autoload\paste.vim
                  >
                  > no idea if this is ok or not. I have been using vim for a year or so but
                  > I am not a connoisseur regarding its inner workings or viml.
                  >
                  > BTW I am using vim from http://tuxproject.de/projects/vim/
                  >
                  > thanks!


                  If those two scripts are still loaded even when you do

                  vim.exe -u NONE -U NONE -V9 vimlog.txt

                  AND NOTHING ELSE, then there's something very weird at work. Maybe some
                  of the unlisted "manual compiling fixes" barely mentioned on that
                  tuxproject site.

                  For 32-bit Windows, Steve Hall's "Vim without Cream" has an established
                  reputation. Could you try it? It is found, as I already said, at
                  http://sourceforge.net/projects/cream/files/Vim/ . It is admittedly
                  still "only" at patchlevel 7.4.110, but if you don't see the bug in it,
                  then either it's in one of the 21 patches since then, or it's in
                  tuxproject's "manual fixes".

                  If there's a difference beween invoking "vim" and invoking "vim.exe"
                  then maybe there's a "vim.bat" somewhere. If so, then what does it contain?


                  Best regards,
                  Tony.
                  --
                  Time is money. Especially if you make clocks.

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • jmlucjav
                  I am calling gvim.exe -u NONE -U NONE -V9 vimlog.txt not vim.exe...I always use gvim, not vim.exe. Tried to run vim.exe in a cmd but somethings does not
                  Message 8 of 11 , Dec 29, 2013
                    I am calling 'gvim.exe -u NONE -U NONE -V9 vimlog.txt' not vim.exe...I always use gvim, not vim.exe. Tried to run vim.exe in a cmd but somethings does not work, I get no output to :scriptnames. 

                    Could that be the issue? calling gvim?

                    I tried another gvim.exe, the one I used to use before, from, http://wyw.dcweb.cn/#download, but this is just the exe put in my current vim dir, overriting the original gvim.exe. Same behaviour.

                    I was going to test with vim without cream, but it's an installer, I am afraid it will polute my HOME etc, is there somewhere an oficial vim zip distrib for win I could try?




                    On Sun, Dec 29, 2013 at 7:18 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
                    On 29/12/13 18:51, jmlucjav wrote:



                    On Sun, Dec 29, 2013 at 6:36 PM, Tony Mechelynck
                    <antoine.mechelynck@... <mailto:antoine.mechelynck@gmail.com>> wrote:

                        On 29/12/13 16:40, jmlucjav wrote:

                            hey Tony

                            with :verbose I still get the same:
                            noautochdir


                        meaning it was never changed from its default. Strange.



                            About autocmd: I just pasted what I got from the log file, I
                            dont know
                            if the autocmd (and there is a autocommand before the au, not
                            sure why
                            you didnt see it) is linked with the chdir, let me copy exactly
                            what I get:
                            -----------------
                            autocommand au! LoadBufferMenu


                            chdir(C:\Users\jm\Dropbox\__conf\home\jm\vimfiles)

                            C:\Users\jm\Dropbox\conf\home\__jm\vimfiles

                            ------------------

                            this is with gvim.exe -u NONE -U NONE -V9vimlog.txt

                            Regarding the version, lol, I meant 7.4 32bit on win7 64bit. Exact
                            version is 7.4 patch 131

                            thanks


                        Ah, that's better.

                        About the autocommand: there is no LoadBufferMenu event (but any
                        script could create a LoadBufferMenu group). Does Vim answer anything to

                                 :verbose au LoadBufferMenu


                    just something along this:
                    -----Auto-commands-----------


                        ?


                        -u NONE -U NONE means no vimrc, no gvimrc, no plugins. It even skips
                        the system vimrc if there is one on your system. You must have done
                        something else after that, or Vim would behave in a strictly
                        standard way, with 'compatible' set (which is not what most of us
                        expect, but we each have a vimrc), and no autocommands at all.

                        Also, you might have a look at the output of the :scriptnames
                        command. Do you see anything in there which you wouldn't have expected?

                    I get this:

                       1: C:\Users\jm\Dropbox\portable\vim\menu.vim
                       2: C:\Users\jm\Dropbox\portable\vim\autoload\paste.vim

                    no idea if this is ok or not. I have been using vim for a year or so but
                    I am not a connoisseur regarding its inner workings or viml.

                    BTW I am using vim from http://tuxproject.de/projects/vim/

                    thanks!


                    If those two scripts are still loaded even when you do

                            vim.exe -u NONE -U NONE -V9 vimlog.txt

                    AND NOTHING ELSE, then there's something very weird at work. Maybe some of the unlisted "manual compiling fixes" barely mentioned on that tuxproject site.

                    For 32-bit Windows, Steve Hall's "Vim without Cream" has an established reputation. Could you try it? It is found, as I already said, at http://sourceforge.net/projects/cream/files/Vim/ . It is admittedly still "only" at patchlevel 7.4.110, but if you don't see the bug in it, then either it's in one of the 21 patches since then, or it's in tuxproject's "manual fixes".

                    If there's a difference beween invoking "vim" and invoking "vim.exe" then maybe there's a "vim.bat" somewhere. If so, then what does it contain?


                    Best regards,
                    Tony.
                    --
                    Time is money.  Especially if you make clocks.


                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    --- You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
                    For more options, visit https://groups.google.com/groups/opt_out.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                     
                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Tony Mechelynck
                    ... It shouldn t. ... Not that I know of. Yes it s an installer, for ease of use, but AFAIK it s rather clean as installers go. If Steve Hall, who makes it, is
                    Message 9 of 11 , Dec 29, 2013
                      On 29/12/13 19:39, jmlucjav wrote:
                      > I am calling 'gvim.exe -u NONE -U NONE -V9 vimlog.txt' not vim.exe...I
                      > always use gvim, not vim.exe. Tried to run vim.exe in a cmd but
                      > somethings does not work, I get no output to :scriptnames.
                      >
                      > Could that be the issue? calling gvim?

                      It shouldn't.

                      >
                      > I tried another gvim.exe, the one I used to use before, from,
                      > http://wyw.dcweb.cn/#download, but this is just the exe put in my
                      > current vim dir, overriting the original gvim.exe. Same behaviour.
                      >
                      > I was going to test with vim without cream, but it's an installer, I am
                      > afraid it will polute my HOME etc, is there somewhere an oficial vim zip
                      > distrib for win I could try?

                      Not that I know of. Yes it's an installer, for ease of use, but AFAIK
                      it's rather clean as installers go. If Steve Hall, who makes it, is
                      reading this, he could give you more explanations than I can; but maybe
                      he's on holiday until after New Year's Day. If you want, you might take
                      a backup of what you care about, then cross your fingers (or touch wood)
                      while it installs.

                      Or you could compile your own, but why reinvent the wheel when Steve
                      Hall's "Vim without Cream" is such a nice product? Any Vim old-timer
                      here that still is on Windows (or, like me, has been for a long time)
                      will tell you the same. Well, once upon a time when I was still on
                      Windows (I think it was between Vim 6.4 and 7.0) Steve had gone AWOL and
                      I did some compiling. Vim wasn't yet on Mercurial by then, the part
                      about getting the sources in my HowTo pages linked below is more recent.

                      Getting the sources:
                      http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
                      Compiling on Windows (may be out-of-date):
                      http://users.skynet.be/antoine.mechelynck/vim/compile.htm


                      Best regards,
                      Tony.
                      --
                      While away at a convention, an executive happened to meet a young woman who
                      was pretty, chic, and intelligent. When he persuaded her to disrobe in his
                      hotel room, he found out she had a superb body as well. Unfortunately, as
                      will happen, the executive sadly found himself unable to perform.
                      On his first night home, the executive padded naked from the shower
                      into the bedroom to find his wife swathed in a rumpled bathrobe, her hair
                      curled, her face creamed, munching candy loudly as she pored through a movie
                      magazine. And then, without warning, he felt the onset of a magnificent
                      erection.
                      Looking down at his throbbing member, he snarled, "Why you ungrateful,
                      mixed-up, son-of-a-bitch! Now I know why they call you a prick!"

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • jmlucjav
                      ok, I installed vim without cream, and starting: c: Program Files (x86) vim vim74 gvim.exe -u NONE -U NONE -V9vimlog.txt I run :scriptnames and also get only
                      Message 10 of 11 , Dec 30, 2013
                        ok, I installed vim without cream, and starting:
                        "c:\Program Files (x86)\vim\vim74\gvim.exe" -u NONE -U NONE -V9vimlog.txt 

                        I run :scriptnames and also get only 
                         1: c:\Program Files (x86)\vim\vim74\menu.vim
                          2: c:\Program Files (x86)\vim\vim74\autoload\paste.vim

                        so I guess this was not a problem to begin with, and I should focus again on the chdir being done...?
                        With this versiosn of vim, I dont see the chdir in the logs...I am going to investigate more


                        On Sun, Dec 29, 2013 at 8:35 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
                        On 29/12/13 19:39, jmlucjav wrote:
                        I am calling 'gvim.exe -u NONE -U NONE -V9 vimlog.txt' not vim.exe...I
                        always use gvim, not vim.exe. Tried to run vim.exe in a cmd but
                        somethings does not work, I get no output to :scriptnames.

                        Could that be the issue? calling gvim?

                        It shouldn't.



                        I tried another gvim.exe, the one I used to use before, from,
                        http://wyw.dcweb.cn/#download, but this is just the exe put in my
                        current vim dir, overriting the original gvim.exe. Same behaviour.

                        I was going to test with vim without cream, but it's an installer, I am
                        afraid it will polute my HOME etc, is there somewhere an oficial vim zip
                        distrib for win I could try?

                        Not that I know of. Yes it's an installer, for ease of use, but AFAIK it's rather clean as installers go. If Steve Hall, who makes it, is reading this, he could give you more explanations than I can; but maybe he's on holiday until after New Year's Day. If you want, you might take a backup of what you care about, then cross your fingers (or touch wood) while it installs.

                        Or you could compile your own, but why reinvent the wheel when Steve Hall's "Vim without Cream" is such a nice product? Any Vim old-timer here that still is on Windows (or, like me, has been for a long time) will tell you the same. Well, once upon a time when I was still on Windows (I think it was between Vim 6.4 and 7.0) Steve had gone AWOL and I did some compiling. Vim wasn't yet on Mercurial by then, the part about getting the sources in my HowTo pages linked below is more recent.

                        Getting the sources:
                                http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
                        Compiling on Windows (may be out-of-date):
                                http://users.skynet.be/antoine.mechelynck/vim/compile.htm


                        Best regards,
                        Tony.
                        --
                        While away at a convention, an executive happened to meet a young woman who
                        was pretty, chic, and intelligent.  When he persuaded her to disrobe in his
                        hotel room, he found out she had a superb body as well.  Unfortunately, as
                        will happen, the executive sadly found himself unable to perform.
                                On his first night home, the executive padded naked from the shower
                        into the bedroom to find his wife swathed in a rumpled bathrobe, her hair
                        curled, her face creamed, munching candy loudly as she pored through a movie
                        magazine.  And then, without warning, he felt the onset of a magnificent
                        erection.
                                Looking down at his throbbing member, he snarled, "Why you ungrateful,
                        mixed-up, son-of-a-bitch!  Now I know why they call you a prick!"


                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        --- You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
                        For more options, visit https://groups.google.com/groups/opt_out.

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                         
                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • jmlucjav
                        ok, I finally found out the issue. Apparently renaming the top directory that contains all stuff (vim74) to vim/, causes my issue. Leaving it as vim74/ works
                        Message 11 of 11 , Dec 30, 2013
                          ok, I finally found out the issue. Apparently renaming the top directory that contains all stuff (vim74) to vim/, causes my issue. Leaving it as vim74/ works fine, vim-rooter now does the only chdir, no additional chdir.

                          This works with vim without cream and also the vim I was using from tux. I will keep that as I need lua.

                          I saw another thread or issue asking for the installation dir not to contain the version name, this makes sense to me too.

                          thanks


                          On Mon, Dec 30, 2013 at 12:27 PM, jmlucjav <jmlucjav@...> wrote:
                          ok, I installed vim without cream, and starting:
                          "c:\Program Files (x86)\vim\vim74\gvim.exe" -u NONE -U NONE -V9vimlog.txt 

                          I run :scriptnames and also get only 
                           1: c:\Program Files (x86)\vim\vim74\menu.vim
                            2: c:\Program Files (x86)\vim\vim74\autoload\paste.vim

                          so I guess this was not a problem to begin with, and I should focus again on the chdir being done...?
                          With this versiosn of vim, I dont see the chdir in the logs...I am going to investigate more


                          On Sun, Dec 29, 2013 at 8:35 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
                          On 29/12/13 19:39, jmlucjav wrote:
                          I am calling 'gvim.exe -u NONE -U NONE -V9 vimlog.txt' not vim.exe...I
                          always use gvim, not vim.exe. Tried to run vim.exe in a cmd but
                          somethings does not work, I get no output to :scriptnames.

                          Could that be the issue? calling gvim?

                          It shouldn't.



                          I tried another gvim.exe, the one I used to use before, from,
                          http://wyw.dcweb.cn/#download, but this is just the exe put in my
                          current vim dir, overriting the original gvim.exe. Same behaviour.

                          I was going to test with vim without cream, but it's an installer, I am
                          afraid it will polute my HOME etc, is there somewhere an oficial vim zip
                          distrib for win I could try?

                          Not that I know of. Yes it's an installer, for ease of use, but AFAIK it's rather clean as installers go. If Steve Hall, who makes it, is reading this, he could give you more explanations than I can; but maybe he's on holiday until after New Year's Day. If you want, you might take a backup of what you care about, then cross your fingers (or touch wood) while it installs.

                          Or you could compile your own, but why reinvent the wheel when Steve Hall's "Vim without Cream" is such a nice product? Any Vim old-timer here that still is on Windows (or, like me, has been for a long time) will tell you the same. Well, once upon a time when I was still on Windows (I think it was between Vim 6.4 and 7.0) Steve had gone AWOL and I did some compiling. Vim wasn't yet on Mercurial by then, the part about getting the sources in my HowTo pages linked below is more recent.

                          Getting the sources:
                                  http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
                          Compiling on Windows (may be out-of-date):
                                  http://users.skynet.be/antoine.mechelynck/vim/compile.htm


                          Best regards,
                          Tony.
                          --
                          While away at a convention, an executive happened to meet a young woman who
                          was pretty, chic, and intelligent.  When he persuaded her to disrobe in his
                          hotel room, he found out she had a superb body as well.  Unfortunately, as
                          will happen, the executive sadly found himself unable to perform.
                                  On his first night home, the executive padded naked from the shower
                          into the bedroom to find his wife swathed in a rumpled bathrobe, her hair
                          curled, her face creamed, munching candy loudly as she pored through a movie
                          magazine.  And then, without warning, he felt the onset of a magnificent
                          erection.
                                  Looking down at his throbbing member, he snarled, "Why you ungrateful,
                          mixed-up, son-of-a-bitch!  Now I know why they call you a prick!"


                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          --- You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
                          For more options, visit https://groups.google.com/groups/opt_out.


                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                           
                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        Your message has been successfully submitted and would be delivered to recipients shortly.