Loading ...
Sorry, an error occurred while loading the content.

Colors when opening a file where a swap file exists

Expand Messages
  • Martin Lundberg
    I m trying to find out how to change the color that vim uses when you try to open a file where a swap file exists. Right now it s light green on my light
    Message 1 of 16 , Dec 9, 2013
    • 0 Attachment
      I'm trying to find out how to change the color that vim uses when you try to open a file where a swap file exists. Right now it's light green on my light yellow background so I can hardly see what it says: https://cloudup.com/cMTKdxrfEZV

      Thanks!

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Lucas Prado Melo
      On Mon, Dec 9, 2013 at 5:23 AM, Martin Lundberg ... I think you need to :set background=light so Vim automatically changes the shade of green that it uses.
      Message 2 of 16 , Dec 9, 2013
      • 0 Attachment
        On Mon, Dec 9, 2013 at 5:23 AM, Martin Lundberg <martin.lundberg@...> wrote:
        I'm trying to find out how to change the color that vim uses when you try to open a file where a swap file exists. Right now it's light green on my light yellow background so I can hardly see what it says: https://cloudup.com/cMTKdxrfEZV

        Thanks!


        I think you need to ":set background=light" so Vim automatically changes the shade of green that it uses.

        --
        []'s
        Lucas

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Martin Lundberg
        ... I ve already got that in my colors file. Will look into that though. -- -- You received this message from the vim_use maillist. Do not top-post! Type
        Message 3 of 16 , Dec 9, 2013
        • 0 Attachment
          On Monday, December 9, 2013 9:27:46 AM UTC+1, Lucas Prado Melo wrote:
          > I think you need to ":set background=light" so Vim automatically changes the shade of green that it uses.

          I've already got that in my colors file. Will look into that though.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          Hi Martin! ... I think you are seeing the ConfirmMsg highlighting. If you see this message when starting vim, the ConfirmMsg highlighting group might not been
          Message 4 of 16 , Dec 9, 2013
          • 0 Attachment
            Hi Martin!

            On Mo, 09 Dez 2013, Martin Lundberg wrote:

            > I'm trying to find out how to change the color that vim uses when you
            > try to open a file where a swap file exists. Right now it's light
            > green on my light yellow background so I can hardly see what it says:
            > https://cloudup.com/cMTKdxrfEZV

            I think you are seeing the ConfirmMsg highlighting. If you see this
            message when starting vim, the ConfirmMsg highlighting group might not
            been set to its corresponding Colorscheme value, so it might change
            later on. For the gui version, you can however work around it, by
            removing the 'c' flag from the guioptions setting.

            Best,
            Christian
            --
            Der Arzt nach der Untersuchung zum Patienten:
            "Haben Sie das schon mal gehabt?"
            "Ja."
            "Nun, dann haben Sie's jetzt wieder!"

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Martin Lundberg
            ... Not sure what you mean. I looked in my color file and I did not have a line for ConfirmMsg, I added it (as black) but terminal vim still shows me the same
            Message 5 of 16 , Dec 10, 2013
            • 0 Attachment
              On Monday, December 9, 2013 7:00:47 PM UTC+1, Christian Brabandt wrote:
              > I think you are seeing the ConfirmMsg highlighting. If you see this
              > message when starting vim, the ConfirmMsg highlighting group might not
              > been set to its corresponding Colorscheme value, so it might change
              > later on.

              Not sure what you mean. I looked in my color file and I did not have a line for ConfirmMsg, I added it (as black) but terminal vim still shows me the same green message.

              > For the gui version, you can however work around it, by
              > removing the 'c' flag from the guioptions setting.

              I've actually added the 'c' flag myself because I don't want the GUI dialogs. However in MacVim the message is shown as Normal color with or without the ConfirmMsg highlight line.

              Is it actually my terminal that is showing the color as green? Maybe it can't be changed from Vim?

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Brabandt
              ... Sorry, I think, I meant the MoreMsg highlighting group. There is no ConfirmMsg highlighting group. What I mean is, if you see this message when starting
              Message 6 of 16 , Dec 10, 2013
              • 0 Attachment
                On Tue, December 10, 2013 10:34, Martin Lundberg wrote:
                > On Monday, December 9, 2013 7:00:47 PM UTC+1, Christian Brabandt wrote:
                >> I think you are seeing the ConfirmMsg highlighting. If you see this
                >> message when starting vim, the ConfirmMsg highlighting group might not
                >> been set to its corresponding Colorscheme value, so it might change
                >> later on.
                >
                > Not sure what you mean. I looked in my color file and I did not have a
                > line for ConfirmMsg, I added it (as black) but terminal vim still shows me
                > the same green message.

                Sorry, I think, I meant the MoreMsg highlighting group. There is no
                ConfirmMsg highlighting group.

                What I mean is, if you see this message when starting vim or gvim,
                then by that time, Vim hasn't adjusted the colors to the corresponding
                colorscheme yet, simply because is hasn't sourced your colorscheme
                yet, so it uses a compiled default, which might not match your
                terminal. You can tell by provoking this message again, after Vim was
                loaded, and see, if Vim uses a different color then.

                What should work however is to reset the 'hl' setting by e.g.
                vim --cmd "let &hl=substitute(&hl, 'm:[^,]*,', 'm:ErrorMsg,', '')"
                foobar

                This would use the 'ErrorMsg' highlighting everywhere where the
                MoreMsg highlighting is used. I am not sure, this is actually wise to
                do so, however.

                But it might be easier to configure your terminal correctly. What
                terminal are you using and what is your $TERM variable? It might
                already help to force Vim to use a 't_Co' setting of 256, e.g. do an
                export TERM=xterm-256colors
                in your terminal (or whathever your shell needs)
                This might also depend on your 'bg' setting.

                For the gui, I am not sure, what will help there. Perhaps a .gtkrc file?

                >> For the gui version, you can however work around it, by
                >> removing the 'c' flag from the guioptions setting.
                >
                > I've actually added the 'c' flag myself because I don't want the GUI
                > dialogs. However in MacVim the message is shown as Normal color with or
                > without the ConfirmMsg highlight line.

                Don't know about MacVim. But I suspect, MacVim is no problem for you
                then?

                > Is it actually my terminal that is showing the color as green? Maybe it
                > can't be changed from Vim?

                It can, but usually only when all startup scripts have been read
                (which might not be the case when starting Vim with a filename and a
                swapfile is found.

                Best,
                Christian

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Егор
                Can t understand why, but if I try to use perldoc from vim it says that no documents. For example, i put cursor on word foreach and hit h. I ve got 1 No
                Message 7 of 16 , Dec 10, 2013
                • 0 Attachment
                  Can't understand why, but if I try to use perldoc from vim it says that
                  no documents. For example, i put cursor on word "foreach" and hit \h.
                  I've got
                  1 No documentation found for perl module, perl function or perl FAQ
                  keyword
                  2 'foreach'

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Martin Lundberg
                  ... Yes, that seem to be the case. If I open another file which is already open after I ve opened the first the message is in the color that I ve set. ... I
                  Message 8 of 16 , Dec 10, 2013
                  • 0 Attachment
                    On Tuesday, December 10, 2013 10:59:52 AM UTC+1, Christian Brabandt wrote:
                    > Sorry, I think, I meant the MoreMsg highlighting group. There is no
                    > ConfirmMsg highlighting group.
                    >
                    > What I mean is, if you see this message when starting vim or gvim,
                    > then by that time, Vim hasn't adjusted the colors to the corresponding
                    > colorscheme yet, simply because is hasn't sourced your colorscheme
                    > yet, so it uses a compiled default, which might not match your
                    > terminal. You can tell by provoking this message again, after Vim was
                    > loaded, and see, if Vim uses a different color then.

                    Yes, that seem to be the case. If I open another file which is already open after I've opened the first the message is in the color that I've set.

                    > What should work however is to reset the 'hl' setting by e.g.
                    > vim --cmd "let &hl=substitute(&hl, 'm:[^,]*,', 'm:ErrorMsg,', '')"
                    > foobar

                    I tried this and then the message was shown with the color that ErrorMsg has.

                    > But it might be easier to configure your terminal correctly. What
                    > terminal are you using and what is your $TERM variable? It might
                    > already help to force Vim to use a 't_Co' setting of 256, e.g. do an
                    > export TERM=xterm-256colors
                    > in your terminal (or whathever your shell needs)

                    I'm using iTerm2 and TERM is set to xterm-256color. If I run :set t_Co? inside vim I get 256.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Charles Campbell
                    ... Two things: * don t highjack another thread. The result is that fewer people will look at your issue because they aren t interested in the original thread
                    Message 9 of 16 , Dec 11, 2013
                    • 0 Attachment
                      Егор wrote:
                      > Can't understand why, but if I try to use perldoc from vim it says
                      > that no documents. For example, i put cursor on word "foreach" and hit
                      > \h. I've got
                      > 1 No documentation found for perl module, perl function or perl FAQ
                      > keyword
                      > 2 'foreach'
                      >
                      Two things:

                      * don't highjack another thread. The result is that fewer people will
                      look at your issue because they aren't interested in the original thread
                      and so never even see it. Instead, start a new thread for your new
                      topic. You likely did this by "replying" to a message from the thread
                      and re-writing the subject.

                      * try running vim -u NONE -N whatever.pm and then hit "\h". You'll get
                      "No mapping found". So, look into whatever is providing your mapping for
                      \h: :verbose map \h and peruse the resulting file.

                      Regards,
                      C Campbell

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Christian Brabandt
                      ... Does it change with vim --cmd :set bg=dark or vim --cmd :set bg=light ? ... Okay, that was expected. ... Sorry, don t know iTerm2 well. From a quick
                      Message 10 of 16 , Dec 11, 2013
                      • 0 Attachment
                        On Di, 10 Dez 2013, Martin Lundberg wrote:

                        > On Tuesday, December 10, 2013 10:59:52 AM UTC+1, Christian Brabandt wrote:
                        > > Sorry, I think, I meant the MoreMsg highlighting group. There is no
                        > > ConfirmMsg highlighting group.
                        > >
                        > > What I mean is, if you see this message when starting vim or gvim,
                        > > then by that time, Vim hasn't adjusted the colors to the corresponding
                        > > colorscheme yet, simply because is hasn't sourced your colorscheme
                        > > yet, so it uses a compiled default, which might not match your
                        > > terminal. You can tell by provoking this message again, after Vim was
                        > > loaded, and see, if Vim uses a different color then.
                        >
                        > Yes, that seem to be the case. If I open another file which is already open after I've opened the first the message is in the color that I've set.

                        Does it change with vim --cmd ':set bg=dark' or
                        vim --cmd ':set bg=light'
                        ?
                        >
                        > > What should work however is to reset the 'hl' setting by e.g.
                        > > vim --cmd "let &hl=substitute(&hl, 'm:[^,]*,', 'm:ErrorMsg,', '')"
                        > > foobar
                        >
                        > I tried this and then the message was shown with the color that ErrorMsg has.

                        Okay, that was expected.

                        >
                        > > But it might be easier to configure your terminal correctly. What
                        > > terminal are you using and what is your $TERM variable? It might
                        > > already help to force Vim to use a 't_Co' setting of 256, e.g. do an
                        > > export TERM=xterm-256colors
                        > > in your terminal (or whathever your shell needs)
                        >
                        > I'm using iTerm2 and TERM is set to xterm-256color. If I run :set
                        > t_Co? inside vim I get 256.

                        Sorry, don't know iTerm2 well. From a quick google search xterm-256color
                        seems to be correct. Can't you configure it for other colors?

                        Best,
                        Christian
                        --
                        Wie man sein Kind nicht nennen sollte:
                        Kai Nessen

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Martin Lundberg
                        ... Nope, still get the green color using any of the above. ... What do you mean configure it for other colors? I can change the color for normal and light
                        Message 11 of 16 , Dec 11, 2013
                        • 0 Attachment
                          On Wednesday, December 11, 2013 9:48:08 PM UTC+1, Christian Brabandt wrote:
                          > Does it change with vim --cmd ':set bg=dark' or
                          > vim --cmd ':set bg=light'
                          > ?

                          Nope, still get the green color using any of the above.

                          > Sorry, don't know iTerm2 well. From a quick google search xterm-256color
                          > seems to be correct. Can't you configure it for other colors?

                          What do you mean configure it for other colors? I can change the color for normal and light green but I use a dark theme in my terminal where I want the colors configured but then I use a light color in vim :)

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Christian Brabandt
                          Hi Martin! ... It should use a light green when Vim is using :set bg=dark and a dark green for :set bg=light Are you sure, nothing is resetting the background
                          Message 12 of 16 , Dec 11, 2013
                          • 0 Attachment
                            Hi Martin!

                            On Mi, 11 Dez 2013, Martin Lundberg wrote:

                            > On Wednesday, December 11, 2013 9:48:08 PM UTC+1, Christian Brabandt wrote:
                            > > Does it change with vim --cmd ':set bg=dark' or
                            > > vim --cmd ':set bg=light'
                            > > ?
                            >
                            > Nope, still get the green color using any of the above.

                            It should use a light green when Vim is using :set bg=dark and a dark
                            green for :set bg=light Are you sure, nothing is resetting the
                            background setting afterwards? If I do
                            vim -u NONE -N --cmd 'set bg=dark'
                            and then :hi MoreMsg I get this
                            MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen
                            while with this:
                            vim -u NONE -N --cmd 'set bg=light'
                            I see
                            MoreMsg xxx term=bold ctermfg=2 gui=bold guifg=SeaGreen
                            (and each time, the 'xxx' are colored slightly different)

                            I think the point is, when starting up. you won't be able to reconfigure
                            Vim to use a different color other then the compiled in ones, unless you
                            use some hacks with --cmd=':colors colorscheme' or so
                            (I am not sure, if setting 'bg' early in your .vimrc might make a
                            difference).

                            > > Sorry, don't know iTerm2 well. From a quick google search xterm-256color
                            > > seems to be correct. Can't you configure it for other colors?
                            >
                            > What do you mean configure it for other colors? I can change the color for normal and light green but I use a dark theme in my terminal where I want the colors configured but then I use a light color in vim :)

                            I thought, you can configure, what colors it uses for e.g. a darkgreen
                            or lightgreen (e.g. ctermcolor 2 and 121).

                            Best,
                            Christian
                            --
                            Tatsächlich sind es die wichtigsten Momente im Leben, wenn wir allein
                            sind.
                            -- Anne Morrow Lindbergh

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Martin Lundberg
                            ... ~$ vim --cmd :set bg=dark|hi MoreMsg test.php MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen ~$ vim --cmd :set bg=light|hi MoreMsg
                            Message 13 of 16 , Dec 11, 2013
                            • 0 Attachment
                              On Wednesday, December 11, 2013 10:15:55 PM UTC+1, Christian Brabandt wrote:
                              > It should use a light green when Vim is using :set bg=dark and a dark
                              > green for :set bg=light Are you sure, nothing is resetting the
                              > background setting afterwards? If I do
                              > vim -u NONE -N --cmd 'set bg=dark'
                              > and then :hi MoreMsg I get this
                              > MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen
                              > while with this:
                              > vim -u NONE -N --cmd 'set bg=light'
                              > I see
                              > MoreMsg xxx term=bold ctermfg=2 gui=bold guifg=SeaGreen
                              > (and each time, the 'xxx' are colored slightly different)

                              ~$ vim --cmd ':set bg=dark|hi MoreMsg' test.php
                              MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen

                              ~$ vim --cmd ':set bg=light|hi MoreMsg' test.php
                              MoreMsg xxx term=bold ctermfg=2 gui=bold guifg=SeaGreen

                              Not sure what 2 is since the colortest (http://www.vim.org/scripts/script.php?script_id=1349) doesn't show color number 2. I'll look into if I should just add a bash alias with some --cmd fix or if I'll change the color in the terminal.

                              Thanks for taking time to look into this! :)

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Christian Brabandt
                              Hi Martin! ... And do the xxx look different? ... Color 2 is for xterm in the 16color cube equivalent to #00CD00 (a darkgreen color) while 121 is only
                              Message 14 of 16 , Dec 11, 2013
                              • 0 Attachment
                                Hi Martin!

                                On Mi, 11 Dez 2013, Martin Lundberg wrote:

                                > On Wednesday, December 11, 2013 10:15:55 PM UTC+1, Christian Brabandt wrote:
                                > > It should use a light green when Vim is using :set bg=dark and a dark
                                > > green for :set bg=light Are you sure, nothing is resetting the
                                > > background setting afterwards? If I do
                                > > vim -u NONE -N --cmd 'set bg=dark'
                                > > and then :hi MoreMsg I get this
                                > > MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen
                                > > while with this:
                                > > vim -u NONE -N --cmd 'set bg=light'
                                > > I see
                                > > MoreMsg xxx term=bold ctermfg=2 gui=bold guifg=SeaGreen
                                > > (and each time, the 'xxx' are colored slightly different)
                                >
                                > ~$ vim --cmd ':set bg=dark|hi MoreMsg' test.php
                                > MoreMsg xxx term=bold ctermfg=121 gui=bold guifg=SeaGreen
                                >
                                > ~$ vim --cmd ':set bg=light|hi MoreMsg' test.php
                                > MoreMsg xxx term=bold ctermfg=2 gui=bold guifg=SeaGreen
                                >
                                > Not sure what 2 is since the colortest (http://www.vim.org/scripts/script.php?script_id=1349) doesn't show color number 2. I'll look into if I should just add a bash alias with some --cmd fix or if I'll change the color in the terminal.

                                And do the xxx look different?

                                > Thanks for taking time to look into this! :)

                                Color 2 is for xterm in the 16color cube equivalent to #00CD00 (a
                                darkgreen color) while 121 is only supported for 256color terminals and
                                for xterm equivalent to - if I am not mistaken - #87FFAF (a lightgreen
                                color)

                                Now this only holds for xterm, not sure, what colors other terminals
                                use.

                                Best,
                                Christian
                                --
                                Erwachsen werden bedeutet, zu vergessen, daß man als Kind noch die
                                Welt retten wollte.
                                -- Adnan Zelkanovic

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • Martin Lundberg
                                ... Yes, with light background the color is green but with dark it s a green with a little more blue in it, almost teal. -- -- You received this message from
                                Message 15 of 16 , Dec 11, 2013
                                • 0 Attachment
                                  On Wednesday, December 11, 2013 11:03:28 PM UTC+1, Christian Brabandt wrote:
                                  > And do the xxx look different?

                                  Yes, with light background the color is green but with dark it's a green with a little more blue in it, almost teal.

                                  --
                                  --
                                  You received this message from the "vim_use" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                • Christian Brabandt
                                  ... Well if I read http://www.iterm2.com/#/section/documentation/hidden_settings correctly, you might be able, to tune that particular color in iTerm2 that is
                                  Message 16 of 16 , Dec 12, 2013
                                  • 0 Attachment
                                    On Thu, December 12, 2013 08:41, Martin Lundberg wrote:
                                    > On Wednesday, December 11, 2013 11:03:28 PM UTC+1, Christian Brabandt
                                    > wrote:
                                    >> And do the xxx look different?
                                    >
                                    > Yes, with light background the color is green but with dark it's a green
                                    > with a little more blue in it, almost teal.
                                    >

                                    Well if I read
                                    http://www.iterm2.com/#/section/documentation/hidden_settings
                                    correctly, you might be able, to tune that particular color in iTerm2
                                    that is hard to read by that control sequence:
                                    ^[]Pnrrggbb^[\
                                    by setting n to that cterm color number and set rrggbb to the new
                                    values.

                                    If this works for you, then you can certainly put something
                                    like this into your .bashrc or whatever you use for initialization
                                    of your shell and set that particular ansi color possibly guarded
                                    by some tests, that figures out, if you are currently running iTerm2.

                                    Best,
                                    Christian

                                    --
                                    --
                                    You received this message from the "vim_use" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                    For more options, visit https://groups.google.com/groups/opt_out.
                                  Your message has been successfully submitted and would be delivered to recipients shortly.