Loading ...
Sorry, an error occurred while loading the content.
 

Snipmate not working with pathogen

Expand Messages
  • Luc-Frédéric Langis
    Hi Pathogen already installed and work fine. Installed snipMate in bundle directory. Add filetype plugin on on my _vimrc created a js file write for nothing
    Message 1 of 22 , Nov 12, 2013
      Hi

      Pathogen already installed and work fine.
      Installed snipMate in bundle directory.
      Add filetype plugin on on my _vimrc

      created a js file
      write for
      nothing happens when I hit the tab key

      I think pathogen don't get my snipmate.vim. I add
      source [path]\bundle\snipmate\after\plugin\snipMate.vim to _vimrc

      Test fail again

      Running on windows 7 32bits with gvim 7.3

      Any help appreciated

      Thanks in advance


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Marc Weber
      How to find out whether plugin files got loaded? ... snipmate is using vundle/snipmate/after/plugin/snipMate.vim Important is your &rtp setting. Try
      Message 2 of 22 , Nov 12, 2013
        How to find out whether plugin files got loaded?
        :scriptnames, more ideas see [2]
        snipmate is using vundle/snipmate/after/plugin/snipMate.vim

        Important is your &rtp setting. Try <c-r>=&rtp<cr> in insert mode.
        That should contain the bundle/snipmate/after directory.

        [1] talks about the special case after/* which pathogen should take care
        of (I checked source of latest 1270dceb1fe)

        [1]: http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html
        [2]: http://vim-wiki.mawercer.de/wiki/topic/debugging-viml.html

        to learn that special care must be taken to make the after/plugin
        directory work. Current pathogen does this.

        There are *many* versions of snipmate. The upstream snipmate version
        (which fixed quite many bugs) is at github.com/garbas/vim-snipmate
        (dependencies which VAM can install automatically see its
        addon-info.json file)

        If you need a quick second way to test what the problem is I can
        recommend the VAM downloader for Windows:
        http://vam.mawercer.de/

        Just get "snipmate" plugin from that page, dependencies will be added automatically.
        You'll get a _vimrc and a vimfiles directory. If that dosen't work we
        have to discuss and fix your case.

        Marc Weber

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Luc-Frédéric Langis
        ... I already done this and snip ... I try with vunble, and it has fail. ... It s show me nothing except =&rtp ... Sadly, it s the same result :( ...
        Message 3 of 22 , Nov 13, 2013
          Le mardi 12 novembre 2013 14:39:54 UTC+1, MarcWeber a écrit :
          > How to find out whether plugin files got loaded?
          >
          > :scriptnames, more ideas see [2]

          I already done this and snip

          >
          > snipmate is using vundle/snipmate/after/plugin/snipMate.vim

          I try with vunble, and it has fail.
          >
          >
          >
          > Important is your &rtp setting. Try <c-r>=&rtp<cr> in insert mode.

          It's show me nothing except <c-r>=&rtp<cr>
          >
          > That should contain the bundle/snipmate/after directory.
          >
          >
          >
          > [1] talks about the special case after/* which pathogen should take care
          >
          > of (I checked source of latest 1270dceb1fe)
          >
          >
          >
          > [1]: http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html
          >
          > [2]: http://vim-wiki.mawercer.de/wiki/topic/debugging-viml.html
          >
          >
          >
          > to learn that special care must be taken to make the after/plugin
          >
          > directory work. Current pathogen does this.
          >
          >
          >
          > There are *many* versions of snipmate. The upstream snipmate version
          >
          > (which fixed quite many bugs) is at github.com/garbas/vim-snipmate
          >
          > (dependencies which VAM can install automatically see its
          >
          > addon-info.json file)
          >
          >
          >
          > If you need a quick second way to test what the problem is I can
          >
          > recommend the VAM downloader for Windows:
          >
          > http://vam.mawercer.de/
          Sadly, it's the same result :(
          >
          >
          >
          > Just get "snipmate" plugin from that page, dependencies will be added automatically.
          >
          > You'll get a _vimrc and a vimfiles directory. If that dosen't work we
          >
          > have to discuss and fix your case.
          >
          >
          >
          > Marc Weber

          Here my _vimrc
          set nocompatible

          " Encodage
          set encoding=utf-8
          set fileencoding=utf-8
          filetype indent plugin on | syn on

          " Pathogen pour la gestion en module [bundle]
          execute pathogen#infect()

          " Ajuste le visuel
          set guioptions-=m " remove menu bar
          set guioptions-=T " remove toolbar
          set guioptions-=r " remove right-hand scroll bar
          set guioptions+=LlRrb " remove left-hand scroll bar
          set guioptions-=LlRrb " remove left-hand scroll bar
          colorscheme custom " Color scheme

          " Fix update time [css-color]
          let g:cssColorVimDoNotMessMyUpdatetime = 1

          " Ctags extension [taglist]
          let g:tagbar_ctags_bin = 'C:\Users\Luc Langis\Desktop\gvim\Vim\vim73\bundle\ctags\ctags.exe'


          " Appel extension
          nnoremap ,t :TagbarToggle<CR>
          nnoremap ,n :NERDTree<CR>

          " Navigation entre les fenetres ( CTRL+W + [h,j,k,l] --> CRTL+[h,j,k,l] )
          nmap <C-j> <C-w>j
          nmap <C-k> <C-w>k
          nmap <C-h> <C-w>h
          nmap <C-l> <C-w>l

          "Backspace peut effacer
          set backspace=eol,start,indent

          " Recherche avec surlignement et prend mieux la case
          set ignorecase
          set smartcase
          "set hlsearch
          set incsearch

          " Unix comme type
          set ffs=unix,dos,mac

          " Formatage
          syntax on
          set number
          set smartindent
          set tabstop=4
          set shiftwidth=4



          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Marc Weber
          ... I meant 1) switch to instert mode 2) type ctrl-r then character = then &rtp then hit return The result in my case looks like this:
          Message 4 of 22 , Nov 13, 2013
            Excerpts from Luc-Frédéric Langis's message of Wed Nov 13 11:16:46 +0100 2013:
            > > Important is your &rtp setting. Try <c-r>=&rtp<cr> in insert mode.
            > It's show me nothing except <c-r>=&rtp<cr>

            I meant
            1) switch to instert mode
            2) type ctrl-r then character = then &rtp then hit return

            The result in my case looks like this:

            /home/marc/.vim,/home/marc/mwr/vim-addon-other,/home/marc/mwr/vim-addon-mru,/home/marc/mwr/vim-addon-commenting,/home/marc/mwr/vim-addon-local-vimrc [...]

            Maybe this is easier (vim command):

            :put=split(&rtp,',')

            Have a look for all lines containing snipmate, in particular such:

            bundle/snipmate/after

            Marc Weber

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Luc-Frédéric Langis
            Thank again for the help. The only line with snipmate I got C: Users Luc Langis Desktop gvim Vim vim74 bundle snipmate after/plugin/snipmate.vim still missing.
            Message 5 of 22 , Nov 13, 2013
              Thank again for the help.

              The only line with snipmate I got

              C:\Users\Luc Langis\Desktop\gvim\Vim\vim74\bundle\snipmate

              after/plugin/snipmate.vim still missing. :/ So my fix woth source [path]/after/plugin/snipmate.vim doesn't work.

              How can I set my vimrc to search the missing file ?

              Thank

              Luc

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • dyh_2011
              ... Could you show the output of :sriptnames command ? I think you may install pathogen not correctly. ... I guess you put all to the C: Users Luc
              Message 6 of 22 , Nov 14, 2013
                hi:
                > :scriptnames, more ideas see [2]
                >I already done this and snip
                Could you show the output of :sriptnames command ?
                I think you may install pathogen not correctly.
                >" Ctags extension [taglist]
                >let g:tagbar_ctags_bin = 'C:\Users\Luc Langis\Desktop\gvim\Vim\vim73\bundle\ctags\ctags.exe'
                I guess you put all to the "'C:\Users\Luc Langis\Desktop\gvim\Vim\vim73\bundle", did you?
                if so, I think you did everything in a wrong directory.
                    you can install pathogen following this:

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Luc-Frédéric Langis
                ... I add scriptnames.png in the attachement of the message. ... I don t think I did it wrong. Because Desktop gvim Vim vim73 bundle was my installation
                Message 7 of 22 , Nov 18, 2013
                  Le vendredi 15 novembre 2013 03:28:12 UTC+1, dyh_2011 a écrit :
                  > hi:
                  >
                  > > :scriptnames, more ideas see [2]

                  I add scriptnames.png in the attachement of the message.

                  > >I already done this and snip
                  >
                  > Could you show the output of :sriptnames command ?
                  >
                  >
                  > I think you may install pathogen not
                  > correctly.
                  >
                  >
                  >
                  > >" Ctags extension [taglist]
                  >
                  > >let g:tagbar_ctags_bin = 'C:\Users\Luc Langis\Desktop\gvim\Vim\vim73\bundle\ctags\ctags.exe'
                  >
                  > I guess you put all to the
                  > "'C:\Users\Luc Langis\Desktop\gvim\Vim\vim73\bundle", did you?
                  >
                  > if so, I think you did everything in a wrong
                  > directory.
                  >
                  >     you can install pathogen following this:
                  >
                  > https://github.com/tpope/vim-pathogen/blob/master/README.markdown

                  I don't think I did it wrong. Because Desktop\gvim\Vim\vim73\bundle was my installation directory at the time (I ain't have the administrator right to install on program file).

                  Now, vim is in C:\Program Files\Vim\vim74 (with administrator right) but snip still don't work :(

                  Thank for the help

                  Luc-F.

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Luc-Frédéric Langis
                  Scriptnames http://imageshack.com/a/img826/4376/n1up.png -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below
                  Message 8 of 22 , Nov 18, 2013
                    Scriptnames http://imageshack.com/a/img826/4376/n1up.png


                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Nikolay Pavlov
                    On Nov 18, 2013 12:54 PM, Luc-Frédéric Langis ... No need to use screenshots. Use ... . This way you get scriptnames output in
                    Message 9 of 22 , Nov 18, 2013


                      On Nov 18, 2013 12:54 PM, "Luc-Frédéric Langis" <lucf.langis@...> wrote:
                      >
                      > Scriptnames http://imageshack.com/a/img826/4376/n1up.png

                      No need to use screenshots. Use

                          :redir @+
                          :silent scriptnames
                          :redir END

                      . This way you get scriptnames output in system clipboard.

                      > --
                      > --
                      > You received this message from the "vim_use" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php
                      >
                      > ---
                      > You received this message because you are subscribed to the Google Groups "vim_use" group.
                      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      > For more options, visit https://groups.google.com/groups/opt_out.

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Luc-Frédéric Langis
                      ... Thank for the tips 1: ~ _vimrc 2: C: Program Files Vim vim74 filetype.vim 3: C: Program Files Vim vim74 menu.vim 4: C: Program
                      Message 10 of 22 , Nov 18, 2013
                        Le lundi 18 novembre 2013 09:57:52 UTC+1, ZyX a écrit :
                        > On Nov 18, 2013 12:54 PM, "Luc-Frédéric Langis" <lucf....@...> wrote:
                        >
                        > >
                        >
                        > > Scriptnames http://imageshack.com/a/img826/4376/n1up.png
                        >
                        > No need to use screenshots. Use
                        >
                        >     :redir @+
                        >
                        >     :silent scriptnames
                        >
                        >     :redir END
                        >
                        > . This way you get scriptnames output in system clipboard.
                        >
                        > > --
                        >
                        > > --
                        >
                        > > You received this message from the "vim_use" maillist.
                        >
                        > > Do not top-post! Type your reply below the text you are replying to.
                        >
                        > > For more information, visit http://www.vim.org/maillist.php
                        >
                        > >
                        >
                        > > ---
                        >
                        > > You received this message because you are subscribed to the Google Groups "vim_use" group.
                        >
                        > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+u...@....
                        >
                        > > For more options, visit https://groups.google.com/groups/opt_out.

                        Thank for the tips



                        1: ~\_vimrc
                        2: C:\Program Files\Vim\vim74\filetype.vim
                        3: C:\Program Files\Vim\vim74\menu.vim
                        4: C:\Program Files\Vim\vim74\lang\menu_fr.utf-8.vim
                        5: C:\Program Files\Vim\vim74\lang\menu_fr_fr.latin1.vim
                        6: C:\Program Files\Vim\vim74\autoload\paste.vim
                        7: C:\Program Files\Vim\vim74\ftplugin.vim
                        8: C:\Program Files\Vim\vim74\autoload\pathogen.vim
                        9: C:\Program Files\Vim\vim74\ftoff.vim
                        10: C:\Program Files\Vim\vim74\bundle\less\ftdetect\less.vim
                        11: C:\Program Files\Vim\vim74\colors\custom.vim
                        12: C:\Program Files\Vim\vim74\syntax\syntax.vim
                        13: C:\Program Files\Vim\vim74\syntax\synload.vim
                        14: C:\Program Files\Vim\vim74\syntax\syncolor.vim
                        15: C:\Program Files\Vim\vim74\plugin\getscriptPlugin.vim
                        16: C:\Program Files\Vim\vim74\plugin\gzip.vim
                        17: C:\Program Files\Vim\vim74\plugin\matchparen.vim
                        18: C:\Program Files\Vim\vim74\plugin\netrwPlugin.vim
                        19: C:\Program Files\Vim\vim74\plugin\rrhelper.vim
                        20: C:\Program Files\Vim\vim74\plugin\spellfile.vim
                        21: C:\Program Files\Vim\vim74\plugin\tarPlugin.vim
                        22: C:\Program Files\Vim\vim74\plugin\tohtml.vim
                        23: C:\Program Files\Vim\vim74\plugin\vimballPlugin.vim
                        24: C:\Program Files\Vim\vim74\plugin\zipPlugin.vim
                        25: C:\Program Files\Vim\vim74\bundle\emmet\plugin\emmet.vim
                        26: C:\Program Files\Vim\vim74\bundle\jsbeautify\plugin\beautifier.vim
                        27: C:\Program Files\Vim\vim74\bundle\NERDtree\plugin\NERD_tree.vim
                        28: C:\Program Files\Vim\vim74\bundle\NERDtree\autoload\nerdtree.vim
                        29: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\path.vim
                        30: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\menu_controller.vim
                        31: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\menu_item.vim
                        32: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\key_map.vim
                        33: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\bookmark.vim
                        34: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\tree_file_node.vim
                        35: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\tree_dir_node.vim
                        36: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\opener.vim
                        37: C:\Program Files\Vim\vim74\bundle\NERDtree\lib\nerdtree\creator.vim
                        38: C:\Program Files\Vim\vim74\bundle\NERDtree\nerdtree_plugin\exec_menuitem.vim
                        39: C:\Program Files\Vim\vim74\bundle\NERDtree\nerdtree_plugin\fs_menu.vim
                        40: C:\Program Files\Vim\vim74\bundle\snipmate\plugin\snipMate.vim
                        41: C:\Program Files\Vim\vim74\bundle\vim-addon-mw-utils\autoload\funcref.vim
                        42: C:\Program Files\Vim\vim74\bundle\snipmate\plugin\snipMateInterface.vim
                        43: C:\Program Files\Vim\vim74\bundle\sourcebeautify\plugin\sourcebeautify\sourcebeautify.vim
                        44: C:\Program Files\Vim\vim74\bundle\surround\plugin\surround.vim
                        45: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\autoloclist.vim
                        46: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\balloons.vim
                        47: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\checker.vim
                        48: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\cursor.vim
                        49: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\highlighting.vim
                        50: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\loclist.vim
                        51: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\makeprg_builder.vim
                        52: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\modemap.vim
                        53: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\notifiers.vim
                        54: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\registry.vim
                        55: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic\signs.vim
                        56: C:\Program Files\Vim\vim74\bundle\syntastic\plugin\syntastic.vim
                        57: C:\Program Files\Vim\vim74\bundle\tagbar\plugin\tagbar.vim
                        58: C:\Program Files\Vim\vim74\bundle\tlib\plugin\02tlib.vim
                        59: C:\Program Files\Vim\vim74\bundle\syntastic\autoload\syntastic\util.vim

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Егор
                        How can I run console command before saving file? Is it possible to do it when type :w? -- -- You received this message from the vim_use maillist. Do not
                        Message 11 of 22 , Nov 18, 2013
                          How can I run console command before saving file? Is it possible to do
                          it when type :w?

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        • Paul Isambert
                          ... (see help :bar on why you can t simply use :!cmd | w ). If you want to do something whenever you write a buffer to a file, use the BufWrite autocommand.
                          Message 12 of 22 , Nov 18, 2013
                            "Егор" <negrmen@...>:
                            > How can I run console command before saving file? Is it possible to
                            > do it when type :w?

                            It depends on what you want to do exactly; you can try:

                            :execute "!cmd" | w

                            (see "help :bar" on why you can't simply use ":!cmd | w").

                            If you want to do something whenever you write a buffer to a file, use the
                            BufWrite autocommand.

                            Best,
                            Paul

                            --
                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php

                            ---
                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                            For more options, visit https://groups.google.com/groups/opt_out.
                          • Егор
                            ... Ok, next question. I use autocmd BufWrite * execute !apache restart Now i need hit two times when use :w Is it possible to fix it? -- -- You
                            Message 13 of 22 , Nov 18, 2013
                              18.11.2013 13:54, Paul Isambert написав(ла):
                              > "Егор" <negrmen@...>:
                              >> How can I run console command before saving file? Is it possible to
                              >> do it when type :w?
                              > It depends on what you want to do exactly; you can try:
                              >
                              > :execute "!cmd" | w
                              >
                              > (see "help :bar" on why you can't simply use ":!cmd | w").
                              >
                              > If you want to do something whenever you write a buffer to a file, use the
                              > BufWrite autocommand.
                              >
                              > Best,
                              > Paul
                              >
                              Ok, next question. I use autocmd BufWrite * execute "!apache restart"
                              Now i need hit <Enter> two times when use :w Is it possible to fix it?

                              --
                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php

                              ---
                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                              For more options, visit https://groups.google.com/groups/opt_out.
                            • Paul Isambert
                              Егор ... You re welcome. ... I guess you re looking for autocmd BufWrite * execute silent !apache restart Best, Paul -- -- You
                              Message 14 of 22 , Nov 18, 2013
                                "Егор" <negrmen@...>
                                > 18.11.2013 13:54, Paul Isambert написав(ла):
                                > > "Егор" <negrmen@...>:
                                > >> How can I run console command before saving file? Is it possible
                                > >> to
                                > >> do it when type :w?
                                > > It depends on what you want to do exactly; you can try:
                                > >
                                > > :execute "!cmd" | w
                                > >
                                > > (see "help :bar" on why you can't simply use ":!cmd | w").
                                > >
                                > > If you want to do something whenever you write a buffer to a file,
                                > > use the
                                > > BufWrite autocommand.
                                > >
                                > > Best,
                                > > Paul
                                > >
                                > Ok, next question.

                                You're welcome.

                                > I use autocmd BufWrite * execute "!apache restart"
                                > Now i need hit <Enter> two times when use :w Is it possible to fix
                                > it?

                                I guess you're looking for

                                autocmd BufWrite * execute "silent !apache restart"

                                Best,
                                Paul

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              • Ben Fritz
                                ... For your NEXT question, please start a NEW thread instead of hijacking somebody else s (or even your own on an unrelated topic). -- -- You received this
                                Message 15 of 22 , Nov 18, 2013
                                  On Monday, November 18, 2013 7:30:44 AM UTC-6, Егор wrote:
                                  > 18.11.2013 13:54, Paul Isambert написав(ла):
                                  >
                                  > > "Егор" <negrmen@...>:
                                  >
                                  > >> How can I run console command before saving file? Is it possible to
                                  >
                                  > >> do it when type :w?
                                  >
                                  > > It depends on what you want to do exactly; you can try:
                                  >
                                  > >
                                  >
                                  > > :execute "!cmd" | w
                                  >
                                  > >
                                  >
                                  > > (see "help :bar" on why you can't simply use ":!cmd | w").
                                  >
                                  > >
                                  >
                                  > > If you want to do something whenever you write a buffer to a file, use the
                                  >
                                  > > BufWrite autocommand.
                                  >
                                  > >
                                  >
                                  > > Best,
                                  >
                                  > > Paul
                                  >
                                  > >
                                  >
                                  > Ok, next question. I use autocmd BufWrite * execute "!apache restart"
                                  >
                                  > Now i need hit <Enter> two times when use :w Is it possible to fix it?

                                  For your NEXT question, please start a NEW thread instead of hijacking somebody else's (or even your own on an unrelated topic).

                                  --
                                  --
                                  You received this message from the "vim_use" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php

                                  ---
                                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                  For more options, visit https://groups.google.com/groups/opt_out.
                                • Gary Johnson
                                  ... There is no need for the :execute command here. The following will suffice. autocmd BufWrite * silent !apache restart Regards, Gary -- -- You received
                                  Message 16 of 22 , Nov 18, 2013
                                    On 2013-11-18, Paul Isambert wrote:
                                    > "Егор"
                                    > > 18.11.2013 13:54, Paul Isambert написав(ла):
                                    > > > "Егор":
                                    > > >> How can I run console command before saving file? Is it possible
                                    > > >> to
                                    > > >> do it when type :w?
                                    > > > It depends on what you want to do exactly; you can try:
                                    > > >
                                    > > > :execute "!cmd" | w
                                    > > >
                                    > > > (see "help :bar" on why you can't simply use ":!cmd | w").
                                    > > >
                                    > > > If you want to do something whenever you write a buffer to a file,
                                    > > > use the
                                    > > > BufWrite autocommand.
                                    > > >
                                    > > > Best,
                                    > > > Paul
                                    > > >
                                    > > Ok, next question.
                                    >
                                    > You're welcome.
                                    >
                                    > > I use autocmd BufWrite * execute "!apache restart"
                                    > > Now i need hit <Enter> two times when use :w Is it possible to fix
                                    > > it?
                                    >
                                    > I guess you're looking for
                                    >
                                    > autocmd BufWrite * execute "silent !apache restart"

                                    There is no need for the :execute command here. The following will
                                    suffice.

                                    autocmd BufWrite * silent !apache restart

                                    Regards,
                                    Gary

                                    --
                                    --
                                    You received this message from the "vim_use" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php

                                    ---
                                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                    For more options, visit https://groups.google.com/groups/opt_out.
                                  • Paul Isambert
                                    ... Oh yes, I’ve blindly modified the OP’s code, which was a mix of my first two solutions. Best, Paul -- -- You received this message from the vim_use
                                    Message 17 of 22 , Nov 18, 2013
                                      Gary Johnson <garyjohn@...> a écrit:
                                      > On 2013-11-18, Paul Isambert wrote:
                                      > > "Егор"
                                      > > > 18.11.2013 13:54, Paul Isambert написав(ла):
                                      > > > > "Егор":
                                      > > > >> How can I run console command before saving file? Is it possible
                                      > > > >> to
                                      > > > >> do it when type :w?
                                      > > > > It depends on what you want to do exactly; you can try:
                                      > > > >
                                      > > > > :execute "!cmd" | w
                                      > > > >
                                      > > > > (see "help :bar" on why you can't simply use ":!cmd | w").
                                      > > > >
                                      > > > > If you want to do something whenever you write a buffer to a file,
                                      > > > > use the
                                      > > > > BufWrite autocommand.
                                      > > > >
                                      > > > > Best,
                                      > > > > Paul
                                      > > > >
                                      > > > Ok, next question.
                                      > >
                                      > > You're welcome.
                                      > >
                                      > > > I use autocmd BufWrite * execute "!apache restart"
                                      > > > Now i need hit <Enter> two times when use :w Is it possible to fix
                                      > > > it?
                                      > >
                                      > > I guess you're looking for
                                      > >
                                      > > autocmd BufWrite * execute "silent !apache restart"
                                      >
                                      > There is no need for the :execute command here. The following will
                                      > suffice.
                                      >
                                      > autocmd BufWrite * silent !apache restart

                                      Oh yes, I’ve blindly modified the OP’s code, which was a mix of my first two solutions.

                                      Best,
                                      Paul

                                      --
                                      --
                                      You received this message from the "vim_use" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php

                                      ---
                                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                      For more options, visit https://groups.google.com/groups/opt_out.
                                    • Luc-Frédéric Langis
                                      Sorry to interrup guys, but can we got back to the main question ? Like why snipmate don t want to work with my config ? Thank -- -- You received this message
                                      Message 18 of 22 , Nov 18, 2013
                                        Sorry to interrup guys,

                                        but can we got back to the main question ? Like why snipmate don't want to work with my config ?

                                        Thank

                                        --
                                        --
                                        You received this message from the "vim_use" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php

                                        ---
                                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                        For more options, visit https://groups.google.com/groups/opt_out.
                                      • Marc Weber
                                        C: Users Luc Langis Desktop gvim Vim vim74 bundle snipmate after/plugin/snipmate.vim still missing. :/ So my fix woth source [path]/after/plugin/snipmate.vim
                                        Message 19 of 22 , Nov 18, 2013
                                          C:\Users\Luc Langis\Desktop\gvim\Vim\vim74\bundle\snipmate

                                          after/plugin/snipmate.vim still missing. :/ So my fix woth source
                                          [path]/after/plugin/snipmate.vim doesn't work.

                                          Didn't we already talk about set rtp+= .. ? that it should contain the
                                          after directory?

                                          Let me remind you that I thought that pathogen should be able to handle
                                          this (if you use latest version).

                                          If you still have trouble contact me by private mail, I can offer
                                          connecting to your machine by remote sharing or I can offer you to
                                          connect to my virtual Windows so that you can show you how to setup
                                          snipmate - because yes - this just takes too long.

                                          Marc Weber

                                          --
                                          --
                                          You received this message from the "vim_use" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php

                                          ---
                                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                          For more options, visit https://groups.google.com/groups/opt_out.
                                        • Luc-Frédéric Langis
                                          Hi Marc, I read all the post again and I make some new ajustement for pathogen. Now my bundle folder is in ~/vimfiles/bundle . Here rtp result C: Users Luc
                                          Message 20 of 22 , Nov 19, 2013
                                            Hi Marc,

                                            I read all the post again and I make some new ajustement for pathogen. Now my bundle folder is in ~/vimfiles/bundle .

                                            Here rtp result

                                            C:\Users\Luc Langis/vimfiles,
                                            C:\Users\Luc Langis\vimfiles\bundle\css-color,
                                            C:\Users\Luc Langis\vimfiles\bundle\ctags,
                                            C:\Users\Luc Langis\vimfiles\bundle\emmet,
                                            C:\Users\Luc Langis\vimfiles\bundle\jsbeautify,
                                            C:\Users\Luc Langis\vimfiles\bundle\less,
                                            C:\Users\Luc Langis\vimfiles\bundle\NERDtree,
                                            C:\Users\Luc Langis\vimfiles\bundle\snipmate,
                                            C:\Users\Luc Langis\vimfiles\bundle\sourcebeautify,
                                            C:\Users\Luc Langis\vimfiles\bundle\surround,
                                            C:\Users\Luc Langis\vimfiles\bundle\syntastic,
                                            C:\Users\Luc Langis\vimfiles\bundle\tagbar,
                                            C:\Users\Luc Langis\vimfiles\bundle\tlib,
                                            C:\Users\Luc Langis\vimfiles\bundle\vim-addon-mw-utils,
                                            C:\Program Files\Vim/vimfiles,
                                            C:\Program Files\Vim\vim74,
                                            C:\Program Files\Vim/vimfiles/after,
                                            C:\Users\Luc Langis\vimfiles\bundle\snipmate\after,
                                            C:\Users\Luc Langis/vimfiles/after

                                            He load C:\Users\Luc Langis\vimfiles\bundle\snipmate\after .

                                            So I don't know why it's not working. I try with a "clean" installation. Only snipmate, tlib and vim-addon-mw-utils, with a clean vimrc file and nothing work. So snipmate is not in conflict with a another bundle.

                                            Thank for the offer Marc, but I'm on my work computer. I don't have the permission to let someone to connect to the computer.

                                            Thank all for the help, but I think snipmate not gonna work with me :/.

                                            --
                                            --
                                            You received this message from the "vim_use" maillist.
                                            Do not top-post! Type your reply below the text you are replying to.
                                            For more information, visit http://www.vim.org/maillist.php

                                            ---
                                            You received this message because you are subscribed to the Google Groups "vim_use" group.
                                            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                            For more options, visit https://groups.google.com/groups/opt_out.
                                          • Marc Weber
                                            ... So that file is there. Try source C: Users Luc Langis vimfiles bundle snipmate plugin snipMate.vim source C: Users Luc
                                            Message 21 of 22 , Nov 19, 2013
                                              > C:\Users\Luc Langis\vimfiles\bundle\snipmate\after,
                                              So that file is there.

                                              Try
                                              source C:\\Users\\Luc\ Langis\\vimfiles\\bundle\\snipmate\\plugin\\snipMate.vim
                                              source C:\\Users\\Luc\ Langis\\vimfiles\\bundle\\snipmate\\after\\plugin\snipMate.vim
                                              Does after Vim started. Does it work or throw error messages then?
                                              Also check :messages.

                                              after Vim has started up.
                                              About the offer: I offered two things:
                                              a) connect to your machine
                                              b) let you connect to my machine to investigate

                                              You've missed option b.

                                              Marc Weber

                                              --
                                              --
                                              You received this message from the "vim_use" maillist.
                                              Do not top-post! Type your reply below the text you are replying to.
                                              For more information, visit http://www.vim.org/maillist.php

                                              ---
                                              You received this message because you are subscribed to the Google Groups "vim_use" group.
                                              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                              For more options, visit https://groups.google.com/groups/opt_out.
                                            • Luc-Frédéric Langis
                                              ... Just a last update. Finaly, I give up for snipmate. I try the neocomplete ( https://github.com/Shougo/neocomplete.vim ) plugin and he work find for me.
                                              Message 22 of 22 , Nov 19, 2013
                                                Le mardi 19 novembre 2013 09:34:45 UTC+1, Luc-Frédéric Langis a écrit :
                                                > Hi Marc,
                                                >
                                                > I read all the post again and I make some new ajustement for pathogen. Now my bundle folder is in ~/vimfiles/bundle .
                                                >
                                                > Here rtp result
                                                >
                                                > C:\Users\Luc Langis/vimfiles,
                                                > C:\Users\Luc Langis\vimfiles\bundle\css-color,
                                                > C:\Users\Luc Langis\vimfiles\bundle\ctags,
                                                > C:\Users\Luc Langis\vimfiles\bundle\emmet,
                                                > C:\Users\Luc Langis\vimfiles\bundle\jsbeautify,
                                                > C:\Users\Luc Langis\vimfiles\bundle\less,
                                                > C:\Users\Luc Langis\vimfiles\bundle\NERDtree,
                                                > C:\Users\Luc Langis\vimfiles\bundle\snipmate,
                                                > C:\Users\Luc Langis\vimfiles\bundle\sourcebeautify,
                                                > C:\Users\Luc Langis\vimfiles\bundle\surround,
                                                > C:\Users\Luc Langis\vimfiles\bundle\syntastic,
                                                > C:\Users\Luc Langis\vimfiles\bundle\tagbar,
                                                > C:\Users\Luc Langis\vimfiles\bundle\tlib,
                                                > C:\Users\Luc Langis\vimfiles\bundle\vim-addon-mw-utils,
                                                > C:\Program Files\Vim/vimfiles,
                                                > C:\Program Files\Vim\vim74,
                                                > C:\Program Files\Vim/vimfiles/after,
                                                > C:\Users\Luc Langis\vimfiles\bundle\snipmate\after,
                                                > C:\Users\Luc Langis/vimfiles/after
                                                >
                                                > He load C:\Users\Luc Langis\vimfiles\bundle\snipmate\after .
                                                >
                                                > So I don't know why it's not working. I try with a "clean" installation. Only snipmate, tlib and vim-addon-mw-utils, with a clean vimrc file and nothing work. So snipmate is not in conflict with a another bundle.
                                                >
                                                > Thank for the offer Marc, but I'm on my work computer. I don't have the permission to let someone to connect to the computer.
                                                >
                                                > Thank all for the help, but I think snipmate not gonna work with me :/.

                                                Just a last update. Finaly, I give up for snipmate. I try the neocomplete ( https://github.com/Shougo/neocomplete.vim ) plugin and he work find for me.

                                                Thank for all your help.

                                                Luc

                                                --
                                                --
                                                You received this message from the "vim_use" maillist.
                                                Do not top-post! Type your reply below the text you are replying to.
                                                For more information, visit http://www.vim.org/maillist.php

                                                ---
                                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                                For more options, visit https://groups.google.com/groups/opt_out.
                                              Your message has been successfully submitted and would be delivered to recipients shortly.