Loading ...
Sorry, an error occurred while loading the content.

Is it possible to get GNU Unifont to work with GVim?

Expand Messages
  • Sibin Thomas
    Hi, Is there any way to get GNU Unifont to work with GVim? Environment details - Windows 7, 64 bit, Vim 7.3 (64 bit) Steps undertaken so far ... * I downloaded
    Message 1 of 2 , Nov 9, 2013
    • 0 Attachment
      Hi,

      Is there any way to get GNU Unifont to work with GVim?
      Environment details - Windows 7, 64 bit, Vim 7.3 (64 bit)

      Steps undertaken so far
      ---------------------------------
      * I downloaded the GNU Unifont TrueType font from here -> http://unifoundry.com/unifont.html
      * I pasted this file in the Windows/Fonts directory.
      * In GVim I tried to select this font via :se guifont=*. I don't see it in the Font selection window.  For the record, the options available to me are - Consolas, Courier, Courier New, Courier10 BT, DejaVu Sans Mono, Fixedsys, Lucida Console and Terminal.
      * Clicking the "Show more fonts" button at the bottom of the dialog just leads to the Fonts folder in Control Panel. No pertinent action can be taken here.

      If the answer to the above question is 'No', are there any other GVim compatible Unicode fonts with as broad a character support as that of GNU Unifont or Arial Unicode MS?

      --
      Regards,
      Sibin

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... If GNU Unifont is not defined as a monospace font (i.e. if it hasn t got in its font descriptor the bit telling the OS that all glyphs are the same width),
      Message 2 of 2 , Nov 11, 2013
      • 0 Attachment
        On 09/11/13 13:43, Sibin Thomas wrote:
        > Hi,
        >
        > Is there any way to get GNU Unifont to work with GVim?
        > Environment details - Windows 7, 64 bit, Vim 7.3 (64 bit)
        >
        > Steps undertaken so far
        > ---------------------------------
        > * I downloaded the GNU Unifont TrueType font
        > <http://unifoundry.com/pub/unifont-6.3.20131020/font-builds/unifont-6.3.20131020.ttf>
        > from here -> http://unifoundry.com/unifont.html
        > * I pasted this file in the Windows/Fonts directory.
        > * In GVim I tried to select this font via :se guifont=*. I don't see it
        > in the Font selection window. For the record, the options available to
        > me are - Consolas, Courier, Courier New, Courier10 BT, DejaVu Sans
        > Mono, Fixedsys, Lucida Console and Terminal.
        > * Clicking the "Show more fonts" button at the bottom of the dialog just
        > leads to the Fonts folder in Control Panel. No pertinent action can be
        > taken here.
        >
        > If the answer to the above question is 'No', are there any other GVim
        > compatible Unicode fonts with as broad a character support as that of
        > /GNU Unifont/ or /Arial Unicode MS/?
        >
        > --
        > Regards,
        > Sibin

        If GNU Unifont is not defined as a monospace font (i.e. if it hasn't got
        in its font descriptor the bit telling the OS that all glyphs are the
        same width), then the only version of gvim which will accept it is the
        GTK2 version (which runs only on Unix/Linux, on Cygwin with X11, or on
        Mac OSX with X11 — and running X11 on Cygwin or on a Mac is usually not
        the best solution). In addition, if all glyphs are not actually the same
        width, it will look ugly even in gvim for GTK2 (thin letters such as i I
        l will have too much empty space around them, and fat-width letters such
        as M m will look cramped).

        Try installing the GNU Unifont Mono font if you can find it. In my GTK2
        gvim I can't see the difference between the "abcdefghijk ABCDEFGHIJK"
        sample shown for either of them in the font selector. (In general, any
        font with one of the words "Mono", "Monospace" or "Fixed" — or even
        "Typewriter" — as part of its name is quasi-certainly a monospaced font.)


        Best regards,
        Tony.
        --
        If a guru falls in the forest with no one to hear him, was he really a
        guru at all?
        -- Strange de Jim, "The Metasexuals"

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.