Loading ...
Sorry, an error occurred while loading the content.

Vim variables not being created.

Expand Messages
  • sai baba
    Hi, Im new to Vim scripting. Im using a ftplugin from vimscripts.org and im getting a error E121 saying the variable is undefined. From my understanding any
    Message 1 of 11 , Oct 30, 2013
    • 0 Attachment
      Hi,

      Im new to Vim scripting.

      Im using a ftplugin from vimscripts.org and im getting a error E121 saying the variable is undefined.

      From my understanding any variables with scope w: or b: or l: or s: are not being created in my Gvim editor.

      I tried typing :let to see list of variables declared and i find, the variables declared in my script are not being listed or created.

      please help me in understanding..

      ps: Im using Gvim version 703 on linux machine.

      Thanks in advance
      sai

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Yeeeeah...these should work in any Vim except maybe with TINY features. What plugin? What variable? I suspect a plugin issue. Or maybe the plugin was
      Message 2 of 11 , Oct 30, 2013
      • 0 Attachment
        On Wednesday, October 30, 2013 8:22:52 AM UTC-5, sai baba wrote:
        > Hi,
        >
        > Im new to Vim scripting.
        >
        > Im using a ftplugin from vimscripts.org and im getting a error E121 saying the variable is undefined.
        >
        > From my understanding any variables with scope w: or b: or l: or s: are not being created in my Gvim editor.
        >
        > I tried typing :let to see list of variables declared and i find, the variables declared in my script are not being listed or created.
        >
        > please help me in understanding..
        >
        > ps: Im using Gvim version 703 on linux machine.
        >
        > Thanks in advance
        > sai

        Yeeeeah...these should work in any Vim except maybe with TINY features.

        What plugin? What variable? I suspect a plugin issue. Or maybe the plugin was designed for a more recent Vim. What exact Vim version do you have? There were over 1000 patches between the 7.3 and 7.4 releases.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Marc Weber
        When does viml code get run (which defines vars)? If you have the default setup, thus such (ftplugin etc enabled)
        Message 3 of 11 , Oct 30, 2013
        • 0 Attachment
          When does viml code get run (which defines vars)?

          If you have the default setup, thus such (ftplugin etc enabled)
          http://vim-wiki.mawercer.de/wiki/topic/vimrc.html

          Then ftplugin/*.vim files get sourced when such a filetype is opened.
          plugin/**/.vim files get sourced on startup
          autoload/** get sourced automatically as needed (function autolad feature)

          There are some more less cases such as ftdetect,syntax,... which I don't
          consider important.
          Thus make sure you're using such minimal .vimrc, if you still have
          problems with the plugin post again, then it might be a bug in the
          plugin or a filetype it did'nt expect.

          I haven't looked at the plugin yet - so everything I wrote about is
          important to know, but might not solve your issue.

          Marc Weber

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • sai baba
          ... Hi.. I have downloaded the pulgin from the below link.. http://www.vim.org/scripts/script.php?script_id=2372 File :: automatic.vim is the one im using. Im
          Message 4 of 11 , Oct 30, 2013
          • 0 Attachment
            On Wednesday, October 30, 2013 9:14:36 PM UTC+5:30, MarcWeber wrote:
            > When does viml code get run (which defines vars)?
            >
            >
            >
            > If you have the default setup, thus such (ftplugin etc enabled)
            >
            > http://vim-wiki.mawercer.de/wiki/topic/vimrc.html
            >
            >
            >
            > Then ftplugin/*.vim files get sourced when such a filetype is opened.
            >
            > plugin/**/.vim files get sourced on startup
            >
            > autoload/** get sourced automatically as needed (function autolad feature)
            >
            >
            >
            > There are some more less cases such as ftdetect,syntax,... which I don't
            >
            > consider important.
            >
            > Thus make sure you're using such minimal .vimrc, if you still have
            >
            > problems with the plugin post again, then it might be a bug in the
            >
            > plugin or a filetype it did'nt expect.
            >
            >
            >
            > I haven't looked at the plugin yet - so everything I wrote about is
            >
            > important to know, but might not solve your issue.
            >
            >
            >
            > Marc Weber

            Hi..

            I have downloaded the pulgin from the below link..

            http://www.vim.org/scripts/script.php?script_id=2372

            File :: automatic.vim is the one im using.

            Im placing this file in my home directory(linux) ~/.vim/ftdetect/automatic.vim

            is this the cause of problem??

            All local buffer variables(with b:*) in file automatic.vim are undefined.

            But i can still see the verilog menu being loaded from automatic.vim in my Gvim menu bar.

            Im using Gvim version 703.

            Thanks
            sai

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Christian Brabandt
            ... It s a filetype plugin, so you need to place it in ~/.vim/ftplugin/verilog/ (create directories, that don t exist), assuming that the filetype for verilog
            Message 5 of 11 , Oct 31, 2013
            • 0 Attachment
              On Thu, October 31, 2013 07:07, sai baba wrote:
              > On Wednesday, October 30, 2013 9:14:36 PM UTC+5:30, MarcWeber wrote:
              >> When does viml code get run (which defines vars)?
              >>
              >>
              >>
              >> If you have the default setup, thus such (ftplugin etc enabled)
              >>
              >> http://vim-wiki.mawercer.de/wiki/topic/vimrc.html
              >>
              >>
              >>
              >> Then ftplugin/*.vim files get sourced when such a filetype is opened.
              >>
              >> plugin/**/.vim files get sourced on startup
              >>
              >> autoload/** get sourced automatically as needed (function autolad
              >> feature)
              >>
              >>
              >>
              >> There are some more less cases such as ftdetect,syntax,... which I don't
              >>
              >> consider important.
              >>
              >> Thus make sure you're using such minimal .vimrc, if you still have
              >>
              >> problems with the plugin post again, then it might be a bug in the
              >>
              >> plugin or a filetype it did'nt expect.
              >>
              >>
              >>
              >> I haven't looked at the plugin yet - so everything I wrote about is
              >>
              >> important to know, but might not solve your issue.
              >>
              >>
              >>
              >> Marc Weber
              >
              > Hi..
              >
              > I have downloaded the pulgin from the below link..
              >
              > http://www.vim.org/scripts/script.php?script_id=2372
              >
              > File :: automatic.vim is the one im using.
              >
              > Im placing this file in my home directory(linux)
              > ~/.vim/ftdetect/automatic.vim

              It's a filetype plugin, so you need to place it in ~/.vim/ftplugin/verilog/
              (create directories, that don't exist), assuming that the filetype
              for verilog files is called verilog.

              Best,
              Christian

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Marc Weber
              There are several problems: - You didn t RTFM. http://www.vim.org/scripts/script.php?script_id=2372 clearly talks about where to put that file Consider joining
              Message 6 of 11 , Oct 31, 2013
              • 0 Attachment
                There are several problems:

                - You didn't RTFM. http://www.vim.org/scripts/script.php?script_id=2372
                clearly talks about where to put that file

                Consider joining the vim-addon-manager (VAM) [1] project which tries very hard to
                get such things right by default for plugins being used by the
                community.

                In this particular case it does.

                I agree that its most useful to understand how Vim and Vim plugins work.
                But this takes time.

                Marc Weber

                [1]: https://github.com/MarcWeber/vim-addon-manager

                compare with http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html
                which lists more plugin management options and tries to compare them.

                (If anybody thinks this page is unfair write me or just edit it. You can
                help make this be a fair and easy to use source of knowledge if you want
                to)

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • sai baba
                ... Placing the file in ~/.vim/ftplugin/verilog/ did NOT WORK, hence i tried placing the file in ~/.vim/ftdetect/ and i was able to load the script. variables
                Message 7 of 11 , Oct 31, 2013
                • 0 Attachment
                  On Thursday, October 31, 2013 1:13:36 PM UTC+5:30, Christian Brabandt wrote:
                  > On Thu, October 31, 2013 07:07, sai baba wrote:
                  >
                  > > On Wednesday, October 30, 2013 9:14:36 PM UTC+5:30, MarcWeber wrote:
                  >
                  > >> When does viml code get run (which defines vars)?
                  >
                  > >>
                  >
                  > >>
                  >
                  > >>
                  >
                  > >> If you have the default setup, thus such (ftplugin etc enabled)
                  >
                  > >>
                  >
                  > >> http://vim-wiki.mawercer.de/wiki/topic/vimrc.html
                  >
                  > >>
                  >
                  > >>
                  >
                  > >>
                  >
                  > >> Then ftplugin/*.vim files get sourced when such a filetype is opened.
                  >
                  > >>
                  >
                  > >> plugin/**/.vim files get sourced on startup
                  >
                  > >>
                  >
                  > >> autoload/** get sourced automatically as needed (function autolad
                  >
                  > >> feature)
                  >
                  > >>
                  >
                  > >>
                  >
                  > >>
                  >
                  > >> There are some more less cases such as ftdetect,syntax,... which I don't
                  >
                  > >>
                  >
                  > >> consider important.
                  >
                  > >>
                  >
                  > >> Thus make sure you're using such minimal .vimrc, if you still have
                  >
                  > >>
                  >
                  > >> problems with the plugin post again, then it might be a bug in the
                  >
                  > >>
                  >
                  > >> plugin or a filetype it did'nt expect.
                  >
                  > >>
                  >
                  > >>
                  >
                  > >>
                  >
                  > >> I haven't looked at the plugin yet - so everything I wrote about is
                  >
                  > >>
                  >
                  > >> important to know, but might not solve your issue.
                  >
                  > >>
                  >
                  > >>
                  >
                  > >>
                  >
                  > >> Marc Weber
                  >
                  > >
                  >
                  > > Hi..
                  >
                  > >
                  >
                  > > I have downloaded the pulgin from the below link..
                  >
                  > >
                  >
                  > > http://www.vim.org/scripts/script.php?script_id=2372
                  >
                  > >
                  >
                  > > File :: automatic.vim is the one im using.
                  >
                  > >
                  >
                  > > Im placing this file in my home directory(linux)
                  >
                  > > ~/.vim/ftdetect/automatic.vim
                  >
                  >
                  >
                  > It's a filetype plugin, so you need to place it in ~/.vim/ftplugin/verilog/
                  >
                  > (create directories, that don't exist), assuming that the filetype
                  >
                  > for verilog files is called verilog.
                  >
                  >
                  >
                  > Best,
                  >
                  > Christian

                  Placing the file in ~/.vim/ftplugin/verilog/ did NOT WORK, hence i tried placing the file in ~/.vim/ftdetect/ and i was able to load the script.

                  variables inside a function are being created but not from script.

                  Thanks
                  sai

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Nikolay Pavlov
                  ... don t ... ~/.vim/ftplugin/verilog/ ... placing the file in ~/.vim/ftdetect/ and i was able to load the script. Did NOT WORK does not provide any useful
                  Message 8 of 11 , Oct 31, 2013
                  • 0 Attachment


                    On Oct 31, 2013 1:47 PM, "sai baba" <baba.2288@...> wrote:
                    >
                    > On Thursday, October 31, 2013 1:13:36 PM UTC+5:30, Christian Brabandt wrote:
                    > > On Thu, October 31, 2013 07:07, sai baba wrote:
                    > >
                    > > > On Wednesday, October 30, 2013 9:14:36 PM UTC+5:30, MarcWeber wrote:
                    > >
                    > > >> When does viml code get run (which defines vars)?
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >> If you have the default setup, thus such (ftplugin etc enabled)
                    > >
                    > > >>
                    > >
                    > > >> http://vim-wiki.mawercer.de/wiki/topic/vimrc.html
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >> Then ftplugin/*.vim files get sourced when such a filetype is opened.
                    > >
                    > > >>
                    > >
                    > > >>   plugin/**/.vim files get sourced on startup
                    > >
                    > > >>
                    > >
                    > > >>   autoload/** get sourced automatically as needed (function autolad
                    > >
                    > > >> feature)
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >> There are some more less cases such as ftdetect,syntax,... which I don't
                    > >
                    > > >>
                    > >
                    > > >> consider important.
                    > >
                    > > >>
                    > >
                    > > >> Thus make sure you're using such minimal .vimrc, if you still have
                    > >
                    > > >>
                    > >
                    > > >> problems with the plugin post again, then it might be a bug in the
                    > >
                    > > >>
                    > >
                    > > >> plugin or a filetype it did'nt expect.
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >> I haven't looked at the plugin yet - so everything I wrote about is
                    > >
                    > > >>
                    > >
                    > > >> important to know, but might not solve your issue.
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >>
                    > >
                    > > >> Marc Weber
                    > >
                    > > >
                    > >
                    > > > Hi..
                    > >
                    > > >
                    > >
                    > > > I have downloaded the pulgin from the below link..
                    > >
                    > > >
                    > >
                    > > > http://www.vim.org/scripts/script.php?script_id=2372
                    > >
                    > > >
                    > >
                    > > > File :: automatic.vim is the one im using.
                    > >
                    > > >
                    > >
                    > > > Im placing this file in my home directory(linux)
                    > >
                    > > > ~/.vim/ftdetect/automatic.vim
                    > >
                    > >
                    > >
                    > > It's a filetype plugin, so you need to place it in ~/.vim/ftplugin/verilog/
                    > >
                    > > (create directories, that don't exist), assuming that the filetype
                    > >
                    > > for verilog files is called verilog.
                    > >
                    > >
                    > >
                    > > Best,
                    > >
                    > > Christian
                    >
                    > Placing the file in ~/.vim/ftplugin/verilog/ did NOT WORK, hence i tried placing the file in ~/.vim/ftdetect/ and i was able to load the script.

                    "Did NOT WORK" does not provide any useful information. What did you observe so that you say that placing does not work?

                    > variables inside a function are being created but not from script.
                    >
                    > Thanks
                    > sai
                    >
                    > --
                    > --
                    > You received this message from the "vim_use" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php
                    >
                    > ---
                    > You received this message because you are subscribed to the Google Groups "vim_use" group.
                    > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    > For more options, visit https://groups.google.com/groups/opt_out.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                     
                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Nikolay Pavlov
                    ... don t ... ~/.vim/ftplugin/verilog/ ... placing the file in ~/.vim/ftdetect/ and i was able to load the script. As Marc correctly said installation
                    Message 9 of 11 , Oct 31, 2013
                    • 0 Attachment


                      On Oct 31, 2013 1:47 PM, "sai baba" <baba.2288@...> wrote:
                      >
                      > On Thursday, October 31, 2013 1:13:36 PM UTC+5:30, Christian Brabandt wrote:
                      > > On Thu, October 31, 2013 07:07, sai baba wrote:
                      > >
                      > > > On Wednesday, October 30, 2013 9:14:36 PM UTC+5:30, MarcWeber wrote:
                      > >
                      > > >> When does viml code get run (which defines vars)?
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >> If you have the default setup, thus such (ftplugin etc enabled)
                      > >
                      > > >>
                      > >
                      > > >> http://vim-wiki.mawercer.de/wiki/topic/vimrc.html
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >> Then ftplugin/*.vim files get sourced when such a filetype is opened.
                      > >
                      > > >>
                      > >
                      > > >>   plugin/**/.vim files get sourced on startup
                      > >
                      > > >>
                      > >
                      > > >>   autoload/** get sourced automatically as needed (function autolad
                      > >
                      > > >> feature)
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >> There are some more less cases such as ftdetect,syntax,... which I don't
                      > >
                      > > >>
                      > >
                      > > >> consider important.
                      > >
                      > > >>
                      > >
                      > > >> Thus make sure you're using such minimal .vimrc, if you still have
                      > >
                      > > >>
                      > >
                      > > >> problems with the plugin post again, then it might be a bug in the
                      > >
                      > > >>
                      > >
                      > > >> plugin or a filetype it did'nt expect.
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >> I haven't looked at the plugin yet - so everything I wrote about is
                      > >
                      > > >>
                      > >
                      > > >> important to know, but might not solve your issue.
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >>
                      > >
                      > > >> Marc Weber
                      > >
                      > > >
                      > >
                      > > > Hi..
                      > >
                      > > >
                      > >
                      > > > I have downloaded the pulgin from the below link..
                      > >
                      > > >
                      > >
                      > > > http://www.vim.org/scripts/script.php?script_id=2372
                      > >
                      > > >
                      > >
                      > > > File :: automatic.vim is the one im using.
                      > >
                      > > >
                      > >
                      > > > Im placing this file in my home directory(linux)
                      > >
                      > > > ~/.vim/ftdetect/automatic.vim
                      > >
                      > >
                      > >
                      > > It's a filetype plugin, so you need to place it in ~/.vim/ftplugin/verilog/
                      > >
                      > > (create directories, that don't exist), assuming that the filetype
                      > >
                      > > for verilog files is called verilog.
                      > >
                      > >
                      > >
                      > > Best,
                      > >
                      > > Christian
                      >
                      > Placing the file in ~/.vim/ftplugin/verilog/ did NOT WORK, hence i tried placing the file in ~/.vim/ftdetect/ and i was able to load the script.

                      As Marc correctly said "installation details" section on the plugin page clearly shows you where to put the file. The location is neither ./ftplugin/verilog nor ./ftdetect.

                      > variables inside a function are being created but not from script.
                      >
                      > Thanks
                      > sai
                      >
                      > --
                      > --
                      > You received this message from the "vim_use" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php
                      >
                      > ---
                      > You received this message because you are subscribed to the Google Groups "vim_use" group.
                      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      > For more options, visit https://groups.google.com/groups/opt_out.

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • ZyX
                      ... It did *not*. There was no information about where to put the file by the time you were writing the message and VAM was putting file into ftplugin/ which
                      Message 10 of 11 , Oct 31, 2013
                      • 0 Attachment
                        On Thursday, October 31, 2013 1:16:36 PM UTC+4, MarcWeber wrote:
                        > There are several problems:
                        >
                        > - You didn't RTFM. http://www.vim.org/scripts/script.php?script_id=2372
                        > clearly talks about where to put that file
                        >
                        > Consider joining the vim-addon-manager (VAM) [1] project which tries very hard to
                        > get such things right by default for plugins being used by the
                        > community.
                        >
                        > In this particular case it does.

                        It did *not*. There was no information about where to put the file by the time you were writing the message and VAM was putting file into ftplugin/ which is incorrect.

                        > I agree that its most useful to understand how Vim and Vim plugins work.
                        > But this takes time.
                        >
                        > Marc Weber
                        >
                        > [1]: https://github.com/MarcWeber/vim-addon-manager
                        >
                        > compare with http://vim-wiki.mawercer.de/wiki/topic/vim%20plugin%20managment.html
                        > which lists more plugin management options and tries to compare them.
                        >
                        > (If anybody thinks this page is unfair write me or just edit it. You can
                        > help make this be a fair and easy to use source of knowledge if you want
                        > to)

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Marc Weber
                        ... You re right, sry, fixed. Marc Weber -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
                        Message 11 of 11 , Nov 1, 2013
                        • 0 Attachment
                          > It did *not*. There was no information about where to put the file by
                          > the time you were writing the message and VAM was putting file into
                          > ftplugin/ which is incorrect.
                          You're right, sry, fixed.

                          Marc Weber

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        Your message has been successfully submitted and would be delivered to recipients shortly.