Loading ...
Sorry, an error occurred while loading the content.
 

OutlookVim quoting

Expand Messages
  • Carlo Bertoldi
    Hello everybody, I m happily using OutlookVim plugin, but I have a problem with message quoting. I ve configured Outlook to prefix the original message with
    Message 1 of 4 , Oct 23, 2013
      Hello everybody,
      I'm happily using OutlookVim plugin, but I have a problem with message quoting.
      I've configured Outlook to prefix the original message with ">", but that character is not replicated into the Vim buffer.
      Is that a bug, or did I miss something in the documentation?

      Carlo

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • David Fishburn
      ... When the email is opened in Vim, the filetype is set to mail (typically). So you need to setup Vim the way you want it to to edit emails. There are many
      Message 2 of 4 , Oct 23, 2013

        On Wed, Oct 23, 2013 at 6:01 AM, Carlo Bertoldi <carlo.bertoldi@...> wrote:
        Hello everybody,
         I'm happily using OutlookVim plugin, but I have a problem with message quoting.
        I've configured Outlook to prefix the original message with ">", but that character is not replicated into the Vim buffer.
        Is that a bug, or did I miss something in the documentation?


        When the email is opened in Vim, the filetype is set to mail (typically).

        So you need to setup Vim the way you want it to to edit emails.
        There are many mail plugins for Vim, which will setup various maps for quoting and unquoting as well as setting the comment character.

        So, no bug in OutlookVim, you just need to setup your Vim the way you want it to edit emails.

        HTH,
        David 

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Carlo Bertoldi
        ... Yes it helped :) I ve read more of TFM and discovered about q and fo+=aw to format mail better. Another step towards a more vimmful experience :)
        Message 3 of 4 , Oct 24, 2013
          On Wednesday, October 23, 2013 1:17:18 PM UTC+2, David Fishburn wrote:
          > So, no bug in OutlookVim, you just need to setup your Vim the way you want it to edit emails.
          >
          >
          >
          > HTH,
          > David
          Yes it helped :)
          I've read more of TFM and discovered about <leader>q and fo+=aw to format mail better.
          Another step towards a more "vimmful" experience :)

          Carlo

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • David Fishburn
          On Thu, Oct 24, 2013 at 11:18 AM, Carlo Bertoldi ... I went down one path of using Mutt to edit my email some years ago. When I did that, I started with this
          Message 4 of 4 , Oct 24, 2013

            On Thu, Oct 24, 2013 at 11:18 AM, Carlo Bertoldi <carlo.bertoldi@...> wrote:
            On Wednesday, October 23, 2013 1:17:18 PM UTC+2, David Fishburn wrote:
            > So, no bug in OutlookVim, you just need to setup your Vim the way you want it to edit emails.
             
            ...
            I've read more of TFM and discovered about <leader>q and fo+=aw to format mail better.
            Another step towards a more "vimmful" experience :)

            I went down one path of using Mutt to edit my email some years ago.

            When I did that, I started with this mail ftplugin:

            Then added some of my own goo.

            Thought it might also help.

            David

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.