Loading ...
Sorry, an error occurred while loading the content.

Re: why is vim autoindenting even if set noautoindent is on?

Expand Messages
  • "天井冴太 (AmaiSaeta)"
    ... In this case, autoindent doesn t effect. Use cindent . -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
    Message 1 of 3 , Oct 4, 2013
    • 0 Attachment
      (2013年10月05日 10:46), DwigtArmyOfChampions wrote:
      > I type "set noai" to disable auto-indents, but when I have, for example, a piece of code like the following:
      >
      > int main() {
      > }
      >
      > If I put my cursor on the end of the line on the first curly brace, type "i" to go into Insert mode, and then hit return, it still indents with a tab character. Why is this happening if auto-indent is turned off?
      >
      In this case, 'autoindent' doesn't effect. Use 'cindent'.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.