Loading ...
Sorry, an error occurred while loading the content.

Cursor position change after operator + text object

Expand Messages
  • Wiktor Ruben
    Is there any way to stop Vim changing cursor position after operator + text object combination? For example: I have a string foo bar with cursor placed at
    Message 1 of 2 , Oct 3, 2013
    • 0 Attachment
      Is there any way to stop Vim changing cursor position after operator +
      text object combination?

      For example: I have a string "foo bar" with cursor placed at the space
      between 'foo' and 'bar'. After 'yi"' cursor is placed at 'f'. What's
      worse neither '``' nor <C-o> moves cursor to previous position.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Then you can jump back with ``. -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
      Message 2 of 2 , Oct 3, 2013
      • 0 Attachment
        On Thursday, October 3, 2013 5:45:10 AM UTC-5, Wiktor Ruben wrote:
        > Is there any way to stop Vim changing cursor position after operator +
        > text object combination?
        >
        > For example: I have a string "foo bar" with cursor placed at the space
        > between 'foo' and 'bar'. After 'yi"' cursor is placed at 'f'. What's
        > worse neither '``' nor <C-o> moves cursor to previous position.

        You could:

        :nnoremap y m'y

        Then you can jump back with ``.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.