Loading ...
Sorry, an error occurred while loading the content.
 

Re: A problem with autofilling with non-english language.

Expand Messages
  • Alex K
    Ok, pasting the text answer. filetype= complete=.,w,b,u,t,i completefunc= completeopt=menu,preview 2013/9/25 Nikolay Pavlov ... -- -- You
    Message 1 of 11 , Sep 25, 2013
      Ok, pasting the text answer.

        filetype=
        complete=.,w,b,u,t,i
        completefunc=
        completeopt=menu,preview



      2013/9/25 Nikolay Pavlov <zyx.vim@...>


      On Sep 25, 2013 3:08 PM, "Alex K" <alexkg.2012@...> wrote:
      >
      > I am sorry. Didn't guess that this stroke is one command. Now the answer is attached:

      It is better to wrap commands with :redir:

          :redir @+
          :verbose setlocal ...
          :redir END

      . This way output will appear in the system clipboard available for pasting, no need to do screenshots.

      >

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Alex K
      Wonderfully I found a solution. This stroke in vimrc makes all right: set iskeyword=@,48-57,_,192-255 Of cource this is for russian language. Maybe be helpfull
      Message 2 of 11 , Oct 5, 2013
        Wonderfully I found a solution.
        This stroke in vimrc makes all right:

        set iskeyword=@,48-57,_,192-255

        Of cource this is for russian language.
        Maybe be helpfull for somebody.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tony Mechelynck
        ... FWIW, this is the nocompatible Vim default except on Dos/Windows. ... Best regards, Tony. -- Life in the state of nature is solitary, poor, nasty,
        Message 3 of 11 , Oct 5, 2013
          On 05/10/13 17:03, Alex K wrote:
          > Wonderfully I found a solution.
          > This stroke in vimrc makes all right:
          >
          > set iskeyword=@,48-57,_,192-255

          FWIW, this is the 'nocompatible' Vim default except on Dos/Windows.

          >
          > Of cource this is for russian language.
          > Maybe be helpfull for somebody.


          Best regards,
          Tony.
          --
          Life in the state of nature is solitary, poor, nasty, brutish, and short.
          -- Thomas Hobbes, Leviathan


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.