Loading ...
Sorry, an error occurred while loading the content.

Re: outlook.vim sets textwidth=76 when starting gvim

Expand Messages
  • Calon
    From line 63 to 68 in outlook.vim, you can find text width option there: textwidth - automatically wrap at a column if exists( g:outlook_textwidth ) let
    Message 1 of 7 , Sep 25, 2013
    • 0 Attachment
      From line 63 to 68 in outlook.vim, you can find text width option there:

      " textwidth  - automatically wrap at a column
      if exists('g:outlook_textwidth')
          let &textwidth = g:outlook_textwidth
      else
          let &textwidth = 76
      endif

      You can set g:outlook_textwidth to override the default setting, as mentioned in help document(outlook.txt).

       This setting (default = 1) overrides the default textwidth the mail ftplugin sets.  This
       allows you to automatically format text using gq by setting the following: >
           let g:outlook_textwidth = 76

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • A Loumiotis
      Thank you. ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more
      Message 2 of 7 , Sep 25, 2013
      • 0 Attachment
        Thank you.


        On Wed, Sep 25, 2013 at 1:16 PM, Calon <calon.xu@...> wrote:
        From line 63 to 68 in outlook.vim, you can find text width option there:

        " textwidth  - automatically wrap at a column
        if exists('g:outlook_textwidth')
            let &textwidth = g:outlook_textwidth
        else
            let &textwidth = 76
        endif

        You can set g:outlook_textwidth to override the default setting, as mentioned in help document(outlook.txt).

         This setting (default = 1) overrides the default textwidth the mail ftplugin sets.  This
         allows you to automatically format text using gq by setting the following: >
             let g:outlook_textwidth = 76

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • David Fishburn
        ... As Calon mentioned, with a new plugin it is best to read the documentation which comes with it. ... It will outline all the different configuration
        Message 3 of 7 , Sep 25, 2013
        • 0 Attachment

          On Wed, Sep 25, 2013 at 5:12 AM, A Loumiotis <antonis.loumiotis@...> wrote:
          Dear all,

          When starting gvim outlook.vim plugin sets textwidth to 76.  How can I remove this setting?

           
          As Calon mentioned,  with a new plugin it is best to read the documentation which comes with it.

          :h outlook.txt

          or in this specific case:
          :h outlook-configuration

          It will outline all the different configuration variables you can customize your use of the OutlookVim plugin.

          David

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • A Loumiotis
          ... I actually had read the documentation and I thought that outlook.vim plugin will only change the textwidth for files ending in .outlook. I realize now
          Message 4 of 7 , Sep 25, 2013
          • 0 Attachment



            On Wed, Sep 25, 2013 at 3:34 PM, David Fishburn <dfishburn.vim@...> wrote:

            On Wed, Sep 25, 2013 at 5:12 AM, A Loumiotis <antonis.loumiotis@...> wrote:
            Dear all,

            When starting gvim outlook.vim plugin sets textwidth to 76.  How can I remove this setting?

             
            As Calon mentioned,  with a new plugin it is best to read the documentation which comes with it.

            :h outlook.txt

            or in this specific case:
            :h outlook-configuration

            It will outline all the different configuration variables you can customize your use of the OutlookVim plugin.

            David


             
            I actually had read the documentation and I thought that outlook.vim plugin will only change the textwidth for files ending in .outlook.  I realize now that it also changes the default textwidth for all files and I will need to use the global variable to override this setting.

            Antonis

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... It looks like this might be a plugin bug: Assuming outlook.vim is meant to be specific to a buffer, this should be &l:textwidth instead of &textwidth, to
            Message 5 of 7 , Sep 25, 2013
            • 0 Attachment
              On Wednesday, September 25, 2013 5:16:07 AM UTC-5, Calon wrote:
              > From line 63 to 68 in outlook.vim, you can find text width option there:
              >
              > " textwidth  - automatically wrap at a column
              > if exists('g:outlook_textwidth')
              >     let &textwidth = g:outlook_textwidth
              >
              >
              > else
              >     let &textwidth = 76
              > endif
              >

              It looks like this might be a plugin bug:

              Assuming outlook.vim is meant to be specific to a buffer, this should be &l:textwidth instead of &textwidth, to set only the buffer-local copy of textwidth.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • David Fishburn
              On Wed, Sep 25, 2013 at 10:46 AM, A Loumiotis ... That is a bug Antonis. Thanks for reporting it, I will fix it and post a new version. David -- -- You
              Message 6 of 7 , Sep 25, 2013
              • 0 Attachment

                On Wed, Sep 25, 2013 at 10:46 AM, A Loumiotis <antonis.loumiotis@...> wrote:
                ... 
                I actually had read the documentation and I thought that outlook.vim plugin will only change the textwidth for files ending in .outlook.  I realize now that it also changes the default textwidth for all files and I will need to use the global variable to override this setting.

                That is a bug Antonis.

                Thanks for reporting it, I will fix it and post a new version.

                David

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.