Loading ...
Sorry, an error occurred while loading the content.

Trouble with alt/meta mappings

Expand Messages
  • Hendrik Jaeger
    Hi, I use vim-latexsuite in an urxvt terminal with neo keyboard layout. The terminal is set to _not_ send an ESC-prefix when meta is pressed, but to set the
    Message 1 of 3 , Sep 24 4:54 AM
    • 0 Attachment
      Hi,

      I use vim-latexsuite in an urxvt terminal with neo keyboard layout.
      The terminal is set to _not_ send an ESC-prefix when meta is pressed,
      but to set the 8th bit.
      vim-latex has a mapping for 'meta-i' to insert the command for a new
      item in a list.

      When I press 'meta-i' followed by two arbitrary other keys, I get é in
      vim now. When I press the keys usually needed to get é, vim does what
      'meta-i' is supposed to do.

      With the terminal set to send an ESC-prefix, behaviour does not change
      much: meta-i moves the cursor to the left and é still inserts a new
      item …


      This is quite annoying, especially in combination with vim-latexsuite
      which relies heavily on mappings using 'meta', and I was unable to get
      it to work properly.
      Am I missing something important?
      Is this a problem in vim? Can it be fixed?

      Thanks and best regards

      henk
    • Tony Mechelynck
      ... Try reading :help map-alt-keys , it might give you some enlightenment for your trial-and-error procedure. Note that Θ (0xE9) is seen by Vim as the same
      Message 2 of 3 , Sep 24 5:37 AM
      • 0 Attachment
        On 24/09/13 13:54, Hendrik Jaeger wrote:
        > Hi,
        >
        > I use vim-latexsuite in an urxvt terminal with neo keyboard layout.
        > The terminal is set to _not_ send an ESC-prefix when meta is pressed,
        > but to set the 8th bit.
        > vim-latex has a mapping for 'meta-i' to insert the command for a new
        > item in a list.
        >
        > When I press 'meta-i' followed by two arbitrary other keys, I get é in
        > vim now. When I press the keys usually needed to get é, vim does what
        > 'meta-i' is supposed to do.
        >
        > With the terminal set to send an ESC-prefix, behaviour does not change
        > much: meta-i moves the cursor to the left and é still inserts a new
        > item …
        >
        >
        > This is quite annoying, especially in combination with vim-latexsuite
        > which relies heavily on mappings using 'meta', and I was unable to get
        > it to work properly.
        > Am I missing something important?
        > Is this a problem in vim? Can it be fixed?
        >
        > Thanks and best regards
        >
        > henk
        >

        Try reading ":help map-alt-keys", it might give you some enlightenment
        for your trial-and-error procedure.

        Note that é (0xE9) is seen by Vim as the same as Alt-i (i.e. 0x80 +
        0x69); so hitting alt-i in Insert mode should insert the é letter (with
        me it does, in gvim for GTK2/Gnome2), and hitting the é key (if you have
        one — I do, on my AZERTY keyboard) should trigger any mapping defined
        for <M-i> for the mode you are in.


        Best regards,
        Tony.
        --
        This screen intentionally left blank.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Hendrik Jäger
        Hi, On Tue, 24 Sep 2013 14:37:20 +0200 ... Thank you for the suggestion. Could you elaborate on what you wanted me to find there? AFAICT I tried everything
        Message 3 of 3 , Sep 25 3:13 AM
        • 0 Attachment
          Hi,

          On Tue, 24 Sep 2013 14:37:20 +0200
          Tony Mechelynck <antoine.mechelynck@...> wrote:

          > Try reading ":help map-alt-keys", it might give you some
          > enlightenment for your trial-and-error procedure.

          Thank you for the suggestion. Could you elaborate on what you wanted me
          to find there? AFAICT I tried everything relevant mentioned there and
          described that I did in my original post. Did I miss anything?

          > Note that é (0xE9) is seen by Vim as the same as Alt-i (i.e. 0x80 +
          > 0x69); so hitting alt-i in Insert mode should insert the é letter
          > (with me it does, in gvim for GTK2/Gnome2), and hitting the é key (if
          > you have one — I do, on my AZERTY keyboard) should trigger any
          > mapping defined for <M-i> for the mode you are in.

          AFAIU gvim behaves a lot different than plain vim in a terminal!
          And I think I described pretty well what happens when I press what in
          my original post.

          Thank you for answering, but I’m not sure how your post was supposed to
          help me. Could you please elaborate?

          Thanks and best regards

          henk
        Your message has been successfully submitted and would be delivered to recipients shortly.