Loading ...
Sorry, an error occurred while loading the content.

Seemingly random text inserted when using vim plugins

Expand Messages
  • Paul King
    Hello I have been a vi user for a long while, but this is the first time I had been using vim plugins. Vim plugins force me to stray from the regular vi key
    Message 1 of 3 , Sep 21, 2013
    • 0 Attachment
      Hello

      I have been a vi user for a long while, but this is the first time I had been using vim plugins. Vim plugins force me to stray from the regular vi key mappings (via :set nocompatible), but right now apart from the fact that the plugins make vim sluggish, these are the least of my worries.

      Since I am new to plugins, the commands used to install the plugins from GIT were:
      > cd ~
      > git clone http://github.com/thenovices/dotfiles
      > ln –s dotfiles/.vim* .
      > git clone https://github.com/gmarik/vundle .vim/bundle/vundle
      > vim +BundleInstall +qall

      The last command ("vim +BundleInstall +qall") had what appeared to be some error messages, but they went by to fast to examine them.

      When plugins are enabled, the worst problem that seems to occur is that it appears as though the last session repeats regardless of the file edited. Vim jumps seemingly randomly around the file I am editing, inserting random numbers, and repeatedly emptying its paste buffer (from earlier sessions) in random places in my new file (which have nothing to do with whatever was in the paste buffer). It is as if it is attempting a recovery process on files which need no such recovery.

      I have tried this across two operating systems, and the plugins fail in both Cygwin and in Linux. I am usually forced to abandon the dotfiles installation by moving the directory to _dotfiles. Then, vim behaves normally, but without the dotfiles "goodies".

      I have more recently found settings.vim to be the culprit, and commenting out these lines have helped, but to a point:

      "set timeoutlen=250 " Time to wait after ESC
      "set timeoutlen=600
      "set ttimeoutlen=50
      "set viminfo='10,\"100,:20,%,n~/.viminfo " Use viminfo
      "set wildmenu
      "set wildmode=list:longest,full " bash-like command line tab completion

      I commented out the first three because I just don't like timeouts. Just give me factory defaults. The last three make me more leery: .viminfo seems to have a list of vim commands when I looked at it, so in my mind it had no business being there. Commented out. I looked at the help for wildmenu. I commented it out because I thought that it too was un-necessary for a vi session. Basically, I still don't know what causes the random text to insert itself, and I don't seem to have completely gotten rid of the problem.

      Random text now mostly appears mostly in the status bar, out of the way of the text of the file, but some random text insertions are still observed once in a while. This is still unacceptable, since the amount of random text insertions was zero before the installation.

      Has anyone ever encountered this before, and what did you do about it?

      Paul

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • glts
      Paul, ... If you allow, a word of advice: don t start with a huge stock of plugins you know nothing about, start from scratch and add plugins on an as-needed
      Message 2 of 3 , Sep 21, 2013
      • 0 Attachment
        Paul,

        On Saturday, September 21, 2013 2:23:05 PM UTC+2, Paul King wrote:
        > I have been a vi user for a long while, but this is the first time I had been using vim plugins. Vim plugins force me to stray from the regular vi key mappings (via :set nocompatible), but right now apart from the fact that the plugins make vim sluggish, these are the least of my worries.
        >
        > Since I am new to plugins, the commands used to install the plugins from GIT were:
        > > cd ~
        > > git clone http://github.com/thenovices/dotfiles
        > > ln –s dotfiles/.vim* .
        > > git clone https://github.com/gmarik/vundle .vim/bundle/vundle
        > > vim +BundleInstall +qall
        >
        > The last command ("vim +BundleInstall +qall") had what appeared to be some error messages, but they went by to fast to examine them.
        >
        > When plugins are enabled, the worst problem that seems to occur is that it appears as though the last session repeats regardless of the file edited. Vim jumps seemingly randomly around the file I am editing, inserting random numbers, and repeatedly emptying its paste buffer (from earlier sessions) in random places in my new file (which have nothing to do with whatever was in the paste buffer). It is as if it is attempting a recovery process on files which need no such recovery.
        >
        > I have tried this across two operating systems, and the plugins fail in both Cygwin and in Linux. I am usually forced to abandon the dotfiles installation by moving the directory to _dotfiles. Then, vim behaves normally, but without the dotfiles "goodies".
        >
        > I have more recently found settings.vim to be the culprit, and commenting out these lines have helped, but to a point:
        >
        > "set timeoutlen=250 " Time to wait after ESC
        > "set timeoutlen=600
        > "set ttimeoutlen=50
        > "set viminfo='10,\"100,:20,%,n~/.viminfo " Use viminfo
        > "set wildmenu
        > "set wildmode=list:longest,full " bash-like command line tab completion
        >
        > I commented out the first three because I just don't like timeouts. Just give me factory defaults. The last three make me more leery: .viminfo seems to have a list of vim commands when I looked at it, so in my mind it had no business being there. Commented out. I looked at the help for wildmenu. I commented it out because I thought that it too was un-necessary for a vi session. Basically, I still don't know what causes the random text to insert itself, and I don't seem to have completely gotten rid of the problem.
        >
        > Random text now mostly appears mostly in the status bar, out of the way of the text of the file, but some random text insertions are still observed once in a while. This is still unacceptable, since the amount of random text insertions was zero before the installation.

        If you allow, a word of advice: don't start with a huge stock of plugins
        you know nothing about, start from scratch and add plugins on an
        as-needed basis. "Using plugins" doesn't have to mean going from zero to
        an unmanageable amount of plugins and arbitrary mappings without any
        sort of quality control.

        When I feel the need to improve a less than optimal state of affairs in
        vanilla Vim, then I go looking for a plugin that specifically addresses
        that deficit. I still use all the standard "vi" keybindings, and I am
        comfortable on a plain, uncustomised Vim, as well as on my own
        moderately configured Vim with about 15 plugins.

        Seeing that you are having trouble with your Vim distro -- and that is
        what you are using, a Vim distro -- then the routine advice given by me
        and others many times before is: get rid of the distro, and start
        building your own personal vimrc, and your own personal store of Vim
        plugins that make sense for your particular personal workflow. It is a
        journey, and a fairly entertaining one if you are willing.

        --

        As for the problem of random text insertion and jumping around: well,
        that is now rather hard to debug since we have an unknown number of
        potential culprits and conflicts. You could try a binary search: get rid
        of half the plugins, see if problem persists, if no, repeat with the
        other half of the plugins, if yes, rinse and repeat ...

        Good luck!

        Best,
        David

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Paul King
        Thanks for the advice, David. It was actually a video from CS50 (Harvard Courseware) that had the list of commands I quoted. They were discussing the use of
        Message 3 of 3 , Sep 21, 2013
        • 0 Attachment
          Thanks for the advice, David. It was actually a video from CS50 (Harvard Courseware) that had the list of commands I quoted. They were discussing the use of vim, and nearly all examples of its use demonstrated in the video were plugin-specific. After cutting and pasting these commands and using them on my systems (one on my account on the MIT Athena system) that it was obvious that the plugins didn't work as advertised. I was posting here, nearly certain someone had already encountered that problem, and you are now saying that no one in their right mind would issue commands in that manner without just installing plugins they want.

          OK, Point taken.

          Paul

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.