Loading ...
Sorry, an error occurred while loading the content.
 

Re: error M:\_viminfo!

Expand Messages
  • Stevew
    Ok after several failed attempts this seems to work. set viminfo+=nc: temp _viminfo When you said flag I thought you meant something like ... vi -n thanks.
    Message 1 of 11 , Sep 20, 2013
      Ok after several failed attempts this seems to work.

      set viminfo+=nc:\\temp\\_viminfo

      When you said flag I thought you meant something like ...
      vi -n

      thanks.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... So...:help viminfo gives an error? What error? I have no idea how somebody on a Windows system managed to get an install with the help documents. Vim s
      Message 2 of 11 , Sep 20, 2013
        On Friday, September 20, 2013 3:08:43 PM UTC-5, Stevew wrote:
        > > Then you read it wrong.
        >
        > Unfortunetely the help file does not seem to be installed.

        So...:help 'viminfo' gives an error? What error?

        I have no idea how somebody on a Windows system managed to get an install with the help documents. Vim's :help system is one of the best things about the editor, I suggest you fix this problem ASAP.

        What does :echo $VIMRUNTIME tell you? Does that directory exist? Is there a "doc" folder there?

        What does :set runtimepath? tell you? Is that $VIMRUNTIME directory there?

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Gooderam
        The copy of Vi Im using has no docs folder etc. To tell you the truth of the matter is that I have been using vi for many years. Im unclear if years ago on
        Message 3 of 11 , Sep 27, 2013
          The copy of Vi Im using has no docs folder etc. To tell you the truth of the matter is that I have been using vi for many years. Im unclear if years ago on Unix when I started using it, if there was much of a sofisticated help as you have described. Certainly you could not get it via f keys accept if you did some magic which I dont know. So really I have plugged along without all the nice features, which probably are helpfull.

          The reason I like vi is because I can put that one program on a floppy disk, usb stick or anywhere and then I cant edit files with some attitute.
          Im unclear if I installaed this vi from a proper windows install or just copyed it from one computer to another, because I just like it.

          I suppose I should look into it to get the most out of it.

          I do have a question though. Vi has worked well for me on this computer for many years. (windows 7) But now when I press ESC to exit from the text mode. It does not work. I have discovered that F1 sort of works. But it gives me an error as well, E433: No tags file and E149: Sorry, no help for help.txt and Press Enter or type command to continue. Then I am it the right mode like I press ed ESC. I dont know why this has changed. I dont recall changing anything.

          Is there any way to get back my ESC.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Ben Fritz
          ... What DOES happen when you hit ESC in insert mode? ESC is an extremely basic feature and it should always work. Unless, of course: 1. You have an
          Message 4 of 11 , Sep 27, 2013
            On Friday, September 27, 2013 9:43:18 AM UTC-5, Gooderam wrote:
            >
            > I do have a question though. Vi has worked well for me on this computer for many years. (windows 7) But now when I press ESC to exit from the text mode. It does not work. I have discovered that F1 sort of works. But it gives me an error as well, E433: No tags file and E149: Sorry, no help for help.txt and Press Enter or type command to continue. Then I am it the right mode like I press ed ESC. I dont know why this has changed. I dont recall changing anything.
            >
            > Is there any way to get back my ESC.

            What DOES happen when you hit ESC in insert mode? ESC is an extremely basic feature and it should always work.

            Unless, of course:
            1. You have an insert-mode mapping for <ESC>
            2. You have the option 'insertmode' set
            3. You are using Vim in "easy mode" (i.e. your Vim is named "evim", or you launch it as "vim -y" or "gvim -y")

            Are any of these true?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Stevew
            Ok well you caused me to think about things a bit and I think I resolved it. Here is what I did. There is one file that I opwn every day and use all the time.
            Message 5 of 11 , Sep 27, 2013
              Ok well you caused me to think about things a bit and I think I resolved it.
              Here is what I did.
              There is one file that I opwn every day and use all the time. This is the file that had the problem. It is an encrypted file -X.
              I decided to open it and then do a :w out.txt
              then exit and then open the out.txt with a -X Now the problem went away. Maybe this file had some characters in it that caused the problems.

              Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix. Its been that way for some time. Well I guess I was wrong It's suppose to be
              " Programing type comment.
              Correct me if Im wrong?
              I discovered this because even with me rewriting the file out, while fixed, now when it was opening it was showing odd things at the bottom in the information :command line.

              I think that has fixed it. Ive used this program for so long, many of these things are new to me when I went to windows. In fact at some point when I did install the vim.exe on windows (as I recall somewhere) I was at the time thinking to myself (angrily) cant they just leave it alone and just provde simple VI.exe
              Let see if everything works now. Or if you have seen some error in my ways.
              thanks.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Charles Campbell
              Stevew wrote: Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix.
              Message 6 of 11 , Sep 27, 2013
                Stevew wrote:

                Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix. Its been that way for some time. Well I guess I was wrong It's suppose to be
                " Programing type comment.
                Correct me if Im wrong?
                I discovered this because even with me rewriting the file out, while fixed, now when it was opening it was showing odd things at the bottom in the information :command line.

                VIm's comments similarly in the sense that a single character starts a
                comment, but uses a leading double-quote (") instead of a hash mark (#).

                Regards,
                C Campbell

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.