Loading ...
Sorry, an error occurred while loading the content.

Windows vim shelling out waits forever

Expand Messages
  • Paul Ericson
    I m currently unable to complete a shell out from the 64-bit Windows version of gvim. Doesn t matter how I launch vim. Also doesn t matter which shell I use.
    Message 1 of 3 , Sep 20, 2013
    • 0 Attachment
      I'm currently unable to complete a shell out from the 64-bit Windows version of gvim. Doesn't matter how I launch vim. Also doesn't matter which shell I use. Tried cmd.exe and cygwin's bash.exe. Behavior is identical:

      Opens a command window as "C:\Program Files\vim\vim72\wimrun.exe"
      Shows something like this:
      c:\cygwin\bin\bash.exe --rcfile c:/cygwin/home/paule/.bashex -i -c "sort"
      Then just waits forever.

      Any idea what's going on or even how to troubleshoot this?

      Thanks,

      Paul

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... There are lots of ways to invoke the shell from Vim. What SPECIFIC Vim command did you use? -- -- You received this message from the vim_use maillist. Do
      Message 2 of 3 , Sep 20, 2013
      • 0 Attachment
        On Friday, September 20, 2013 12:33:26 PM UTC-5, Paul Ericson wrote:
        > I'm currently unable to complete a shell out from the 64-bit Windows version of gvim. Doesn't matter how I launch vim. Also doesn't matter which shell I use. Tried cmd.exe and cygwin's bash.exe. Behavior is identical:
        >
        > Opens a command window as "C:\Program Files\vim\vim72\wimrun.exe"
        > Shows something like this:
        > c:\cygwin\bin\bash.exe --rcfile c:/cygwin/home/paule/.bashex -i -c "sort"
        > Then just waits forever.
        >
        > Any idea what's going on or even how to troubleshoot this?
        >
        > Thanks,
        >
        > Paul

        There are lots of ways to invoke the shell from Vim. What SPECIFIC Vim command did you use?

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... And, what are the values of the options that affect shelling out ; including set shell : name of shell to use for ! and :! commands set shq :
        Message 3 of 3 , Sep 20, 2013
        • 0 Attachment
          Ben Fritz wrote:
          > On Friday, September 20, 2013 12:33:26 PM UTC-5, Paul Ericson wrote:
          >> I'm currently unable to complete a shell out from the 64-bit Windows version of gvim. Doesn't matter how I launch vim. Also doesn't matter which shell I use. Tried cmd.exe and cygwin's bash.exe. Behavior is identical:
          >>
          >> Opens a command window as "C:\Program Files\vim\vim72\wimrun.exe"
          >> Shows something like this:
          >> c:\cygwin\bin\bash.exe --rcfile c:/cygwin/home/paule/.bashex -i -c "sort"
          >> Then just waits forever.
          >>
          >> Any idea what's going on or even how to troubleshoot this?
          >>
          >> Thanks,
          >>
          >> Paul
          > There are lots of ways to invoke the shell from Vim. What SPECIFIC Vim command did you use?
          >
          And, what are the values of the options that affect "shelling out";
          including

          " set shell : name of shell to use for ! and :! commands
          " set shq : shellquote -- how to quote characters about the cmd
          passed to shell
          " set sxq : shellxquote -- includes redirection (shellquote excludes
          that)
          " set ssl : shellslash -- when set, forward slash used to expand
          file names
          " set shcf : shellcmdflag -- flag passed to shell to execute ! and :!
          commands
          " set sp : shellpipe -- string used to put output of :make into
          errorfile
          " set srr : shellredir -- string used to put output of filter cmd
          into temporary file

          Regards,
          C Campbell

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.