Loading ...
Sorry, an error occurred while loading the content.
 

possible bug with surround.vim?

Expand Messages
  • Matteo Cavalleri
    i ve found a strange bug with surround, but i don t know what s the best way to debug it (to be sure it s actually a bug in this plugin and not coming from
    Message 1 of 4 , Sep 17, 2013
      i've found a strange bug with surround, but i don't know what's the best way to debug it (to be sure it's actually a bug in this plugin and not coming from something else). running "vim -u NONE" will not load any plugin, and i don't know how to load it afterward. anyway: here's some more info:

      i'm running the lastest vim 7.4 (full output later), with pathogen, surround.vim and some other plugins. here's a couple of steps to reproduce the problem:

      1) run vim
      2) insert the following line in the buffer

      get "index/index"

      3) move the cursor at the beginning of line

      4) run the command cs"'

      the output is:

      'get '

      if you undo and then move the cursor on the first " (or inside the string) the command works properly.

      i've tried "set regexpengine=1", "set regexpengine=2" and "set regexpengine=0" but the problem still happens in all the three cases

      thanks in advance



      VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Sep 16 2013 09:26:22)
      Included patches: 1-27
      Compiled by xxxxxxxxx
      Big version without GUI. Features included (+) or not (-):
      +acl +farsi +mouse_netterm +syntax
      +arabic +file_in_path +mouse_sgr +tag_binary
      +autocmd +find_in_path -mouse_sysmouse +tag_old_static
      -balloon_eval +float +mouse_urxvt -tag_any_white
      -browse +folding +mouse_xterm -tcl
      ++builtin_terms -footer +multi_byte +terminfo
      +byte_offset +fork() +multi_lang +termresponse
      +cindent +gettext -mzscheme +textobjects
      +clientserver -hangul_input -netbeans_intg +title
      +clipboard +iconv +path_extra -toolbar
      +cmdline_compl +insert_expand -perl +user_commands
      +cmdline_hist +jumplist +persistent_undo +vertsplit
      +cmdline_info +keymap +postscript +virtualedit
      +comments +langmap +printer +visual
      +conceal +libcall -profile +visualextra
      +cryptv +linebreak +python +viminfo
      +cscope +lispindent -python3 +vreplace
      +cursorbind +listcmds +quickfix +wildignore
      +cursorshape +localmap +reltime +wildmenu
      +dialog_con -lua +rightleft +windows
      +diff +menu -ruby +writebackup
      +digraphs +mksession +scrollbind +X11
      -dnd +modify_fname +signs +xfontset
      -ebcdic +mouse +smartindent -xim
      +emacs_tags -mouseshape -sniff +xsmp_interact
      +eval +mouse_dec +startuptime +xterm_clipboard
      +ex_extra -mouse_gpm +statusline -xterm_save
      +extra_search -mouse_jsbterm -sun_workshop -xpm
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      2nd user vimrc file: "~/.vim/vimrc"
      user exrc file: "$HOME/.exrc"
      fall-back for $VIM: "/usr/local/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -O2 -fno-strength-reduce -Wall -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1
      Linking: gcc -L/usr/local/lib -Wl,--as-needed -o vim -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm -ltinfo -ldl -L/usr/lib/python2.7/config-x86_64-linux-gnu -lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynamic -Wl,-O1 -Wl,-Bsymbolic-functions

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Marco
      ... source path/to/plugin/surround.vim ... Get rid of the other plugins for testing. ... Confirmed. It does not happen with older versions. It seems to be a
      Message 2 of 4 , Sep 17, 2013
        On 2013–09–17 Matteo Cavalleri wrote:

        > to be sure it's actually a bug in this plugin and not coming from
        > something else). running "vim -u NONE" will not load any plugin,
        > and i don't know how to load it afterward.

        source path/to/plugin/surround.vim

        > i'm running the lastest vim 7.4 (full output later), with
        > pathogen, surround.vim and some other plugins.

        Get rid of the other plugins for testing.

        > 1) run vim
        > 2) insert the following line in the buffer
        >
        > get "index/index"
        >
        > 3) move the cursor at the beginning of line
        >
        > 4) run the command cs"'
        >
        > the output is:
        >
        > 'get '

        Confirmed. It does not happen with older versions. It seems to be a
        bug in surround.vim

        Marco
      • Matteo Cavalleri
        ... thanks for the help, i ll contact the author as soon as i have a bit more time to write an email (i don t know if he follows this forum). -- -- You
        Message 3 of 4 , Sep 17, 2013
          > Confirmed. It does not happen with older versions. It seems to be a
          >
          > bug in surround.vim

          thanks for the help, i'll contact the author as soon as i have a bit more time to write an email (i don't know if he follows this forum).

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... You can report the issue here: http://gh.codehum.com/tpope/vim-surround/issues regards, Christian -- -- You received this message from the vim_use
          Message 4 of 4 , Sep 17, 2013
            On Tue, September 17, 2013 17:44, Matteo Cavalleri wrote:
            >> Confirmed. It does not happen with older versions. It seems to be a
            >>
            >> bug in surround.vim
            >
            > thanks for the help, i'll contact the author as soon as i have a bit more
            > time to write an email (i don't know if he follows this forum).

            You can report the issue here:
            http://gh.codehum.com/tpope/vim-surround/issues

            regards,
            Christian

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.