Loading ...
Sorry, an error occurred while loading the content.

Re: netrw absolute and relative path handling

Expand Messages
  • Charles Campbell
    ... Thank you for reporting this. I believe its fixed in netrw v150h, which you can get from my website: http://www.drchip.org/astronaut/vim/index.html#NETRW
    Message 1 of 3 , Sep 12, 2013
    • 0 Attachment
      selyana baldo wrote:
      > Hi,
      >
      > I'm currently using vim 7.4.5 in linux (Mint 15 olivia) and I noticed a strange behaviour concerning netrw.
      >
      > if I do:
      > cd /some/directory
      > vim .
      >
      > => it's working (vi runs the netrw plugin and displays the "/some/directory" directory content) even though I have a warning message complaining about "." being a directory
      >
      > if I do:
      > vim /some/directory
      >
      > => I only get a blank screen (vi opens a new and empty buffer) and I get a "/some/directory" is a directory warning. the behaviour is the same with vim /some/directory/ (except that I get an "invalid file name" warning)
      >
      > moreover, if I run vi and then do a ":e /some/directory" it's working.
      >
      > I tried the same with vim 7.3 (same netrw version) : it's working wether the path for the directory is relative or absolute.
      >
      > my .vimrc only contains "set nocp"
      >
      > so it seems opening a directory with its absolute path doesn't work (at least on my computer). I tried to run vim with the -V option but found no significant difference between the "vim -V ." and the "vim -V /some/directory"
      >
      > any ideas ? am I the only one with this strange netrw or vim 7.4 behaviour ?
      >
      Thank you for reporting this. I believe its fixed in netrw v150h,
      which you can get from my website:
      http://www.drchip.org/astronaut/vim/index.html#NETRW

      Regards,
      Chip Campbell

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • selyana baldo
      ... Thanks a lot, it worked like a charm :) -- Selyana -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
      Message 2 of 3 , Sep 17, 2013
      • 0 Attachment
        > Thank you for reporting this. I believe its fixed in netrw v150h,

        Thanks a lot, it worked like a charm :)
        --
        Selyana

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.