Loading ...
Sorry, an error occurred while loading the content.

Which version of Ruby should I use with Vim 7.4?

Expand Messages
  • Oskar Kvist
    Hi! I m having trouble getting Ruby to work (need it for the LustyJuggler plugin) with Vim 7.4. If I look in the gvim.exe file, it references
    Message 1 of 5 , Sep 10, 2013
    • 0 Attachment
      Hi!

      I'm having trouble getting Ruby to work (need it for the LustyJuggler plugin) with Vim 7.4. If I look in the gvim.exe file, it references "msvcrt-ruby192.dll", but even the latest ruby 1.9.3 has msvcrt-ruby191.dll in it. I tried renaming that to msvcrt-ruby192.dll but it didn't work (results in a "LoadError: Incompatible library version"), not renaming the dll does not work either, has('ruby') == 0 then.

      I'm searched for answers to this question, but to my surprise I could not find anything.

      I'm on Windows by the way, maybe that has something to do with it.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... Vim without Cream has, alas, not yet got beyond 7.3.829; it hasn t changed since 20 February. If you want to use it anyway, you need Ruby 1.9.1. I m
      Message 2 of 5 , Sep 10, 2013
      • 0 Attachment
        On 11/09/13 00:14, Oskar Kvist wrote:
        > Hi!
        >
        > I'm having trouble getting Ruby to work (need it for the LustyJuggler plugin) with Vim 7.4. If I look in the gvim.exe file, it references "msvcrt-ruby192.dll", but even the latest ruby 1.9.3 has msvcrt-ruby191.dll in it. I tried renaming that to msvcrt-ruby192.dll but it didn't work (results in a "LoadError: Incompatible library version"), not renaming the dll does not work either, has('ruby') == 0 then.
        >
        > I'm searched for answers to this question, but to my surprise I could not find anything.
        >
        > I'm on Windows by the way, maybe that has something to do with it.
        >

        "Vim without Cream" has, alas, not yet got beyond 7.3.829; it hasn't
        changed since 20 February. If you want to use it anyway, you need Ruby
        1.9.1.

        I'm surprised that your Ruby 1.9.3 has a ruby191.dll with it. If your
        gvim version needs a msvcrt-ruby192.dll, I would expect it to have been
        compiled for Ruby 1.9.2. You can check that by starting it and checking
        the bottom half of the output of the :version command: you'll probably
        see there a number of Ruby-related compiler and linker defines.

        If you compile Vim yourself (on any OS), you can compile it for (almost)
        any Ruby version, but you need to make sure that there is no mismatch
        between your Ruby version and what Vim expects. On Linux this would be
        simply a matter of having the right "development" packages installed
        (and configure would mostly do the right thing), but on Windows you have
        to tell the make program which Ruby version you have installed; how to
        do that may vary according to which compiler (and makefile) you are
        using. Check the text of your src/make_{something}.mak (where
        {something} varies according to your compiler): you ought to be able to
        find there which make command-line switch (or environment variable) you
        need to set, and to what, as a function of your installed Ruby package.
        Usually there is a default value, which may or may not be the version
        installed on your system.


        Best regards,
        Tony.
        --
        "Gentlemen of the jury," said the defense attorney, now beginning
        to warm to his summation, "the real question here before you is, shall this
        beautiful young woman be forced to languish away her loveliest years in a
        dark prison cell? Or shall she be set free to return to her cozy little
        apartment at 4134 Mountain Ave. -- there to spend her lonely, loveless hours
        in her boudoir, lying beside her little Princess phone, 962-7873?"

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Oskar Kvist
        I read about the issue here http://hynek.me/articles/vim-7-3-on-win32/ and downloaded a version that was compiled for Ruby 2 from http://wyw.dcweb.cn/. Works
        Message 3 of 5 , Sep 11, 2013
        • 0 Attachment
          I read about the issue here http://hynek.me/articles/vim-7-3-on-win32/ and downloaded a version that was compiled for Ruby 2 from http://wyw.dcweb.cn/. Works great.

          However, this should probably be reported as an issue. I read that bugs should be reported on vim_dev but I don't know if this qualifies. I read somewhere that if one is not sure that it's a bug, use vim_use instead.

          On Wednesday, September 11, 2013 2:21:20 AM UTC+2, Tony Mechelynck wrote:
          > On 11/09/13 00:14, Oskar Kvist wrote:
          >
          > > Hi!
          >
          > >
          >
          > > I'm having trouble getting Ruby to work (need it for the LustyJuggler plugin) with Vim 7.4. If I look in the gvim.exe file, it references "msvcrt-ruby192.dll", but even the latest ruby 1.9.3 has msvcrt-ruby191.dll in it. I tried renaming that to msvcrt-ruby192.dll but it didn't work (results in a "LoadError: Incompatible library version"), not renaming the dll does not work either, has('ruby') == 0 then.
          >
          > >
          >
          > > I'm searched for answers to this question, but to my surprise I could not find anything.
          >
          > >
          >
          > > I'm on Windows by the way, maybe that has something to do with it.
          >
          > >
          >
          >
          >
          > "Vim without Cream" has, alas, not yet got beyond 7.3.829; it hasn't
          >
          > changed since 20 February. If you want to use it anyway, you need Ruby
          >
          > 1.9.1.
          >
          >
          >
          > I'm surprised that your Ruby 1.9.3 has a ruby191.dll with it. If your
          >
          > gvim version needs a msvcrt-ruby192.dll, I would expect it to have been
          >
          > compiled for Ruby 1.9.2. You can check that by starting it and checking
          >
          > the bottom half of the output of the :version command: you'll probably
          >
          > see there a number of Ruby-related compiler and linker defines.
          >
          >
          >
          > If you compile Vim yourself (on any OS), you can compile it for (almost)
          >
          > any Ruby version, but you need to make sure that there is no mismatch
          >
          > between your Ruby version and what Vim expects. On Linux this would be
          >
          > simply a matter of having the right "development" packages installed
          >
          > (and configure would mostly do the right thing), but on Windows you have
          >
          > to tell the make program which Ruby version you have installed; how to
          >
          > do that may vary according to which compiler (and makefile) you are
          >
          > using. Check the text of your src/make_{something}.mak (where
          >
          > {something} varies according to your compiler): you ought to be able to
          >
          > find there which make command-line switch (or environment variable) you
          >
          > need to set, and to what, as a function of your installed Ruby package.
          >
          > Usually there is a default value, which may or may not be the version
          >
          > installed on your system.
          >
          >
          >
          >
          >
          > Best regards,
          >
          > Tony.
          >
          > --
          >
          > "Gentlemen of the jury," said the defense attorney, now beginning
          >
          > to warm to his summation, "the real question here before you is, shall this
          >
          > beautiful young woman be forced to languish away her loveliest years in a
          >
          > dark prison cell? Or shall she be set free to return to her cozy little
          >
          > apartment at 4134 Mountain Ave. -- there to spend her lonely, loveless hours
          >
          > in her boudoir, lying beside her little Princess phone, 962-7873?"

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tony Mechelynck
          ... It might be a bug, or it might be a bug but not in Vim, orà I d say though, that most people seriously interested in the technical stuff talked about
          Message 4 of 5 , Sep 11, 2013
          • 0 Attachment
            On 11/09/13 22:25, Oskar Kvist wrote:
            > I read about the issue here http://hynek.me/articles/vim-7-3-on-win32/ and downloaded a version that was compiled for Ruby 2 from http://wyw.dcweb.cn/. Works great.
            >
            > However, this should probably be reported as an issue. I read that bugs should be reported on vim_dev but I don't know if this qualifies. I read somewhere that if one is not sure that it's a bug, use vim_use instead.

            It might be a bug, or it might be a bug but not in Vim, or…

            I'd say though, that most people "seriously" interested in the
            "technical" stuff talked about on vim_dev, are also subscribed to
            vim_use. (The converse is of course not true).

            Happy to know you got your problem fixed. Someone interested in
            compiling Vim on Windows with Ruby for the largest audience possible
            might take an interest in this; and even if they don't answer (or not
            immediately), it doesn't mean they didn't take notice.


            Best regards,
            Tony.
            --
            hundred-and-one symptoms of being an internet addict:
            18. Your wife drapes a blond wig over your monitor to remind you of what she
            looks like.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ken Takata
            Hi Tony, ... It s not strange because the dll name is based on the API version, and Ruby 1.9.3 s API version is 1.9.1. Maybe src bigvim.bat is wrong.
            Message 5 of 5 , Sep 12, 2013
            • 0 Attachment
              Hi Tony,

              2013/09/11 Wed 9:21:20 UTC+9 Tony Mechelynck wrote:
              > I'm surprised that your Ruby 1.9.3 has a ruby191.dll with it. If your
              > gvim version needs a msvcrt-ruby192.dll, I would expect it to have been
              > compiled for Ruby 1.9.2.

              It's not strange because the dll name is based on the API version,
              and Ruby 1.9.3's API version is 1.9.1.

              Maybe src\bigvim.bat is wrong. RUBY_VER_LONG should be 1.9.1, not 1.9.2.
              Additionaly, Ruby 1.9.2 is not maintained any more and it may have security
              issues. If Ruby 1.9.x is needed, 1.9.3 should be used.

              --- a/src/bigvim.bat
              +++ b/src/bigvim.bat
              @@ -1,5 +1,5 @@
              :: command to build big Vim with OLE, Perl, Python, Ruby and Tcl
              SET VCDIR="C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\"
              SET TOOLDIR=E:\
              -%VCDIR%nmake -f Make_mvc.mak GUI=yes OLE=yes PERL=E:\perl514 DYNAMIC_PERL=yes PERL_VER=514 PYTHON=%TOOLDIR%python27 DYNAMIC_PYTHON=yes PYTHON_VER=27 PYTHON3=%TOOLDIR%python32 DYNAMIC_PYTHON3=yes PYTHON3_VER=32 RUBY=%TOOLDIR%ruby192 DYNAMIC_RUBY=yes RUBY_VER=19 RUBY_VER_LONG=1.9.2 TCL=%TOOLDIR%tcl TCL_VER=85 TCL_VER_LONG=8.5 DYNAMIC_TCL=yes %1 IME=yes CSCOPE=yes
              +%VCDIR%nmake -f Make_mvc.mak GUI=yes OLE=yes PERL=E:\perl514 DYNAMIC_PERL=yes PERL_VER=514 PYTHON=%TOOLDIR%python27 DYNAMIC_PYTHON=yes PYTHON_VER=27 PYTHON3=%TOOLDIR%python32 DYNAMIC_PYTHON3=yes PYTHON3_VER=32 RUBY=%TOOLDIR%ruby193 DYNAMIC_RUBY=yes RUBY_VER=19 RUBY_VER_LONG=1.9.1 TCL=%TOOLDIR%tcl TCL_VER=85 TCL_VER_LONG=8.5 DYNAMIC_TCL=yes %1 IME=yes CSCOPE=yes


              Regards,
              Ken Takata

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.