Loading ...
Sorry, an error occurred while loading the content.

A problem with autofilling with non-english language.

Expand Messages
  • Alex K
    Hello. When I am using autofilling (CTRL+n) in english it works perfect, but in russian, it makes strange choises. I suppose, that it is well known question,
    Message 1 of 11 , Sep 9, 2013
    • 0 Attachment
      Hello.
      When I am using autofilling (CTRL+n) in english it works perfect, but in russian, it makes strange choises.
      I suppose, that it is well known question, but couldnt find an answer.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... Do you have some examples at hand? Best regards, Tony. -- hundred-and-one symptoms of being an internet addict: 16. You step out of your room and realize
      Message 2 of 11 , Sep 9, 2013
      • 0 Attachment
        On 09/09/13 11:57, Alex K wrote:
        > Hello.
        > When I am using autofilling (CTRL+n) in english it works perfect, but in russian, it makes strange choises.
        > I suppose, that it is well known question, but couldnt find an answer.
        >
        Do you have some examples at hand?

        Best regards,
        Tony.
        --
        hundred-and-one symptoms of being an internet addict:
        16. You step out of your room and realize that your parents have moved
        and you
        don't have a clue when it happened.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Alex K
        Do you have some examples at hand? ... Looks like this. (attaching screen) Al variants on the screen are not exist in whole texts -- -- You received this
        Message 3 of 11 , Sep 12, 2013
        • 0 Attachment
          Do you have some examples at hand?

          Best regards,
          Tony.
          Looks like this. (attaching screen) Al variants on the screen are not exist in whole texts

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tony Mechelynck
          ... Hm, if the completions are correctly aligned they are weird indeed. ( ∩┬╥─╟ , really?) What do you get in answer to ... in the file where you get
          Message 4 of 11 , Sep 22, 2013
          • 0 Attachment
            On 12/09/13 11:01, Alex K wrote:
            > Do you have some examples at hand?
            >
            >
            > Best regards,
            > Tony.
            >
            > Looks like this. (attaching screen) Al variants on the screen are not
            > exist in whole texts
            >
            > --
            > --
            > You received this message from the "vim_use" maillist.
            > Do not top-post! Type your reply below the text you are replying to.
            > For more information, visit http://www.vim.org/maillist.php
            >
            > ---
            > You received this message because you are subscribed to the Google
            > Groups "vim_use" group.
            > To unsubscribe from this group and stop receiving emails from it, send
            > an email to vim_use+unsubscribe@....
            > For more options, visit https://groups.google.com/groups/opt_out.

            Hm, if the completions are correctly aligned they are weird indeed.
            ('Обрдг', really?) What do you get in answer to

            :verbose setlocal ft? complete? completefunc? completeopt?

            in the file where you get those "strange" Russian completions?


            Best regards,
            Tony.
            --
            Does the name Pavlov ring a bell?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Alex K
            ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more information,
            Message 5 of 11 , Sep 24, 2013
            • 0 Attachment
              Hm, if the completions are correctly aligned they are weird indeed. ('Обрдг', really?) What do you get in answer to

                      :verbose setlocal ft? complete? completefunc? completeopt?

              in the file where you get those "strange" Russian completions?


              Best regards,
              Tony.
              --
              Does the name Pavlov ring a bell?

              Tried all 4 variants, but they all work the same way and also strange.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Ben Fritz
              ... That was a request for information, not a suggested fix. If you run that command, nothing will happen to affect behavior, but Vim will tell you the current
              Message 6 of 11 , Sep 24, 2013
              • 0 Attachment
                On Tuesday, September 24, 2013 1:14:56 PM UTC-5, Alex K wrote:
                > Hm, if the completions are correctly aligned they are weird indeed. ('Обрдг', really?) What do you get in answer to
                >
                >
                >
                >         :verbose setlocal ft? complete? completefunc? completeopt?
                >
                >
                >
                > in the file where you get those "strange" Russian completions?
                >
                >
                >
                > Tried all 4 variants, but they all work the same way and also strange.

                That was a request for information, not a suggested fix. If you run that command, nothing will happen to affect behavior, but Vim will tell you the current value of those options, and where that value was set.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Alex K
                I am sorry. Didn t guess that this stroke is one command. Now the answer is ... -- -- You received this message from the vim_use maillist. Do not top-post!
                Message 7 of 11 , Sep 25, 2013
                • 0 Attachment
                  I am sorry. Didn't guess that this stroke is one command. Now the answer is attached:



                  > Hm, if the completions are correctly aligned they are weird indeed. ('Обрдг', really?) What do you get in answer to
                  >
                  >
                  >
                  >         :verbose setlocal ft? complete? completefunc? completeopt?
                  >
                  >
                  >
                  > in the file where you get those "strange" Russian completions?
                  >
                  >
                  >
                  > Tried all 4 variants, but they all work the same way and also strange.

                  That was a request for information, not a suggested fix. If you run that command, nothing will happen to affect behavior, but Vim will tell you the current value of those options, and where that value was set.


                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Nikolay Pavlov
                  ... is attached: ... . This way output will appear in the system clipboard available for pasting, no need to do screenshots. ... ( ∩┬╥─╟ , really?)
                  Message 8 of 11 , Sep 25, 2013
                  • 0 Attachment


                    On Sep 25, 2013 3:08 PM, "Alex K" <alexkg.2012@...> wrote:
                    >
                    > I am sorry. Didn't guess that this stroke is one command. Now the answer is attached:

                    It is better to wrap commands with :redir:

                        :redir @+
                        :verbose setlocal ...
                        :redir END

                    . This way output will appear in the system clipboard available for pasting, no need to do screenshots.

                    >
                    >> > Hm, if the completions are correctly aligned they are weird indeed. ('Обрдг', really?) What do you get in answer to
                    >> >
                    >> >
                    >> >
                    >> >         :verbose setlocal ft? complete? completefunc? completeopt?
                    >> >
                    >> >
                    >> >
                    >> > in the file where you get those "strange" Russian completions?
                    >> >
                    >> >
                    >> >
                    >> > Tried all 4 variants, but they all work the same way and also strange.
                    >>
                    >> That was a request for information, not a suggested fix. If you run that command, nothing will happen to affect behavior, but Vim will tell you the current value of those options, and where that value was set.
                    >
                    >
                    >
                    > --
                    > --
                    > You received this message from the "vim_use" maillist.
                    > Do not top-post! Type your reply below the text you are replying to.
                    > For more information, visit http://www.vim.org/maillist.php
                    >  
                    > ---
                    > You received this message because you are subscribed to the Google Groups "vim_use" group.
                    > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    > For more options, visit https://groups.google.com/groups/opt_out.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                     
                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Alex K
                    Ok, pasting the text answer. filetype= complete=.,w,b,u,t,i completefunc= completeopt=menu,preview 2013/9/25 Nikolay Pavlov ... -- -- You
                    Message 9 of 11 , Sep 25, 2013
                    • 0 Attachment
                      Ok, pasting the text answer.

                        filetype=
                        complete=.,w,b,u,t,i
                        completefunc=
                        completeopt=menu,preview



                      2013/9/25 Nikolay Pavlov <zyx.vim@...>


                      On Sep 25, 2013 3:08 PM, "Alex K" <alexkg.2012@...> wrote:
                      >
                      > I am sorry. Didn't guess that this stroke is one command. Now the answer is attached:

                      It is better to wrap commands with :redir:

                          :redir @+
                          :verbose setlocal ...
                          :redir END

                      . This way output will appear in the system clipboard available for pasting, no need to do screenshots.

                      >

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                       
                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Alex K
                      Wonderfully I found a solution. This stroke in vimrc makes all right: set iskeyword=@,48-57,_,192-255 Of cource this is for russian language. Maybe be helpfull
                      Message 10 of 11 , Oct 5, 2013
                      • 0 Attachment
                        Wonderfully I found a solution.
                        This stroke in vimrc makes all right:

                        set iskeyword=@,48-57,_,192-255

                        Of cource this is for russian language.
                        Maybe be helpfull for somebody.

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                         
                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Tony Mechelynck
                        ... FWIW, this is the nocompatible Vim default except on Dos/Windows. ... Best regards, Tony. -- Life in the state of nature is solitary, poor, nasty,
                        Message 11 of 11 , Oct 5, 2013
                        • 0 Attachment
                          On 05/10/13 17:03, Alex K wrote:
                          > Wonderfully I found a solution.
                          > This stroke in vimrc makes all right:
                          >
                          > set iskeyword=@,48-57,_,192-255

                          FWIW, this is the 'nocompatible' Vim default except on Dos/Windows.

                          >
                          > Of cource this is for russian language.
                          > Maybe be helpfull for somebody.


                          Best regards,
                          Tony.
                          --
                          Life in the state of nature is solitary, poor, nasty, brutish, and short.
                          -- Thomas Hobbes, Leviathan


                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        Your message has been successfully submitted and would be delivered to recipients shortly.