Loading ...
Sorry, an error occurred while loading the content.

Re: Display of Emoticons and characters from Indic scripts in GVim

Expand Messages
  • Ben Fritz
    ... No, my setup doesn t work any better, actually. I have no knowledge of anything but U.S. English and the little bit of Latin and Japanese I remember from
    Message 1 of 7 , Sep 8, 2013
    • 0 Attachment
      On Sunday, September 8, 2013 3:50:41 AM UTC-5, glts wrote:
      > On Saturday, September 7, 2013 11:26:39 PM UTC+2, Ben Fritz wrote:
      > > On Saturday, September 7, 2013 10:52:59 AM UTC-5, Sibin wrote:
      > > >
      > > > > On Sat, Sep 7, 2013 at 8:29 PM, Arnab Bhattacharya <arnabbha...@...> wrote:
      > > > >
      > > > >
      > > > > No, as of now, Indic scripts are not supported well by vim.
      > > > >
      > > > > Arnab
      > > > >
      > >
      > > Not supported WELL. Because IIUC they reshape and such depending on what surrounds them. But If a font has a glyph for it, Vim should be able to display SOMETHING besides a "no character" block. That little rectangle displayed is not Vim's fault, it's the way the font tells you it has no such character.
      >
      > That's a tad too apologetic for my taste. I have never been able to work
      > with Indic scripts in Vim. You might get a base character to be
      > displayed correctly, but things get mangled quickly once you add the
      > diacritic vowels and ligatures to the mix. What's worse, the cursor
      > tends to jump around unpredictably when editing Indic text.
      >
      > But maybe your setup works better.

      No, my setup doesn't work any better, actually. I have no knowledge of anything but U.S. English and the little bit of Latin and Japanese I remember from high school and college respectively. But the OP says he sees nothing but empty boxes, i.e. the "no character" glyph. I'm pointing out that THAT particular problem is because the font being used simply does not have a representation for those characters. THAT part of the problem is not Vim's fault.

      I gather that even if the OP finds a good Indic font (sorry if that is misusing the term), Vim won't present it very well. But at the very least the blank "no character" boxes should go away.

      Vim shouldn't have trouble displaying the emoticons anyway, if you can find a monospace font for them. They might be a little difficult to make out, if your font size is too small, but they should be displayed at least.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.