Loading ...
Sorry, an error occurred while loading the content.

Re: Unix vim running dos files

Expand Messages
  • Linda W
    ... Seems like it would be more user friendly if it could autodetect the line endings like it does on source files. -- -- You received this message from the
    Message 1 of 3 , Sep 5, 2013
    • 0 Attachment
      Tony Mechelynck wrote:
      > On 28/08/13 18:27, Philip Piper wrote:
      >> Is it standard behavior that vim on my debian install can not run DOS
      >> plugins that I download without me converting said plugins to unix
      >> fileformat?
      >>
      >> The screenshot is after trying open vim after install Unite through
      >> pathogen.
      >>
      >
      > According to the help, Windows Vim can source a Unix-fileformat plugin
      > if 'fileformats' includes "unix" but not vice-versa. On a Unix Vim
      > (including Vim for Mac OS X), all lines of all plugins must end in a
      > linefeed with no carriage-return.
      ----
      Seems like it would be more user friendly if it could autodetect
      the line endings like it does on source files.


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... That cannot be done reliably. Especially for short scripts. Just write all Vim scripts with Unix line endings, that s the most straightforward way. -- If
      Message 2 of 3 , Sep 6, 2013
      • 0 Attachment
        Linda W wrote:

        > Tony Mechelynck wrote:
        > > On 28/08/13 18:27, Philip Piper wrote:
        > >> Is it standard behavior that vim on my debian install can not run DOS
        > >> plugins that I download without me converting said plugins to unix
        > >> fileformat?
        > >>
        > >> The screenshot is after trying open vim after install Unite through
        > >> pathogen.
        > >>
        > >
        > > According to the help, Windows Vim can source a Unix-fileformat plugin
        > > if 'fileformats' includes "unix" but not vice-versa. On a Unix Vim
        > > (including Vim for Mac OS X), all lines of all plugins must end in a
        > > linefeed with no carriage-return.
        > ----
        > Seems like it would be more user friendly if it could autodetect
        > the line endings like it does on source files.

        That cannot be done reliably. Especially for short scripts.
        Just write all Vim scripts with Unix line endings, that's the most
        straightforward way.

        --
        If Microsoft would build a car...
        ... Occasionally, executing a maneuver such as a left turn
        would cause your car to shut down and refuse to restart, in
        which case you would have to reinstall the engine.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... Or use dos2unix on the offending file first... Chip -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
        Message 3 of 3 , Sep 9, 2013
        • 0 Attachment
          Bram Moolenaar wrote:
          > Linda W wrote:
          >
          >> Tony Mechelynck wrote:
          >>> On 28/08/13 18:27, Philip Piper wrote:
          >>>> Is it standard behavior that vim on my debian install can not run DOS
          >>>> plugins that I download without me converting said plugins to unix
          >>>> fileformat?
          >>>>
          >>>> The screenshot is after trying open vim after install Unite through
          >>>> pathogen.
          >>>>
          >>> According to the help, Windows Vim can source a Unix-fileformat plugin
          >>> if 'fileformats' includes "unix" but not vice-versa. On a Unix Vim
          >>> (including Vim for Mac OS X), all lines of all plugins must end in a
          >>> linefeed with no carriage-return.
          >> ----
          >> Seems like it would be more user friendly if it could autodetect
          >> the line endings like it does on source files.
          > That cannot be done reliably. Especially for short scripts.
          > Just write all Vim scripts with Unix line endings, that's the most
          > straightforward way.
          >
          Or use dos2unix on the offending file first...
          Chip

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.