Loading ...
Sorry, an error occurred while loading the content.

Fwd: vim: ex cmd with pipe

Expand Messages
  • Ping
    Sent to wrong place.. Resent ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying
    Message 1 of 3 , Sep 5 12:24 PM
    • 0 Attachment
      Sent to wrong place..
      Resent

      > I'm using Conqterm plugin for a long time in a daily basis and basically like it.
      >
      > one of it's cmd is :
      >
      > :Conqterm SOME SHELL CMD
      >
      > like:
      >
      > :Conqterm bash
      > :Conqterm ls -l
      >
      > now I need to tail a file:
      >
      > :Conqterm tail -f /var/log/syslog
      >
      > all fine, but now I need a little bit pipe work here:
      >
      > :Conqterm tail -f /var/log/syslog | grep -i abc
      >
      > this doesn't work and throw me a warning:
      >
      > Error detected while processing function conque_term#open..conque_term#set_buffer_settings:
      > line 6:
      > E10: \ should be followed by /, ? or &
      > Press ENTER or type command to continue
      >
      > I tried this :
      > :Conqterm tail -f /var/log/syslog <bar> grep -i abc
      >
      > I got:
      >
      > Error detected while processing function 237..conque_term#set_mappings:
      > line 150:
      > E31: No such mapping
      >
      > what's the right way to do?
      >
      > thanks
      >
      > regards
      > ping

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Paul
      ... Have you tried | ? -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
      Message 2 of 3 , Sep 6 7:17 AM
      • 0 Attachment
        On Thursday, 05 September, 2013 at 20:24:43 BST, Ping wrote:
        >> all fine, but now I need a little bit pipe work here:
        >>
        >> :Conqterm tail -f /var/log/syslog | grep -i abc
        >>
        >> this doesn't work and throw me a warning:

        Have you tried \| ?

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ping
        I think I tried that but still got errors I ll paste the captures later ... -- -- You received this message from the vim_use maillist. Do not top-post! Type
        Message 3 of 3 , Sep 8 12:09 PM
        • 0 Attachment
          I think I tried that but still got errors
          I'll paste the captures later



          On Sep 6, 2013, at 10:17, Paul <google1241@...> wrote:

          > On Thursday, 05 September, 2013 at 20:24:43 BST, Ping wrote:
          >>> all fine, but now I need a little bit pipe work here:
          >>>
          >>> :Conqterm tail -f /var/log/syslog | grep -i abc
          >>>
          >>> this doesn't work and throw me a warning:
          >
          > Have you tried \| ?
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > --- You received this message because you are subscribed to the Google Groups "vim_use" group.
          > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/groups/opt_out.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.