Loading ...
Sorry, an error occurred while loading the content.

Re: nerdtree display problem

Expand Messages
  • LCD 47
    ... Or set NERDTreeDirArrows to 0: if &termencoding !=# utf-8 let NERDTreeDirArrows = 0 endif /lcd -- -- You received this message from the vim_use
    Message 1 of 7 , Sep 3, 2013
    • 0 Attachment
      On 3 September 2013, Ben Fritz <fritzophrenic@...> wrote:
      > On Tuesday, September 3, 2013 1:25:28 AM UTC-5, sinbad wrote:
      > > nerdtree doesnt display the tree characters
      > >
      > > properly, i'll get the these chars.â~V
      > >
      > > how to fix it ?
      >
      > I'm guessing here, but I bet you need to set your Vim to use a Unicode
      > encoding.
      >
      > http://vim.wikia.com/wiki/Working_with_Unicode

      Or set NERDTreeDirArrows to 0:

      if &termencoding !=# 'utf-8'
      let NERDTreeDirArrows = 0
      endif

      /lcd

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • sinbad
      ... no it s not helping, now i just see different chars like this ¿ -- -- You received this message from the vim_use maillist. Do not top-post! Type your
      Message 2 of 7 , Sep 3, 2013
      • 0 Attachment
        On Tuesday, September 3, 2013 9:58:21 PM UTC+5:30, Ben Fritz wrote:
        > On Tuesday, September 3, 2013 1:25:28 AM UTC-5, sinbad wrote:
        >
        > > nerdtree doesnt display the tree characters
        >
        > >
        >
        > > properly, i'll get the these chars.â~V
        >
        > >
        >
        > > how to fix it ?
        >
        >
        >
        > I'm guessing here, but I bet you need to set your Vim to use a Unicode encoding.
        >
        >
        >
        > http://vim.wikia.com/wiki/Working_with_Unicode

        no it's not helping, now i just see different chars like this ¿

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... Well at least Vim now recognizes that there is only one character there. Does your font have a glyph for that character? Are you using gvim, or Vim inside
        Message 3 of 7 , Sep 4, 2013
        • 0 Attachment
          On Wednesday, September 4, 2013 1:11:37 AM UTC-5, sinbad wrote:
          > On Tuesday, September 3, 2013 9:58:21 PM UTC+5:30, Ben Fritz wrote:
          > > I'm guessing here, but I bet you need to set your Vim to use a Unicode encoding.
          > >
          > > http://vim.wikia.com/wiki/Working_with_Unicode
          >
          > no it's not helping, now i just see different chars like this ¿

          Well at least Vim now recognizes that there is only one character there.

          Does your font have a glyph for that character?

          Are you using gvim, or Vim inside a terminal?

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • sinbad
          ... i don t know. how do i check that. ... i m using version VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 5 2013 06:26:51). i connect through putty from
          Message 4 of 7 , Sep 4, 2013
          • 0 Attachment
            On Wednesday, September 4, 2013 10:38:00 PM UTC+5:30, Ben Fritz wrote:

            >> Does your font have a glyph for that character?

            i don't know. how do i check that.

            >> Are you using gvim, or Vim inside a terminal?

            i'm using version VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 5 2013 06:26:51). i connect through putty from windows to a linux server and start vim there.



            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... To figure out whether Vim at least sees the right character, you can press ga on top of it in normal mode. That should tell you the character being used,
            Message 5 of 7 , Sep 4, 2013
            • 0 Attachment
              On Wednesday, September 4, 2013 11:53:03 PM UTC-5, sinbad wrote:
              > On Wednesday, September 4, 2013 10:38:00 PM UTC+5:30, Ben Fritz wrote:
              >
              > >> Does your font have a glyph for that character?
              >
              > i don't know. how do i check that.
              >
              > >> Are you using gvim, or Vim inside a terminal?
              >
              > i'm using version VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 5 2013 06:26:51). i connect through putty from windows to a linux server and start vim there.

              To figure out whether Vim at least sees the right character, you can press ga on top of it in normal mode. That should tell you the character being used, and you can see whether it is the right one. If Vim sees the right character but that character is not displayed, then probably your font needs changing.

              Are you using a GUI version of Vim with an X server? Or running it in the putty terminal window?

              If you're using the terminal version, I don't actually know how to change the font being used. I'd say it's a pretty good chance whatever the default is won't have a glyph for fancy Unicode characters.

              If you're using the GUI version, try a few fonts by brining up the font dialog:

              :set guifont=*

              Once you find one you like, you can add that to your .gvimrc. See http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.