Loading ...
Sorry, an error occurred while loading the content.

netrw (?) breaking window navigation on stock Debian Stable

Expand Messages
  • Tim Chase
    I m fairly certain I haven t initiated any changes that would impact this, but I just noticed this today and am trying track down when/why it happened, and how
    Message 1 of 2 , Sep 2, 2013
    • 0 Attachment
      I'm fairly certain I haven't initiated any changes that would impact
      this, but I just noticed this today and am trying track down when/why
      it happened, and how to solve it.

      To replicate on Debian Stable:

      bash$ cat reproducible_vimrc
      set nocp
      syn on

      bash$ vi -u reproducible_vimrc some_dir/

      this should open the contents of the directory in a netrw window
      (":set ft" returns "netrw"). From here, issue ":new" or select a
      file/subdirectory and press "o" to open it in a new window. From
      here, I tried to navigate back to the original netrw directory listing
      using <c-w>k to open other files but vim refused to navigate back to
      the window (no error message, just a failure to navigate to the
      window as would normally happen). I also tried ":wincmd k" with
      identical failure. Additionally, things like

      :let @a=''|windo 1yA

      fails to visit all the windows, and @a remains empty (not even
      pulling in the first line of the file I'm currently in). Similarly

      :windo $

      doesn't move my current window to the last line, let alone the netrw
      window.

      If I issue

      vi -u reproducible_vimrc some_dir/

      and then issue ":new", I have similar problems with navigating back
      into the netrw window. If I use "--noplugin", it no longer seems to
      load the netrw plugin at all (expected), so I have control over my
      windows still.

      The headers of /usr/share/vim/vim73/autoload/netrw.vim state that
      it's

      " Date: Apr 05, 2012
      " Version: 145

      It works as I'd expect in the other environments I have available:
      Vim 7.0 (on Win32, with r98 of netrw) and Vim 7.3.457 (on Ubuntu,
      with the same r145 of netrw).

      Is there something I'm missing, or some assumption that netwr makes
      about my vimrc that would trigger this behavior? Or a way to track
      down the problematic behavior?

      -tim


      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Feb 10 2013 02:27:59)
      Included patches: 1-547
      Modified by pkg-vim-maintainers@...
      Compiled by jamessan@...
      Huge version with GTK2 GUI. Features included (+) or not (-):
      +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
      +cindent +clientserver +clipboard +cmdline_compl +cmdline_hist
      +cmdline_info +comments +conceal +cryptv +cscope +cursorbind
      +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags
      +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path
      +float +folding -footer +fork() +gettext -hangul_input +iconv
      +insert_expand +jumplist +keymap +langmap +libcall +linebreak
      +lispindent +listcmds +localmap +lua +menu +mksession +modify_fname
      +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm
      +mouse_netterm -mouse_sysmouse +mouse_xterm +mouse_urxvt +multi_byte
      +multi_lang -mzscheme +netbeans_intg +path_extra +perl
      +persistent_undo +postscript +printer +profile +python -python3
      +quickfix +reltime +rightleft +ruby +scrollbind +signs +smartindent
      -sniff +startuptime +statusline -sun_workshop +syntax +tag_binary
      +tag_old_static -tag_any_white +tcl +terminfo +termresponse
      +textobjects +title +toolbar +user_commands +vertsplit +virtualedit
      +visual +visualextra +viminfo +vreplace +wildignore +wildmenu
      +windows +writebackup +X11 -xfontset +xim +xsmp_interact
      +xterm_clipboard -xterm_save system vimrc file: "$VIM/vimrc" user
      vimrc file: "$HOME/.vimrc" user exrc file: "$HOME/.exrc" system
      gvimrc file: "$VIM/gvimrc" user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
      -pthread -I/usr/include/gtk-2.0
      -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0
      -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0
      -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/
      -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
      -I/usr/include/pixman-1 -I/usr/include/freetype2
      -I/usr/include/libpng12 -g -O2 -fstack-protector
      --param=ssp-buffer-size=4 -Wformat -Werror=format-security
      -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -I/usr/include/tcl8.5
      -D_REENTRANT=1 -D_THREAD_SAFE=1 -D_LARGEFILE64_SOURCE=1 Linking:
      gcc -L. -Wl,-z,relro -rdynamic -Wl,-export-dynamic -Wl,-E
      -Wl,-z,relro -Wl,--as-needed -o vim -lgtk-x11-2.0 -lgdk-x11-2.0
      -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0
      -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0
      -lglib-2.0 -lSM -lICE -lXpm -lXt -lX11 -lXdmcp -lSM -lICE -lm
      -ltinfo -lnsl -lselinux -lacl -lattr -lgpm -L/usr/lib -llua5.1
      -Wl,-E -fstack-protector -L/usr/local/lib -L/usr/lib/perl/5.14/CORE
      -lperl -ldl -lm -lpthread -lcrypt -L/usr/lib/python2.7/config
      -lpython2.7 -lpthread -ldl -lutil -lm -Xlinker -export-dynamic
      -Wl,-O1 -Wl,-Bsymbolic-functions -L/usr/lib -ltcl8.5 -ldl -lpthread
      -lieee -lm -lruby-1.9.1 -lpthread -lrt -ldl -lcrypt -lm -L/usr/lib

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles Campbell
      ... So far, no problem... ... I m not seeing this (vim 7.4.5, netrw v150f): ie. using k to change windows worked. ... Doing this yields: E492: Not an
      Message 2 of 2 , Sep 3, 2013
      • 0 Attachment
        Tim Chase wrote:
        > I'm fairly certain I haven't initiated any changes that would impact
        > this, but I just noticed this today and am trying track down when/why
        > it happened, and how to solve it.
        >
        > To replicate on Debian Stable:
        >
        > bash$ cat reproducible_vimrc
        > set nocp
        > syn on
        >
        > bash$ vi -u reproducible_vimrc some_dir/
        >
        > this should open the contents of the directory in a netrw window
        > (":set ft" returns "netrw"). From here, issue ":new" or select a
        > file/subdirectory and press "o" to open it in a new window.

        So far, no problem...
        > From
        > here, I tried to navigate back to the original netrw directory listing
        > using <c-w>k to open other files but vim refused to navigate back to
        > the window (no error message, just a failure to navigate to the
        > window as would normally happen).

        I'm not seeing this (vim 7.4.5, netrw v150f): ie. using <c-w>k to change
        windows worked.
        > I also tried ":wincmd k" with
        > identical failure. Additionally, things like
        >
        > :let @a=''|windo 1yA
        >
        > fails to visit all the windows, and @a remains empty (not even
        > pulling in the first line of the file I'm currently in).

        Doing this yields: E492: Not an editor command: 1yA .
        Modifying it to
        :let @a=''|windo norm! 1yA
        yields
        E21: Cannot make changes, 'modifiable' is off

        because the netrw window ended up as the final window.
        > Similarly
        >
        > :windo $
        >
        > doesn't move my current window to the last line, let alone the netrw
        > window.
        This command caused the cursor to move to the last line of both windows.
        >
        > If I issue
        >
        > vi -u reproducible_vimrc some_dir/
        >
        > and then issue ":new", I have similar problems with navigating back
        > into the netrw window. If I use "--noplugin", it no longer seems to
        > load the netrw plugin at all (expected), so I have control over my
        > windows still.
        >
        > The headers of /usr/share/vim/vim73/autoload/netrw.vim state that
        > it's
        >
        > " Date: Apr 05, 2012
        > " Version: 145
        >
        > It works as I'd expect in the other environments I have available:
        > Vim 7.0 (on Win32, with r98 of netrw) and Vim 7.3.457 (on Ubuntu,
        > with the same r145 of netrw).
        >
        > Is there something I'm missing, or some assumption that netwr makes
        > about my vimrc that would trigger this behavior? Or a way to track
        > down the problematic behavior?
        >
        Yes -- may I suggest that you upgrade your netrw to the latest (v150f)
        from my website:

        http://www.drchip.org/astronaut/vim/index.html#NETRW

        Regards,
        Chip Campbell

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.