Loading ...
Sorry, an error occurred while loading the content.
 

":e" randomly splits in three windows and shows minibufexpl empty.

Expand Messages
  • dza
    hi guys, I ve been using my vimrc for a few years and now suddenly when I type :e file my minibufexpl splits up in three windows like;
    Message 1 of 3 , Aug 21, 2013
      hi guys, I've been using my vimrc for a few years and now suddenly when I type ":e file" my minibufexpl splits up in three windows like; http://i.imgur.com/ZTG5q17.png - it's quite random! Sometimes I can reopen vim and do two ":e" and minibufexpl shows as normal, but randomly it does this very annoying thing (usually when one file is open and :e is issued).

      I've used minibufexpl for a few years and then I decided to install my latest vimrc to my Windows and this startet happening.

      vimrc:
      https://gist.github.com/dezza/2bbbdc5aae824b2b2fdb

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Christian Brabandt
      ... My bet is some autocommand. Does that happen with :noa :e? Do you have some suspicious Buf{Win}Leave or Buf{Win}Enter autocommands? regards, Christian --
      Message 2 of 3 , Aug 22, 2013
        On Mi, 21 Aug 2013, dza wrote:

        > hi guys, I've been using my vimrc for a few years and now suddenly
        > when I type ":e file" my minibufexpl splits up in three windows like;
        > http://i.imgur.com/ZTG5q17.png - it's quite random! Sometimes I can
        > reopen vim and do two ":e" and minibufexpl shows as normal, but
        > randomly it does this very annoying thing (usually when one file is
        > open and :e is issued).
        >
        > I've used minibufexpl for a few years and then I decided to install my
        > latest vimrc to my Windows and this startet happening.

        My bet is some autocommand. Does that happen with :noa :e?
        Do you have some suspicious Buf{Win}Leave or Buf{Win}Enter autocommands?

        regards,
        Christian
        --
        Die Presse ist für mich Druckerschwärze auf Papier.
        -- Otto von Bismarck

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christoffer Aasted
        Hello Christian and thanks for answering. That s what I thought. I know you can test some auto-commands with ... and ... There is probably other ways to verify
        Message 3 of 3 , Aug 22, 2013
          Hello Christian and thanks for answering.

          That's what I thought. I know you can test some auto-commands with 
          :debug wincmd p
          and
          :redir
          :9verbose edit file.py
          :redir END

          There is probably other ways to verify or debug this step-by-step.

          I made a verbose.log however:

          If I remove all plugins except minibufexpl it works OK!

          If I re-add "mru.vim" I can go to one :MRU choose buffer (ENTER), then type :e somefile.py and it does the same.

          If I re-add "mru.vim" and :e twice nothing happens.





          On 22 August 2013 20:49, Christian Brabandt <cblists@...> wrote:
          On Mi, 21 Aug 2013, dza wrote:

          > hi guys, I've been using my vimrc for a few years and now suddenly
          > when I type ":e file" my minibufexpl splits up in three windows like;
          > http://i.imgur.com/ZTG5q17.png - it's quite random! Sometimes I can
          > reopen vim and do two ":e" and minibufexpl shows as normal, but
          > randomly it does this very annoying thing (usually when one file is
          > open and :e is issued).
          >
          > I've used minibufexpl for a few years and then I decided to install my
          > latest vimrc to my Windows and this startet happening.

          My bet is some autocommand. Does that happen with :noa :e?
          Do you have some suspicious Buf{Win}Leave or Buf{Win}Enter autocommands?

          regards,
          Christian
          --
          Die Presse ist für mich Druckerschwärze auf Papier.
                          -- Otto von Bismarck

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
          To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/-epP4_mQWec/unsubscribe.
          To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.