Loading ...
Sorry, an error occurred while loading the content.

Re: strange behavior: ":w" only writes new buffers to disk, not open them.

Expand Messages
  • Tim Chase
    ... Christian nailed the issue (including digging up which option, F , was the culprit that got wiped out), however he omitted the most important detail: how
    Message 1 of 9 , Aug 21, 2013
    • 0 Attachment
      On 2013-08-21 12:06, Christian Brabandt wrote:
      > On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
      > > set cpo=n
      >
      > This is you error. You probably want to add the 'n' flag
      > to the 'cpo' settings and not have 'cpo' only contain the 'n'.
      >
      > The difference is, in the former, the default flag 'F' will still
      > be available, which is responsible for setting the filename of
      > the current buffer to the one supplied by the :w command.
      > If it isn't there (e.g. by setting cpo=n), Vim won't set the
      > buffername and this is what you are currently experiencing.
      >
      > See also the help:
      > :h cpo-F


      Christian nailed the issue (including digging up which option, 'F',
      was the culprit that got wiped out), however he omitted the most
      important detail: how to fix it. If you got caught by this, it might
      have been helpful to include the remedy, to change

      set cpo=n

      to

      set cpo+=n

      as mentioned at

      :help :set+=

      -tim



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... In other words, you probably want this: set cpo+=n NOT this: set cpo=n -- -- You received this message from the vim_use maillist. Do not top-post! Type
      Message 2 of 9 , Aug 21, 2013
      • 0 Attachment
        On Wednesday, August 21, 2013 5:06:50 AM UTC-5, Christian Brabandt wrote:
        > On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
        >
        > > set cpo=n
        >
        >
        >
        > This is you error. You probably want to add the 'n' flag
        >
        > to the 'cpo' settings and not have 'cpo' only contain the 'n'.
        >
        >

        In other words, you probably want this:

        set cpo+=n

        NOT this:

        set cpo=n

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Leonardo Barbosa
        Cool. Fixed! Thank you all ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying
        Message 3 of 9 , Aug 21, 2013
        • 0 Attachment
          Cool. Fixed! Thank you all



          On Wed, Aug 21, 2013 at 11:20 AM, Ben Fritz <fritzophrenic@...> wrote:
          > On Wednesday, August 21, 2013 5:06:50 AM UTC-5, Christian Brabandt wrote:
          >> On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
          >>
          >> > set cpo=n
          >>
          >>
          >>
          >> This is you error. You probably want to add the 'n' flag
          >>
          >> to the 'cpo' settings and not have 'cpo' only contain the 'n'.
          >>
          >>
          >
          > In other words, you probably want this:
          >
          > set cpo+=n
          >
          > NOT this:
          >
          > set cpo=n
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
          > To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/YPcNy12ubaU/unsubscribe.
          > To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/groups/opt_out.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.