Loading ...
Sorry, an error occurred while loading the content.

Re: strange behavior: ":w" only writes new buffers to disk, not open them.

Expand Messages
  • Tim Chase
    ... then I d start binary-searching your vimrc by putting finish halfway through. If it still works, move it to 75% of the way through; otherwise, move it to
    Message 1 of 9 , Aug 20, 2013
    • 0 Attachment
      On 2013-08-20 23:02, Leonardo Barbosa wrote:
      > c) "vim -u NONE" makes vim works as expected.

      then I'd start binary-searching your vimrc by putting

      finish

      halfway through. If it still works, move it to 75% of the way
      through; otherwise, move it to 25% of the way through. By cutting
      your vimrc in half each time, you should be able to determine the
      problematic line.

      Alternatively, you could try including posting your vimrc here to get
      other eyes on what might be causing the problem.

      -tim


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Leonardo Barbosa
      Thanks again! The problems seems to be the combination of these two lines let &showbreak = ↳ if you can t see this character, it s a return arrow set
      Message 2 of 9 , Aug 21, 2013
      • 0 Attachment
        Thanks again! The problems seems to be the combination of these two lines
        let &showbreak = '↳ ' " if you can't see this character, it's a return arrow
        set cpo=n

        Indeed, i have set those, recently.

        Leo


        On Tue, Aug 20, 2013 at 11:21 PM, Tim Chase <vim@...> wrote:
        > On 2013-08-20 23:02, Leonardo Barbosa wrote:
        >> c) "vim -u NONE" makes vim works as expected.
        >
        > then I'd start binary-searching your vimrc by putting
        >
        > finish
        >
        > halfway through. If it still works, move it to 75% of the way
        > through; otherwise, move it to 25% of the way through. By cutting
        > your vimrc in half each time, you should be able to determine the
        > problematic line.
        >
        > Alternatively, you could try including posting your vimrc here to get
        > other eyes on what might be causing the problem.
        >
        > -tim
        >
        >

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        ... This is you error. You probably want to add the n flag to the cpo settings and not have cpo only contain the n . The difference is, in the former,
        Message 3 of 9 , Aug 21, 2013
        • 0 Attachment
          On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
          > set cpo=n

          This is you error. You probably want to add the 'n' flag
          to the 'cpo' settings and not have 'cpo' only contain the 'n'.

          The difference is, in the former, the default flag 'F' will still
          be available, which is responsible for setting the filename of
          the current buffer to the one supplied by the :w command.
          If it isn't there (e.g. by setting cpo=n), Vim won't set the buffername
          and this is what you are currently experiencing.

          See also the help:
          :h cpo-F

          regards,
          Christian

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tim Chase
          ... Christian nailed the issue (including digging up which option, F , was the culprit that got wiped out), however he omitted the most important detail: how
          Message 4 of 9 , Aug 21, 2013
          • 0 Attachment
            On 2013-08-21 12:06, Christian Brabandt wrote:
            > On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
            > > set cpo=n
            >
            > This is you error. You probably want to add the 'n' flag
            > to the 'cpo' settings and not have 'cpo' only contain the 'n'.
            >
            > The difference is, in the former, the default flag 'F' will still
            > be available, which is responsible for setting the filename of
            > the current buffer to the one supplied by the :w command.
            > If it isn't there (e.g. by setting cpo=n), Vim won't set the
            > buffername and this is what you are currently experiencing.
            >
            > See also the help:
            > :h cpo-F


            Christian nailed the issue (including digging up which option, 'F',
            was the culprit that got wiped out), however he omitted the most
            important detail: how to fix it. If you got caught by this, it might
            have been helpful to include the remedy, to change

            set cpo=n

            to

            set cpo+=n

            as mentioned at

            :help :set+=

            -tim



            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Ben Fritz
            ... In other words, you probably want this: set cpo+=n NOT this: set cpo=n -- -- You received this message from the vim_use maillist. Do not top-post! Type
            Message 5 of 9 , Aug 21, 2013
            • 0 Attachment
              On Wednesday, August 21, 2013 5:06:50 AM UTC-5, Christian Brabandt wrote:
              > On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
              >
              > > set cpo=n
              >
              >
              >
              > This is you error. You probably want to add the 'n' flag
              >
              > to the 'cpo' settings and not have 'cpo' only contain the 'n'.
              >
              >

              In other words, you probably want this:

              set cpo+=n

              NOT this:

              set cpo=n

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Leonardo Barbosa
              Cool. Fixed! Thank you all ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying
              Message 6 of 9 , Aug 21, 2013
              • 0 Attachment
                Cool. Fixed! Thank you all



                On Wed, Aug 21, 2013 at 11:20 AM, Ben Fritz <fritzophrenic@...> wrote:
                > On Wednesday, August 21, 2013 5:06:50 AM UTC-5, Christian Brabandt wrote:
                >> On Wed, August 21, 2013 11:26, Leonardo Barbosa wrote:
                >>
                >> > set cpo=n
                >>
                >>
                >>
                >> This is you error. You probably want to add the 'n' flag
                >>
                >> to the 'cpo' settings and not have 'cpo' only contain the 'n'.
                >>
                >>
                >
                > In other words, you probably want this:
                >
                > set cpo+=n
                >
                > NOT this:
                >
                > set cpo=n
                >
                > --
                > --
                > You received this message from the "vim_use" maillist.
                > Do not top-post! Type your reply below the text you are replying to.
                > For more information, visit http://www.vim.org/maillist.php
                >
                > ---
                > You received this message because you are subscribed to a topic in the Google Groups "vim_use" group.
                > To unsubscribe from this topic, visit https://groups.google.com/d/topic/vim_use/YPcNy12ubaU/unsubscribe.
                > To unsubscribe from this group and all its topics, send an email to vim_use+unsubscribe@....
                > For more options, visit https://groups.google.com/groups/opt_out.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.