Loading ...
Sorry, an error occurred while loading the content.

Certain commands undock & shift window

Expand Messages
  • AndyHancock
    I Windows 7, when I have the gvim windows docked against the right or left half of the screen, the following commands always seem undock the window and shifts
    Message 1 of 5 , Aug 17, 2013
    • 0 Attachment
      I Windows 7, when I have the gvim windows docked against the right or left half of the screen, the following commands always seem undock the window and shifts the position:

      * tab split or tabclose
      * set guioptions+=b when it doesn't have b
      * set guioptions-=b when it does

      I use those commands alot, so I'm constantly having to readjust the window. Would anyone have an idea of what might cause this, and or how to go about troubleshooting?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Dan Wierenga
      Hi Andy, ... I can confirm the behavior on my setup too. I d guess that Windows sees the height of the gvim window change and thus undocks it for you, just
      Message 2 of 5 , Aug 19, 2013
      • 0 Attachment

        Hi Andy,

        On Sat, Aug 17, 2013 at 6:18 PM, AndyHancock <AndyMHancock@...> wrote:
        I Windows 7, when I have the gvim windows docked against the right or left half of the screen, the following commands always seem undock the window and shifts the position:

         * tab split or tabclose
         * set guioptions+=b when it doesn't have b
         * set guioptions-=b when it does

        I use those commands alot, so I'm constantly having to readjust the window.  Would anyone have an idea of what might cause this, and or how to go about troubleshooting?

         

        I can confirm the behavior on my setup too.  I'd guess that Windows sees the height of the gvim window change and thus undocks it for you, just like it does if you change the height of the window with the mouse.  I don't think there's a way to stop Windows from "helping" in that manner, unless you can somehow convince gvim to not change the window height.  A few quick experiments didn't reveal anything useful to me however.

        I personally just re-dock the gvim window again.  Holding down the Windows key and hitting the right-arrow key is a very quick way of re-docking it to the right side again ( or left-arrow to the left side), much faster than reaching for the mouse.

        Hope that helps,
        Dan

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • AndyHancock
        ... Wow, I didn t even realize that the window size changed. The trick for docking a window from the keyboard is neat. Unfortunately (well, just for me, that
        Message 3 of 5 , Aug 20, 2013
        • 0 Attachment
          On Mon, Aug 19, 2013 at 12:42 PM, Dan Wierenga wrote:
          >>On Sat, Aug 17, 2013 at 6:18 PM, AndyHancock wrote:
          >> I Windows 7, when I have the gvim windows docked against the right
          >> or left half of the screen, the following commands always seem
          >> undock the window and shifts the position:
          >>
          >> * tab split or tabclose
          >> * set guioptions+=b when it doesn't have b
          >> * set guioptions-=b when it does
          >>
          >> I use those commands alot, so I'm constantly having to readjust the
          >> window. Would anyone have an idea of what might cause this, and or
          >> how to go about troubleshooting?
          >>
          >>I can confirm the behavior on my setup too. I'd guess that Windows
          >>sees the height of the gvim window change and thus undocks it for
          >>you, just like it does if you change the height of the window with
          >>the mouse. I don't think there's a way to stop Windows from
          >>"helping" in that manner, unless you can somehow convince gvim to
          >>not change the window height. A few quick experiments didn't reveal
          >>anything useful to me however. I personally just re-dock the gvim
          >>window again. Holding down the Windows key and hitting the
          >>right-arrow key is a very quick way of re-docking it to the right
          >>side again ( or left-arrow to the left side), much faster than
          >>reaching for the mouse.

          Wow, I didn't even realize that the window size changed.

          The trick for docking a window from the keyboard is neat. Unfortunately (well, just for me, that is), I will still have use the mouse since I actually adjust the window after docking to be skinnier than half the width of the screen. I have a widescreen so that I can work with many windows at once, and having one app take up an entire half of the display defeats the purpose of the widescreen (especially when I don't need the app to take up that amount of width).

          Ah well. Welcome to Windows. Thanks anyway.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Dan Wierenga
          ... I would look into AutoHotKey [1] then. It does some pretty amazing things for Windows workflows. This script [2] seems like something that would help
          Message 4 of 5 , Aug 20, 2013
          • 0 Attachment
            On Tue, Aug 20, 2013 at 12:10 AM, AndyHancock <AndyMHancock@...> wrote:
            The trick for docking a window from the keyboard is neat.  Unfortunately (well, just for me, that is), I will still have use the mouse since I actually adjust the window after docking to be skinnier than half the width of the screen.  I have a widescreen so that I can work with many windows at once, and having one app take up an entire half of the display defeats the purpose of the widescreen (especially when I don't need the app to take up that amount of width).

            I would look into AutoHotKey [1] then.  It does some pretty amazing things for Windows workflows.   This script [2] seems like something that would help you.


            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • AndyHancock
            ... Dan, it looks like an interestin app. Don t mean to sound unappreciative, but I am restricted in the kinds of solutions I can pursue because most of time,
            Message 5 of 5 , Aug 20, 2013
            • 0 Attachment
              On Tuesday, August 20, 2013 12:43:42 PM UTC-4, dwierenga wrote:
              > On Tue, Aug 20, 2013 at 12:10 AM, AndyHancock <AndyMH...@...>
              > wrote:
              >
              > The trick for docking a window from the keyboard is neat.
              > Unfortunately (well, just for me, that is), I will still have use
              > the mouse since I actually adjust the window after docking to be
              > skinnier than half the width of the screen. I have a widescreen so
              > that I can work with many windows at once, and having one app take
              > up an entire half of the display defeats the purpose of the
              > widescreen (especially when I don't need the app to take up that
              > amount of width).
              >
              > I would look into AutoHotKey [1] then. It does some pretty amazing
              > things for Windows workflows. This script [2] seems like something
              > that would help you.
              >
              > [1] http://www.autohotkey.com/ [2]
              > http://www.howtogeek.com/howto/28663/create-a-hotkey-to-resize-windows-to-a-specific-size-with-autohotkey/

              Dan, it looks like an interestin app. Don't mean to sound unappreciative, but I am restricted in the kinds of solutions I can pursue because most of time, I'm in a locked down environment. It took moving heaven and earth to get vim. If it was a simple switch in vim to avoid the window shift problem, that'd be do-able. Anything else....it's could be remotely possible, but pushing for it could be a full time job. I think I better get use to reaching for the mouse. Thanks anyway.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.