Loading ...
Sorry, an error occurred while loading the content.

vim 7.4 & python3

Expand Messages
  • inheritsfrom@...
    Hello, I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem
    Message 1 of 6 , Aug 2, 2013
    • 0 Attachment
      Hello,

      I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?

      Thanks.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Andrei Olsen
      ... Shouldn t it be ./configure --enable-python3interp=dynamic -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
      Message 2 of 6 , Aug 2, 2013
      • 0 Attachment
        On Saturday, August 3, 2013 12:23:51 AM UTC+2, inheri...@... wrote:
        > Hello,
        >
        > I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?
        >
        > Thanks.

        Shouldn't it be

        ./configure --enable-python3interp=dynamic

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Odne Hellebø
        ... I have to add --enable-pythoninterp=dynamic --enable-python3interp=dynamic --with-python-config-dir=/usr/lib/python2.7/config
        Message 3 of 6 , Aug 2, 2013
        • 0 Attachment
          On Saturday, August 3, 2013 12:23:51 AM UTC+2, inheri...@... wrote:
          > Hello,
          >
          > I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?
          >
          > Thanks.

          I have to add
          --enable-pythoninterp=dynamic \
          --enable-python3interp=dynamic \
          --with-python-config-dir=/usr/lib/python2.7/config \
          --with-python3-config-dir=/usr/lib/python3.3/config-3.3m \
          to get python2 and python3 working. Maybe the --with-python3-config-dir option? Good luck :)

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • inheritsfrom@...
          ... Thanks. But `brew install` handles the ./configure step, and simply passing --with-perl or --with-ruby or --with-python does what it s supposed to. And
          Message 4 of 6 , Aug 3, 2013
          • 0 Attachment
            On Friday, August 2, 2013 4:30:05 PM UTC-7, Andrei Olsen wrote:
            > On Saturday, August 3, 2013 12:23:51 AM UTC+2, inheri...@... wrote:
            > > Hello,
            > >
            > > I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?
            > >
            > > Thanks.
            >
            > Shouldn't it be
            >
            > ./configure --enable-python3interp=dynamic

            Thanks. But `brew install` handles the ./configure step, and simply passing --with-perl or --with-ruby or --with-python does what it's supposed to. And there actually was a time when I could --with-python3 and it would successfully link to brew installed python3.

            BTW, tried `brew install vim --enable-python3interp=dynamic` but had no success.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • inheritsfrom@...
            ... Thanks. Tried after adjusting the python3 config dir path to my installation of python3, but had no success. -- -- You received this message from the
            Message 5 of 6 , Aug 3, 2013
            • 0 Attachment
              On Friday, August 2, 2013 7:05:45 PM UTC-7, Odne Hellebø wrote:
              > On Saturday, August 3, 2013 12:23:51 AM UTC+2, inheri...@... wrote:
              > > Hello,
              > >
              > > I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?
              > >
              > > Thanks.
              >
              > I have to add
              > --enable-pythoninterp=dynamic \
              > --enable-python3interp=dynamic \
              > --with-python-config-dir=/usr/lib/python2.7/config \
              > --with-python3-config-dir=/usr/lib/python3.3/config-3.3m \
              > to get python2 and python3 working. Maybe the --with-python3-config-dir option? Good luck :)

              Thanks. Tried after adjusting the python3 config dir path to my installation of python3, but had no success.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Hettomei
              ... I had several problems with homebrew and --with-rubyinterp Since I compile from the source I have no problem (from hg clone https://vim.googlecode.com/hg/
              Message 6 of 6 , Aug 3, 2013
              • 0 Attachment
                Le samedi 3 août 2013 16:36:22 UTC+2, inheri...@... a écrit :
                > On Friday, August 2, 2013 7:05:45 PM UTC-7, Odne Hellebø wrote:
                >
                > > On Saturday, August 3, 2013 12:23:51 AM UTC+2, inheri...@... wrote:
                >
                > > > Hello,
                >
                > > >
                >
                > > > I install vim 7.4 via homebrew on OS X 10.8.4. But passing --with-python3 never successfully builds vim with python3 support. I had the same problem with vim 7.3. Does anyone have a solution?
                >
                > > >
                >
                > > > Thanks.
                >
                > >
                >
                > > I have to add
                >
                > > --enable-pythoninterp=dynamic \
                >
                > > --enable-python3interp=dynamic \
                >
                > > --with-python-config-dir=/usr/lib/python2.7/config \
                >
                > > --with-python3-config-dir=/usr/lib/python3.3/config-3.3m \
                >
                > > to get python2 and python3 working. Maybe the --with-python3-config-dir option? Good luck :)
                >
                >
                >
                > Thanks. Tried after adjusting the python3 config dir path to my installation of python3, but had no success.

                I had several problems with homebrew and --with-rubyinterp
                Since I compile from the source I have no problem
                (from hg clone https://vim.googlecode.com/hg/ vim )

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.