Loading ...
Sorry, an error occurred while loading the content.

Re: glob() does not like 'lib'?

Expand Messages
  • Christian Brabandt
    ... I don t see this. Can you reproduce it with vim -u NONE -U NONE -N? Have you checked the permissions of the directory? regards, Christian -- -- You
    Message 1 of 4 , Jul 31, 2013
    • 0 Attachment
      On Wed, July 31, 2013 13:38, Saulius G. wrote:
      > Hi,
      >
      >
      > It seems that glob() returns empty for every existing directory, which
      > ends with '/lib'.
      >
      > For example, glob('/tmp/lib') returns empty string. Directory '/tmp/lib'
      > exists.
      >
      > I'm using latest version of VIM - 7.4b BETA.
      >
      > Is it a bug?

      I don't see this. Can you reproduce it with
      vim -u NONE -U NONE -N?

      Have you checked the permissions of the directory?

      regards,
      Christian

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Saulius G.
      vim -u NONE -U NONE -N worked. I checked and in my .vimrc found the cause of the problem. There was set wildignore+=lib My fault. Thank you. -- Saulius ... --
      Message 2 of 4 , Aug 1, 2013
      • 0 Attachment
        vim -u NONE -U NONE -N worked.

        I checked and in my .vimrc found the cause of the problem.
        There was

        set wildignore+=lib

        My fault.

        Thank you.
        --
        Saulius

        On Wednesday, July 31, 2013 3:56:44 PM UTC+3, Christian Brabandt wrote:
        > On Wed, July 31, 2013 13:38, Saulius G. wrote:
        >
        > > Hi,
        >
        > >
        >
        > >
        >
        > > It seems that glob() returns empty for every existing directory, which
        >
        > > ends with '/lib'.
        >
        > >
        >
        > > For example, glob('/tmp/lib') returns empty string. Directory '/tmp/lib'
        >
        > > exists.
        >
        > >
        >
        > > I'm using latest version of VIM - 7.4b BETA.
        >
        > >
        >
        > > Is it a bug?
        >
        >
        >
        > I don't see this. Can you reproduce it with
        >
        > vim -u NONE -U NONE -N?
        >
        >
        >
        > Have you checked the permissions of the directory?
        >
        >
        >
        > regards,
        >
        > Christian

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        ... You should have used the 2nd parameter of the glob function() ;) regards, Christian -- -- You received this message from the vim_use maillist. Do not
        Message 3 of 4 , Aug 1, 2013
        • 0 Attachment
          On Thu, August 1, 2013 15:11, Saulius G. wrote:
          > vim -u NONE -U NONE -N worked.
          >
          > I checked and in my .vimrc found the cause of the problem.
          > There was
          >
          > set wildignore+=lib
          >
          > My fault.

          You should have used the 2nd parameter of the glob function() ;)

          regards,
          Christian

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.