Loading ...
Sorry, an error occurred while loading the content.

error installing 7.4a

Expand Messages
  • JESii
    I ve installed a new version of Kubuntu (12.04) and rebuilding vim from the source downloaded previously (I have my /home on a separate partition). I ran into
    Message 1 of 2 , Jul 30, 2013
    • 0 Attachment
      I've installed a new version of Kubuntu (12.04) and rebuilding vim from the source downloaded previously (I have my /home on a separate partition).

      I ran into problems rebuilding for the new OS (had to install termcap.h), and retrying after that install didn't work. So, I just ran:
      make -B
      thinking that would just rebuild everything as man says.

      However, this resulted in the following errors:
      checking setjmp.h presence... yes
      checking for setjmp.h... yes
      checking for GCC 3 or later... yes
      checking whether we need -D_FORTIFY_SOURCE=1... yes
      checking linker --as-needed support... yes
      configure: updating cache auto/config.cache
      configure: creating auto/config.status
      config.status: creating auto/config.mk
      config.status: creating auto/config.h
      config.status: auto/config.h is unchanged
      Reaping winning child 0x0211e300 PID 9497
      Removing child 0x0211e300 PID 9497 from chain.
      Successfully remade target file `auto/config.mk'.
      Considering target file `Makefile'.
      Finished prerequisites of target file `Makefile'.
      Making `Makefile' due to always-make flag.
      Must remake target `Makefile'.
      Putting child 0x02122690 (Makefile) PID 12883 on the chain.
      Live child 0x02122690 (Makefile) PID 12883
      /bin/sh: 1: Syntax error: "(" unexpected
      Reaping losing child 0x02122690 PID 12883
      make: *** [Makefile] Error 2
      Removing child 0x02122690 PID 12883 from chain.

      Then I tried just 'make' and got the following:
      -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 version.c -o objects/version.o
      link.sh: $LINK_AS_NEEDED set to 'yes': invoking linker directly.
      gcc -L/usr/local/lib -Wl,-rpath,/usr/local/lib -Wl,--as-needed -o vim objects/buffer.o objects/blowfish.o objects/charset.o objects/diff.o objects/digraph.o objects/edit.o objects/eval.o objects/ex_cmds.o objects/ex_cmds2.o objects/ex_docmd.o objects/ex_eval.o objects/ex_getln.o objects/fileio.o objects/fold.o objects/getchar.o objects/hardcopy.o objects/hashtab.o objects/if_cscope.o objects/if_xcmdsrv.o objects/mark.o objects/memline.o objects/menu.o objects/message.o objects/misc1.o objects/misc2.o objects/move.o objects/mbyte.o objects/normal.o objects/ops.o objects/option.o objects/os_unix.o objects/pathdef.o objects/popupmnu.o objects/quickfix.o objects/regexp.o objects/screen.o objects/search.o objects/sha256.o objects/spell.o objects/syntax.o objects/tag.o objects/term.o objects/ui.o objects/undo.o objects/version.o objects/window.o objects/netbeans.o objects/main.o objects/memfile.o -lm -ltinfo -lnsl -ldl
      link.sh: Linked fine
      cd xxd; CC="gcc" CFLAGS="-I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1" LDFLAGS="-L/usr/local/lib -Wl,-rpath,/usr/local/lib -Wl,--as-needed" \
      make -f Makefile
      make[1]: Entering directory `/home/jseidel/vimbuild/src/xxd'
      gcc -I/usr/local/include -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -L/usr/local/lib -Wl,-rpath,/usr/local/lib -Wl,--as-needed -DUNIX -o xxd xxd.c
      make[1]: Leaving directory `/home/jseidel/vimbuild/src/xxd'

      Any suggestions? I may just try re-downloading the src and starting over from scratch. Thanks!

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • John Little
      Firstly, on a Debian distro, sudo apt-get build-dep vim-gtk would have avoided your first problem. Secondly, I see linked fine in the make output; that s a
      Message 2 of 2 , Jul 31, 2013
      • 0 Attachment
        Firstly, on a Debian distro,

        sudo apt-get build-dep vim-gtk

        would have avoided your first problem.

        Secondly, I see "linked fine" in the make output; that's a success message, there should be a vim executable in the src directory.

        Have you set configure options to get the features you want? Like a GUI, or script language (f. ex. perl, python, ruby, lua...) support? I use Tony Mechelynk's method, see:

        http://users.skynet.be/antoine.mechelynck/vim/compunix.htm

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.