Loading ...
Sorry, an error occurred while loading the content.

Press ENTER or type command to continue problem at every vim startup

Expand Messages
  • Jean-Marcel Belmont
    Hello I am using vim 7.4 beta with patches (1-39). I am using Mac OS X 10.7 Everytime I open vim now I get the prompt: Press ENTER or type command to continue
    Message 1 of 5 , Jul 29 11:52 AM
    • 0 Attachment
      Hello I am using vim 7.4 beta with patches (1-39). I am using Mac OS X 10.7
      Everytime I open vim now I get the prompt:
      Press ENTER or type command to continue
      In my vimrc I have the following:
      set equalalways
      set history=200
      set autoread
      set tw=75
      set so=7
      set wrapmargin
      set nocompatible
      " powerline status bar
      set laststatus=2
      set encoding=utf-8
      set wildmenu
      set ruler
      set tabstop=2
      set shiftwidth=2
      set expandtab
      set softtabstop=2
      set cmdheight=1
      set hid
      set backspace=eol,start,indent
      set shiftround
      set ignorecase
      set nobackup
      set autoindent smartindent
      set nowb
      set magic
      set showmatch
      set noswapfile
      set viminfo='20,\"50
      set number
      set wildmode=longest:full,full
      set wildmenu
      set noerrorbells
      set incsearch
      set hlsearch
      I also have additional options set in vimrc but they are for map leader bindings and plugin options as well. I have tried the suggestions in the vim wiki about set shortmess=a, I tried shortmess=at, set cmdheight=2, but these are
      refer to the Press ENTER or type command to continue when you issue an external command such as !ls in vim command window. My problem is that I get
      Press ENTER to type command to continue in each and every vim startup option.
      Does anyone know how to solve this issue. Any suggestions would be greatly appreciated.

      Sincerely,

      Jean-Marcel Belmont

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... I assume you mean: http://vim.wikia.com/wiki/Avoiding_the_%22Hit_ENTER_to_continue%22_prompts Actually the only suggestion on that page regarding external
      Message 2 of 5 , Jul 29 2:20 PM
      • 0 Attachment
        On Monday, July 29, 2013 1:52:22 PM UTC-5, Jean-Marcel Belmont wrote:
        > I have tried the suggestions in the vim wiki about set shortmess=a, I tried shortmess=at, set cmdheight=2, but these are
        > refer to the Press ENTER or type command to continue when you issue an external command such as !ls in vim command window.

        I assume you mean:

        http://vim.wikia.com/wiki/Avoiding_the_%22Hit_ENTER_to_continue%22_prompts

        Actually the only suggestion on that page regarding external commands is that you can use :silent before the command. The rest is about situations where there is something printed to the screen inside Vim which the user must read.

        > My problem is that I get
        > Press ENTER to type command to continue in each and every vim startup option.
        > Does anyone know how to solve this issue.

        Are there other messages that show up before the "press enter" prompt? You can search your plugins for these messages to figure out how to disable them. Or set you cmdheight option big enough to show them all at startup.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Jean-Marcel Belmont
        Hello Ben: I tried to set cmdheight=15 just to see if any messages, but none came. Also I tried vim -u NONE -U NONE and the message Press ENTER or type
        Message 3 of 5 , Jul 29 3:00 PM
        • 0 Attachment
          Hello Ben:

          I tried to set cmdheight=15 just to see if any messages, but none came. Also I tried vim -u NONE -U NONE and the message "Press ENTER or type command" didn't not show. You suggested to search plugins, how should I go about this, should I use grep for the phrase "Press ENTER or type command" on my plugins, or should I read all help files for all my plugins for this problem.


          On Mon, Jul 29, 2013 at 5:20 PM, Ben Fritz <fritzophrenic@...> wrote:
          On Monday, July 29, 2013 1:52:22 PM UTC-5, Jean-Marcel Belmont wrote:
          > I have tried the suggestions in the vim wiki about set shortmess=a, I tried shortmess=at, set cmdheight=2, but these are
          > refer to the Press ENTER or type command to continue when you issue an external command such as !ls in vim command window.

          I assume you mean:

          http://vim.wikia.com/wiki/Avoiding_the_%22Hit_ENTER_to_continue%22_prompts

          Actually the only suggestion on that page regarding external commands is that you can use :silent before the command. The rest is about situations where there is something printed to the screen inside Vim which the user must read.

          > My problem is that I get
          > Press ENTER to type command to continue in each and every vim startup option.
          > Does anyone know how to solve this issue.

          Are there other messages that show up before the "press enter" prompt? You can search your plugins for these messages to figure out how to disable them. Or set you cmdheight option big enough to show them all at startup.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Gary Johnson
          ... The message, Press ENTER or type command to continue is generated by Vim itself. It is not generated by plugins and the string is unlikely to be found
          Message 4 of 5 , Jul 29 6:02 PM
          • 0 Attachment
            On 2013-07-29, Jean-Marcel Belmont wrote:

            > On Mon, Jul 29, 2013 at 5:20 PM, Ben Fritz wrote:
            >
            > On Monday, July 29, 2013 1:52:22 PM UTC-5, Jean-Marcel Belmont wrote:
            > > I have tried the suggestions in the vim wiki about set shortmess=a, I
            > > tried shortmess=at, set cmdheight=2, but these are
            > > refer to the Press ENTER or type command to continue when you issue an
            > > external command such as !ls in vim command window.
            >
            > I assume you mean:
            >
            > http://vim.wikia.com/wiki/Avoiding_the_%22Hit_ENTER_to_continue%22_prompts
            >
            > Actually the only suggestion on that page regarding external commands is
            > that you can use :silent before the command. The rest is about situations
            > where there is something printed to the screen inside Vim which the user
            > must read.
            >
            > > My problem is that I get
            > > Press ENTER to type command to continue in each and every vim startup
            > > option.
            > > Does anyone know how to solve this issue.
            >
            > Are there other messages that show up before the "press enter" prompt? You
            > can search your plugins for these messages to figure out how to disable
            > them. Or set you cmdheight option big enough to show them all at startup.

            > Hello Ben:
            >
            > I tried to set cmdheight=15 just to see if any messages, but none came. Also I
            > tried vim -u NONE -U NONE and the message "Press ENTER or type command" didn't
            > not show. You suggested to search plugins, how should I go about this, should I
            > use grep for the phrase "Press ENTER or type command" on my plugins, or should
            > I read all help files for all my plugins for this problem.

            The message, "Press ENTER or type command to continue" is generated
            by Vim itself. It is not generated by plugins and the string is
            unlikely to be found in any plugin.

            Discussion of this issue is also not likely to be found in the help
            file for any plugin. If the message is part of the normal behavior
            of a plugin, then that normal behavior would be adequately described
            in ":help press-enter". If the message is due to a bug in the
            plugin, then the author is probably not aware of it.

            Lacking any message preceding the "Press ENTER" message, about the
            only way to isolate this to a particular plugin is to do a binary
            search of your plugins. If you're not sure how to do that, the
            following algorithm should work.

            1. Create two directories, ~/unknown and ~/good.
            2. Move half the files in ~/.vim/plugin to ~/unknown.
            3. Run your test, which in this case is to execute vim and
            watch for the "Press ENTER" message. If the message is
            there, the result is "bad"; otherwise, the result is "good".
            4. If "good":
            a) Move all the files in plugin to ~/good.
            b) Move half the files in ~/unknown to plugin.
            If "bad":
            a) Move all the files in ~/unknown to ~/good.
            b) Move half the files in plugin to ~/unknown.
            5. Repeat from step 3 until one bad file remains in plugin.

            The convention in this group is to not top-post. I have reformatted
            your reply accordingly.

            Regards,
            Gary

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Jean-Marcel Belmont
            Okay great thanks for your help. I will try this binary search as you have suggested. ... -- -- You received this message from the vim_use maillist. Do not
            Message 5 of 5 , Jul 29 6:23 PM
            • 0 Attachment
              Okay great thanks for your help. I will try this binary search as you have suggested.


              On Mon, Jul 29, 2013 at 9:02 PM, Gary Johnson <garyjohn@...> wrote:
              On 2013-07-29, Jean-Marcel Belmont wrote:

              > On Mon, Jul 29, 2013 at 5:20 PM, Ben Fritz wrote:
              >
              >     On Monday, July 29, 2013 1:52:22 PM UTC-5, Jean-Marcel Belmont wrote:
              >     > I have tried the suggestions in the vim wiki about set shortmess=a, I
              >     > tried shortmess=at, set cmdheight=2, but these are
              >     > refer to the Press ENTER or type command to continue when you issue an
              >     > external command such as !ls in vim command window.
              >
              >     I assume you mean:
              >
              >     http://vim.wikia.com/wiki/Avoiding_the_%22Hit_ENTER_to_continue%22_prompts
              >
              >     Actually the only suggestion on that page regarding external commands is
              >     that you can use :silent before the command. The rest is about situations
              >     where there is something printed to the screen inside Vim which the user
              >     must read.
              >
              >     > My problem is that I get
              >     > Press ENTER to type command to continue in each and every vim startup
              >     > option.
              >     > Does anyone know how to solve this issue.
              >
              >     Are there other messages that show up before the "press enter" prompt? You
              >     can search your plugins for these messages to figure out how to disable
              >     them. Or set you cmdheight option big enough to show them all at startup.

              > Hello Ben:
              >
              > I tried to set cmdheight=15 just to see if any messages, but none came. Also I
              > tried vim -u NONE -U NONE and the message "Press ENTER or type command" didn't
              > not show. You suggested to search plugins, how should I go about this, should I
              > use grep for the phrase "Press ENTER or type command" on my plugins, or should
              > I read all help files for all my plugins for this problem.

              The message, "Press ENTER or type command to continue" is generated
              by Vim itself.  It is not generated by plugins and the string is
              unlikely to be found in any plugin.

              Discussion of this issue is also not likely to be found in the help
              file for any plugin.  If the message is part of the normal behavior
              of a plugin, then that normal behavior would be adequately described
              in ":help press-enter".  If the message is due to a bug in the
              plugin, then the author is probably not aware of it.

              Lacking any message preceding the "Press ENTER" message, about the
              only way to isolate this to a particular plugin is to do a binary
              search of your plugins.  If you're not sure how to do that, the
              following algorithm should work.

                  1.  Create two directories, ~/unknown and ~/good.
                  2.  Move half the files in ~/.vim/plugin to ~/unknown.
                  3.  Run your test, which in this case is to execute vim and
                      watch for the "Press ENTER" message.  If the message is
                      there, the result is "bad"; otherwise, the result is "good".
                  4.  If "good":
                          a)  Move all the files in plugin to ~/good.
                          b)  Move half the files in ~/unknown to plugin.
                      If "bad":
                          a)  Move all the files in ~/unknown to ~/good.
                          b)  Move half the files in plugin to ~/unknown.
                  5.  Repeat from step 3 until one bad file remains in plugin.

              The convention in this group is to not top-post.  I have reformatted
              your reply accordingly.

              Regards,
              Gary

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.



              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            Your message has been successfully submitted and would be delivered to recipients shortly.