Loading ...
Sorry, an error occurred while loading the content.
 

Re: autoflow fails to add line break if word ends on line margin

Expand Messages
  • Eric Smith
    Thank John ... NO it does not. Output of :set in this case is; ... helplang=en noloadplugins scroll=25 textwidth=65 ttyfast
    Message 1 of 6 , Jul 25, 2013
      Thank John

      > John Little wrote on Thu-25-Jul 13 4:10AM
      > Does your problem occur with
      >
      > gvim -u NONE -c 'set fo=tcqa tw=65'
      NO it does not.

      Output of :set in this case is;

      --- Options ---
      helplang=en noloadplugins scroll=25 textwidth=65 ttyfast ttymouse=xterm
      fileencodings=ucs-bom,utf-8,default,latin1

      Here are my settings normally, where it does occur, any idea?

      --- Options ---
      autowrite incsearch shiftwidth=1 ttyfast
      backspace=2 laststatus=2 sidescroll=5 ttymouse=xterm
      columns=80 linebreak softtabstop=2 undofile
      expandtab nomodeline spell updatetime=300
      filetype=mail mouse=a syntax=mail winwidth=120
      helplang=en report=0 tabstop=3 nowritebackup
      hidden ruler textwidth=65
      history=300 scroll=25 ttimeout
      ignorecase scrolloff=3 ttimeoutlen=1
      cinkeys=0{,0},:,!^F,o,O,e
      cinoptions=>s,e0,n0,f0,{0,}0,^0,:s,=s,ps,t0,+s,(s,us,)20,*30,g0,+0,+0
      clipboard=autoselect,exclude:.*
      dictionary=/usr/dict/linux.words,/usr/local/doc/retailers.txt,/usr/local/doc/p
      roducers.txt,/usr/local/doc/main.txt,/usr/local/doc/transport.txt,/usr/local/doc
      /shipment.txt,/usr/local/doc/references.txt
      fileencoding=utf-8
      fileencodings=ucs-bom,utf-8,default,latin1
      formatoptions=tcqa
      grepprg=ack-grep -a
      include=^\s*#\s*nclude
      isfname=@,48-57,/,.,-,_,+,,,#,$,%,~,^=
      iskeyword=@,48-57,_,-,192,255,.,(,),#
      listchars=eol:$,precedes:<,extends:>



      --
      Eric Smith
      >
      > Regards, John Little
      >
      > --
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >
      > ---
      > You received this message because you are subscribed to the Google Groups "vim_use" group.
      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      > For more options, visit https://groups.google.com/groups/opt_out.
      >

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • John Little
      ... I set all those in a gvim -u NONE -N, and your problem didn t occur. The only one that I noticed was the file type, which suggests a file type plugin
      Message 2 of 6 , Jul 25, 2013
        On Thursday, July 25, 2013 10:09:11 PM UTC+12, Eric Smith wrote:
        > > Does your problem occur with
        > > gvim -u NONE -c 'set fo=tcqa tw=65'
        >
        > NO it does not.
        >
        > Here are my settings normally, where it does occur, any idea?
        > ...

        I set all those in a gvim -u NONE -N, and your problem didn't occur. The only one that I noticed was the file type, which suggests a file type plugin might be involved.

        All I can suggest is standard vim problem isolation:

        1. set nocompatible mode, a return to sanity:

        gvim -u NONE -N -c 'set fo=tcqa tw=65'

        2. Try with no plugins:

        gvim --noplugins -N -c 'set fo=tcqa tw=65' x

        If this avoids your problem, then a plugin is the culprit. If you use a plugin manager, it may have a method to track problems down, otherwise move them aside one by one till you find one that does it. The :scriptnames command can tell you everything that's running, or see :help plugin-details.

        3. Try no .gvimrc:

        gvim -U NONE -N

        or
        vim

        4. Bisect your .vimrc, by putting a finish command in it, and moving it back and forth till your problem is triggered just.

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.