Loading ...
Sorry, an error occurred while loading the content.

gVim converting Unix file Write To DOS Format

Expand Messages
  • octopusgrabbus
    I am using gVim version version 7.2.411 to remotely edit files on a Linux system from a Linux system. I have set fileformats=unix,dos in .vimrc as well as
    Message 1 of 7 , Jul 24, 2013
    • 0 Attachment
      I am using gVim version version 7.2.411 to remotely edit files on a Linux system from a Linux system. I have set

      fileformats=unix,dos

      in .vimrc as well as well as

      filetype plugin indent on

      The file reads in as Unix file format using

      :e ftp://user@system//home/csm/csmdev/recpt_rpt.4gl

      When I :w the file and then read it back in :e!, the format has changed to DOS file format.

      What can I do to correct this problem?

      Thanks.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tim Chase
      ... A couple ideas occur to me: 1) you have some plugin that is changing the ff setting. I d check what :set ff? to see what vim thinks the file should
      Message 2 of 7 , Jul 24, 2013
      • 0 Attachment
        On 2013-07-24 11:09, octopusgrabbus wrote:
        > I am using gVim version version 7.2.411 to remotely edit files on
        > a Linux system from a Linux system. I have set
        >
        > fileformats=unix,dos
        >
        > in .vimrc as well as well as
        >
        > filetype plugin indent on
        >
        > The file reads in as Unix file format using
        >
        > :e ftp://user@system//home/csm/csmdev/recpt_rpt.4gl
        >
        > When I :w the file and then read it back in :e!, the format has
        > changed to DOS file format.
        >
        > What can I do to correct this problem?

        A couple ideas occur to me:

        1) you have some plugin that is changing the 'ff' setting. I'd check
        what ":set ff?" to see what vim thinks the file should be written as.

        2) you should be able to force writing as Unix format with ":w
        ++ff=unix

        3) it's theoretically possible that FTP is transferring the file back
        up in ASCII rather than BIN mode. I don't mess around much with
        editing remote files, but if you write a copy of the file locally and
        it's Unix format, but becomes DOS after transferring it, I remember
        having FTP mung my newlines in the past.

        -tim


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • octopusgrabbus
        ... Thanks. I ll go look at sftp and see if that s it. I tried the :set ff? and it thinks it s Unix. -- -- You received this message from the vim_use
        Message 3 of 7 , Jul 24, 2013
        • 0 Attachment
          On Wednesday, July 24, 2013 2:09:19 PM UTC-4, octopusgrabbus wrote:
          > I am using gVim version version 7.2.411 to remotely edit files on a Linux system from a Linux system. I have set
          >
          > fileformats=unix,dos
          >
          > in .vimrc as well as well as
          >
          > filetype plugin indent on
          >
          > The file reads in as Unix file format using
          >
          > :e ftp://user@system//home/csm/csmdev/recpt_rpt.4gl
          >
          > When I :w the file and then read it back in :e!, the format has changed to DOS file format.
          >
          > What can I do to correct this problem?
          >
          > Thanks.

          Thanks. I'll go look at sftp and see if that's it. I tried the :set ff? and it thinks it's Unix.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • octopusgrabbus
          sftp.conf had ascii mangling commented out. I uncommented it and answered NO; and restarted the daemon, which probably amounted to the mangling directives
          Message 4 of 7 , Jul 24, 2013
          • 0 Attachment
            sftp.conf had ascii mangling commented out. I uncommented it and answered NO; and restarted the daemon, which probably amounted to the mangling directives being commented out.

            This appears to be a gVim problem, because command line ftp from one system does not cause the file type to be altered.

            Thanks again.

            On Wednesday, July 24, 2013 3:02:05 PM UTC-4, Tim Chase wrote:
            > On 2013-07-24 11:09, octopusgrabbus wrote:
            >
            > > I am using gVim version version 7.2.411 to remotely edit files on
            >
            > > a Linux system from a Linux system. I have set
            >
            > >
            >
            > > fileformats=unix,dos
            >
            > >
            >
            > > in .vimrc as well as well as
            >
            > >
            >
            > > filetype plugin indent on
            >
            > >
            >
            > > The file reads in as Unix file format using
            >
            > >
            >
            > > :e ftp://user@system//home/csm/csmdev/recpt_rpt.4gl
            >
            > >
            >
            > > When I :w the file and then read it back in :e!, the format has
            >
            > > changed to DOS file format.
            >
            > >
            >
            > > What can I do to correct this problem?
            >
            >
            >
            > A couple ideas occur to me:
            >
            >
            >
            > 1) you have some plugin that is changing the 'ff' setting. I'd check
            >
            > what ":set ff?" to see what vim thinks the file should be written as.
            >
            >
            >
            > 2) you should be able to force writing as Unix format with ":w
            >
            > ++ff=unix
            >
            >
            >
            > 3) it's theoretically possible that FTP is transferring the file back
            >
            > up in ASCII rather than BIN mode. I don't mess around much with
            >
            > editing remote files, but if you write a copy of the file locally and
            >
            > it's Unix format, but becomes DOS after transferring it, I remember
            >
            > having FTP mung my newlines in the past.
            >
            >
            >
            > -tim

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • octopusgrabbus
            ... I ve done more testing, and this occurs on both command line and gvim. -- -- You received this message from the vim_use maillist. Do not top-post! Type
            Message 5 of 7 , Jul 25, 2013
            • 0 Attachment
              On Wednesday, July 24, 2013 3:02:05 PM UTC-4, Tim Chase wrote:
              > On 2013-07-24 11:09, octopusgrabbus wrote:
              >
              > > I am using gVim version version 7.2.411 to remotely edit files on
              >
              > > a Linux system from a Linux system. I have set
              >
              > >
              >
              > > fileformats=unix,dos
              >
              > >
              >
              > > in .vimrc as well as well as
              >
              > >
              >
              > > filetype plugin indent on
              >
              > >
              >
              > > The file reads in as Unix file format using
              >
              > >
              >
              > > :e ftp://user@system//home/csm/csmdev/recpt_rpt.4gl
              >
              > >
              >
              > > When I :w the file and then read it back in :e!, the format has
              >
              > > changed to DOS file format.
              >
              > >
              >
              > > What can I do to correct this problem?
              >
              >
              >
              > A couple ideas occur to me:
              >
              >
              >
              > 1) you have some plugin that is changing the 'ff' setting. I'd check
              >
              > what ":set ff?" to see what vim thinks the file should be written as.
              >
              >
              >
              > 2) you should be able to force writing as Unix format with ":w
              >
              > ++ff=unix
              >
              >
              >
              > 3) it's theoretically possible that FTP is transferring the file back
              >
              > up in ASCII rather than BIN mode. I don't mess around much with
              >
              > editing remote files, but if you write a copy of the file locally and
              >
              > it's Unix format, but becomes DOS after transferring it, I remember
              >
              > having FTP mung my newlines in the past.
              >
              >
              >
              > -tim

              I've done more testing, and this occurs on both command line and gvim.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • octopusgrabbus
              This is solved by building and using 7.4a BETA. I do not believe this was due to .vimrc directives. -- -- You received this message from the vim_use
              Message 6 of 7 , Jul 29, 2013
              • 0 Attachment
                This is solved by building and using 7.4a BETA. I do not believe this was due to .vimrc directives.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Charles Campbell
                ... Great! I was mystified about why it was occurring -- and given the problem with debugging via Decho, hadn t figured out how to proceed. Regards, C
                Message 7 of 7 , Jul 29, 2013
                • 0 Attachment
                  octopusgrabbus wrote:
                  > This is solved by building and using 7.4a BETA. I do not believe this was due to .vimrc directives.
                  >
                  Great! I was mystified about why it was occurring -- and given the
                  problem with debugging via Decho, hadn't figured out how to proceed.

                  Regards,
                  C Campbell

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.