Loading ...
Sorry, an error occurred while loading the content.

vim + tmux

Expand Messages
  • Claus Atzenbeck
    Hi all: I m using Vim 7.3 in combination with tmux 1.8 on Mac OS 10.8.4. Vim shows a strange behavior on tmux s vertically split windows. For example, when
    Message 1 of 3 , Jul 23, 2013
    • 0 Attachment
      Hi all:

      I'm using Vim 7.3 in combination with tmux 1.8 on Mac OS 10.8.4.

      Vim shows a strange behavior on tmux's vertically split windows. For
      example, when deleting a couple of lines, I receive the message

      6 fewer lines
      Press ENTER or type command to continue

      Why does Vim ask me to press enter?

      This only happens in tmux *vertical* split windows. -- It does *not*
      happen in horizontally split windows or in not split windows.

      Based to which rules does Vim ask to press enter? Is there a config
      option to suppress that?

      Thanks for any hint.

      Claus

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Shawn Wilson
      set winminwidth=0 Sent from my android device. ... From: Claus Atzenbeck To: vim_use Sent: Tue, 23 Jul
      Message 2 of 3 , Jul 23, 2013
      • 0 Attachment
        set winminwidth=0

        Sent from my android device.

        -----Original Message-----
        From: Claus Atzenbeck <claus.atzenbeck@...>
        To: vim_use <vim_use@...>
        Sent: Tue, 23 Jul 2013 5:11
        Subject: vim + tmux

        Hi all:

        I'm using Vim 7.3 in combination with tmux 1.8 on Mac OS 10.8.4.

        Vim shows a strange behavior on tmux's vertically split windows. For
        example, when deleting a couple of lines, I receive the message

             6 fewer lines
             Press ENTER or type command to continue

        Why does Vim ask me to press enter?

        This only happens in tmux *vertical* split windows. -- It does *not*
        happen in horizontally split windows or in not split windows.

        Based to which rules does Vim ask to press enter? Is there a config
        option to suppress that?

        Thanks for any hint.

        Claus

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Claus Atzenbeck
        ... Thanks, Shawn. This was not the solution, however, it helped me to find the right way. The issue was that due to tmux s vertical split Vim s command line
        Message 3 of 3 , Jul 23, 2013
        • 0 Attachment
          On Tue, 23 Jul 2013 at 7:21am -0400, Shawn Wilson wrote:

          > set winminwidth=0

          Thanks, Shawn. This was not the solution, however, it helped me to find
          the right way. The issue was that due to tmux's vertical split Vim's
          command line width became too narrow, as my rulerformat shows quite some
          information. This was why Vim issued the "Press ENTER or type command to
          continue" notice.

          I was able to solve the issue in two ways:

          set cmdheight=2

          Or to narrow the width defined in the ruler format:

          set rulerformat=%74 ...

          (instead of originally "set rulerformat=%100 ...").

          Best,
          Claus

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.