Loading ...
Sorry, an error occurred while loading the content.
 

Re: Bug in opening partial path on windows (using '/' instead of '\'

Expand Messages
  • Linda W
    ... That works, but besides being a pain to type every time, it seems to come up with no mods... ;-| Eto...um...so what does that say? ;-) simplified the test
    Message 1 of 4 , Jul 21, 2013
      Ben Fritz wrote:
      > I've never seen that problem, and I use shellslash in my config.
      > Does it work with launching Vim as follows?
      >
      > gvim -N -u NONE -U NONE -i NONE --cmd "set shellslash" fb17X/content/firebug/chrome.js
      >
      > I know that the 'shellslash' option can make shellescape() do bad things on Windows, and it makes paths copied from Vim or passed to shell commands sometimes fail, but I don't know of any other ill effects.
      >
      >
      That works, but besides being a pain to type every time,
      it seems to come up with no mods... ;-|

      Eto...um...so what does that say? ;-)

      simplified the test case BTW to creating a tmp dir in my home dir and
      saying "gvim tmp/remake".



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Exactly. It s a command to launch Vim without any plugins or customizations, and then apply the shellslash option. The intent is to figure out whether
      Message 2 of 4 , Jul 28, 2013
        On Sunday, July 21, 2013 12:25:05 PM UTC-5, Linda W wrote:
        > Ben Fritz wrote:
        >
        > > I've never seen that problem, and I use shellslash in my config.
        >
        > > Does it work with launching Vim as follows?
        >
        > >
        >
        > > gvim -N -u NONE -U NONE -i NONE --cmd "set shellslash" fb17X/content/firebug/chrome.js
        >
        > >
        >
        >
        > That works, but besides being a pain to type every time,
        >
        > it seems to come up with no mods... ;-|
        >
        >

        Exactly. It's a command to launch Vim without any plugins or customizations, and then apply the "shellslash" option. The intent is to figure out whether your problem is a problem with Vim or with your config.

        Since it worked as intended when launching Vim that way, then probably you have a plugin or setting in your .vimrc interfering.

        Now you can try:

        gvim -N --noplugin -i NONE fb17X/content/firebug/chrome.js

        This will show you what Vim does with your .vimrc but without your plugins.

        Then:

        gvim -N -u NORC -i NONE fb17X/content/firebug/chrome.js

        will show you what Vim does with your plugins but without your .vimrc.

        Once you find out which portion of your config is at fault, you'll need to start selectively disabling parts of that config until you find the culprit.

        See http://vim.wikia.com/wiki/Troubleshooting

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.