Loading ...
Sorry, an error occurred while loading the content.

A small feature request for Vim 7.4

Expand Messages
  • Aggelos Kolaitis
    I m using Vim version 7.3. ... I move the cursor the first f , enter visual block mode with Ctrl-V and do a 2j to move to t of third. This, however,
    Message 1 of 5 , Jul 15, 2013
    • 0 Attachment
      I'm using Vim version 7.3.

      When in visual block mode, once I have chosen a one-line column, the last char has not been highlighted. For example consider the following text:

      | first
      | second
      | third

      I move the cursor the first 'f', enter visual block mode with 'Ctrl-V' and do a '2j' to move to 't' of third.

      This, however, will only highlight 'f' and 's' (the first characters from the first and second lines). This wasn't a problem when my terminal used a block for its cursor ( [] ), which was something that highlighted the final line.

      Recently I switched to and underline character ( _ ) for cursor, and now that makes me a little dizzy trying to figure out the portion selected. Could it be the 7.4 version ( or a quick patch for 7.3 ) that would also highlight the last character?? I hope the example was useful to understand the 'issue'.

      Thanks...

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Marcin Szamotulski
      ... The visual block mode selects in your case selects only one column: and the selected letters are f,s and t. Every one is the first and last in its row.
      Message 2 of 5 , Jul 15, 2013
      • 0 Attachment
        On 07:26 Mon 15 Jul , Aggelos Kolaitis wrote:
        > I'm using Vim version 7.3.
        >
        > When in visual block mode, once I have chosen a one-line column, the last char has not been highlighted. For example consider the following text:
        >
        > | first
        > | second
        > | third
        >
        > I move the cursor the first 'f', enter visual block mode with 'Ctrl-V' and do a '2j' to move to 't' of third.
        >
        > This, however, will only highlight 'f' and 's' (the first characters from the first and second lines). This wasn't a problem when my terminal used a block for its cursor ( [] ), which was something that highlighted the final line.
        >
        > Recently I switched to and underline character ( _ ) for cursor, and now that makes me a little dizzy trying to figure out the portion selected. Could it be the 7.4 version ( or a quick patch for 7.3 ) that would also highlight the last character?? I hope the example was useful to understand the 'issue'.
        >
        > Thanks...
        >

        The visual block mode selects in your case selects only one column: and
        the selected letters are f,s and t. Every one is the first and last in
        its row. What do you mean by showing also the last character?

        As a workaround in your case I'd rather suggest changing the cursor shape
        in visual selection mode. I think it is possible though I don't have an
        example how to do that at hand.

        Regards,
        Marcin

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Nicolas Dermine
        ... Hi, for what it s worth when I try and reproduce your steps on the same text (Ctrl+V 2j starting on f ), the letters f , s and t are highlighted. I
        Message 3 of 5 , Jul 15, 2013
        • 0 Attachment



          On Mon, Jul 15, 2013 at 4:26 PM, Aggelos Kolaitis <neoaggelos@...> wrote:
          I'm using Vim version 7.3.

          When in visual block mode, once I have chosen a one-line column, the last char has not been highlighted. For example consider the following text:

          |   first
          |   second
          |   third

          I move the cursor the first 'f', enter visual block mode with 'Ctrl-V' and do a '2j' to move to 't' of third.

          This, however, will only highlight 'f' and 's' (the first characters from the first and second lines). This wasn't a problem when my terminal used a block for its cursor ( [] ), which was something that highlighted the final line.

          Recently I switched to and underline character ( _ ) for cursor, and now that makes me a little dizzy trying to figure out the portion selected. Could it be the 7.4 version ( or a quick patch for 7.3 ) that would also highlight the last character?? I hope the example was useful to understand the 'issue'.

          Thanks...

          Hi,

          for what it's worth when I try and reproduce your steps on the same text (Ctrl+V 2j starting on 'f'), the letters 'f', 's' and 't' are highlighted.
          I tried with colorscheme koehler and default, Vim 7.3 on windows 7.

          Nicolas




           

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Aggelos Kolaitis
          ... Yeah, but what is your cursor s shape ??? If it is a block character ( [] ), then everything is highlighted, (the cursor highlights the `t` in our
          Message 4 of 5 , Jul 15, 2013
          • 0 Attachment
            On Monday, July 15, 2013 7:19:09 PM UTC+3, Nicolas Dermine wrote:
            > On Mon, Jul 15, 2013 at 4:26 PM, Aggelos Kolaitis <neoag...@...> wrote:
            >
            > I'm using Vim version 7.3.
            >
            >
            >
            > When in visual block mode, once I have chosen a one-line column, the last char has not been highlighted. For example consider the following text:
            >
            >
            >
            > |   first
            >
            > |   second
            >
            > |   third
            >
            >
            >
            > I move the cursor the first 'f', enter visual block mode with 'Ctrl-V' and do a '2j' to move to 't' of third.
            >
            >
            >
            > This, however, will only highlight 'f' and 's' (the first characters from the first and second lines). This wasn't a problem when my terminal used a block for its cursor ( [] ), which was something that highlighted the final line.
            >
            >
            >
            >
            > Recently I switched to and underline character ( _ ) for cursor, and now that makes me a little dizzy trying to figure out the portion selected. Could it be the 7.4 version ( or a quick patch for 7.3 ) that would also highlight the last character?? I hope the example was useful to understand the 'issue'.
            >
            >
            >
            >
            > Thanks...
            >
            >
            >
            > Hi,
            >
            >
            > for what it's worth when I try and reproduce your steps on the same text (Ctrl+V 2j starting on 'f'), the letters 'f', 's' and 't' are highlighted.
            >
            > I tried with colorscheme koehler and default, Vim 7.3 on windows 7.
            >
            >
            > Nicolas
            >
            >
            >
            >
            >
            >
            >
            >
            >  
            >
            >
            >
            > --
            >
            > --
            >
            > You received this message from the "vim_use" maillist.
            >
            > Do not top-post! Type your reply below the text you are replying to.
            >
            > For more information, visit http://www.vim.org/maillist.php
            >
            >
            >
            > ---
            >
            > You received this message because you are subscribed to the Google Groups "vim_use" group.
            >
            > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+u...@....
            >
            > For more options, visit https://groups.google.com/groups/opt_out.

            Yeah, but what is your cursor's shape ??? If it is a ''block character''( [] ), then everything is highlighted, (the cursor highlights the `t` in our exaple. But with the underline character (_) as cursor, this does not happen.

            The main issue is that vim, when highlighting a visual selection, it highlights everything but the current cursor position. That is okay with some cursors, since they take care of highlighting the current position, but not for all (e.g. my example with the underline `_' character).

            So, is it possible to allow vim to highlight the current position too ? And if it breaks some things ( e.g. cursor cannot be found because the blink is not shown, at least have an option somewhere to switching this behaviour on/off.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Paul Isambert
            ... I use gVim (like Nicolas, I suppose, since he mentionned Windows), and there the last character is properly highlighted. However, in console Vim the last
            Message 5 of 5 , Jul 16, 2013
            • 0 Attachment
              Aggelos Kolaitis <neoaggelos@...> a écrit:
              > On Monday, July 15, 2013 7:19:09 PM UTC+3, Nicolas Dermine wrote:
              > > > On Mon, Jul 15, 2013 at 4:26 PM, Aggelos Kolaitis <neoag...@...> wrote:
              > > >
              > > > I'm using Vim version 7.3.
              > > >
              > > > When in visual block mode, once I have chosen a one-line column, the last char has not been highlighted. For example consider the following text:
              > > >
              > > > |   first
              > > > |   second
              > > > |   third
              > > >
              > > > I move the cursor the first 'f', enter visual block mode with 'Ctrl-V' and do a '2j' to move to 't' of third.
              > > >
              > > > This, however, will only highlight 'f' and 's' (the first characters from
              > > > the first and second lines). This wasn't a problem when my terminal used a
              > > > block for its cursor ( [] ), which was something that highlighted the final
              > > > line.
              > > >
              > > > Recently I switched to and underline character ( _ ) for cursor, and now
              > > > that makes me a little dizzy trying to figure out the portion selected. Could
              > > > it be the 7.4 version ( or a quick patch for 7.3 ) that would also highlight
              > > > the last character?? I hope the example was useful to understand the 'issue'.
              > > >
              > > > Thanks...
              > >
              > > Hi,
              > >
              > > for what it's worth when I try and reproduce your steps on the same text (Ctrl+V 2j starting on 'f'), the letters 'f', 's' and 't' are highlighted.
              > > I tried with colorscheme koehler and default, Vim 7.3 on windows 7.
              >
              >
              > Nicolas
              > Yeah, but what is your cursor's shape ??? If it is a ''block character''( [] ), then everything is highlighted, (the cursor highlights the `t` in our exaple. But with the underline character (_) as cursor, this does not happen.
              >
              > The main issue is that vim, when highlighting a visual selection, it highlights everything but the current cursor position. That is okay with some cursors, since they take care of highlighting the current position, but not for all (e.g. my example with the underline `_' character).
              >
              > So, is it possible to allow vim to highlight the current position too ? And if it breaks some things ( e.g. cursor cannot be found because the blink is not shown, at least have an option somewhere to switching this behaviour on/off.

              I use gVim (like Nicolas, I suppose, since he mentionned Windows), and
              there the last character is properly highlighted. However, in console
              Vim the last character is indeed left unhighlighted. I don’t know
              which behavior is the right one, but it seems inconsistent and should
              probably be fixed.

              Best,
              Paul

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            Your message has been successfully submitted and would be delivered to recipients shortly.